Full Version: XBian on Raspberry Pi don't show iTunes Trailer only Audio
You're currently viewing a stripped down version of our content. View the full version with proper formatting.

since yesterday I have XBian on my Raspberry Pi. Nearly everything is working fine.
I can use the Airplay function to stream YouTube video but when I start a trailer in iTunes on my iPad, I have only audio and no video. On my iPad the video app is telling me the video will be shown on the XBian. All seems to be ok but no video.

What settings are missing to have also the video from iTunes with AirPlay running well or is there a licenses issue?

Best regards
You need to deduce what sort of video format the file is. Use something like Gspot on Windoze to tell you this.

If it is MPEG1 you will need a license, if any of the other iTunes formats .mov or mp4 it should be fine.

Try copying the file to a USB drive and see if it plays then.

Also look at the output in .xbmc/temp/xbmc.log and see if there are any errors. If so post a little of the output here.
MPEG2 and VC-1 are the ones which needed the codec licences
To find out which codec is using, press O on keyboard or info (ususaly) on remote to evoke a little debuge on screen

edit: little exlanation what is what

Quote:D() is demuxer data, first line is audio second line is video (most often some info about what type of data it contains)
P() is video/audio player data
C() is global player data
W() is presenter data.

aq/vq: is how full the queue of to be decoded samples of audio/video
dc: is currently used video decoder
drop: is how many frames video player have needed to drop to keep audio/video sync
a/v: is how is the sync between audio/video currently
ad: is explict set delay of audio compared to video
acpu/vcpu/dcpu: is audio/video/demuxer threads current cpu usage
edl: is is there a Edit Decicion List currently active

elupus -Team-XBMC Developer

sorry but I'm not able to press o on my keyboard due to I use XBian on my RPi without keyboard.
But I use the App xbmcRemote and also tried info and o without success.

The only one I know now, is that the video format is m4v. I see the filename in XBian.

I purchased the licenses MPG2 and VC1. Maybe this is the solution.

I also brought a video and tried it without success. When the movie starts the AirPlay icon disappear. Why?

I hope that both licenses will give my the video. But normally MPG2 and VC1 is not m4v and m4v should work.

Further more I read an article in which the told that m4v is not support due to license requirements.

Do have any orther ideas. Here are the link with comment.

in the case of .m4v you are out of luck here thanks to your fruit product maker as this files are under DRM copy protection.
I dont think so you will ever make it working on RPi

Wiki - m4v
can you please edit your post and remove your log
use pastebin as mentioned under rules or at least CODE TAG
The reason why your iTunes trailer is missing is that your iTunes movies purchased and rented from iTunes are encrypted by FairPlay DRM technology. SO bad news. If you want to do other thing with these iTunes trailers, you need to remove DRM from iTunes with the help of M4V Converter. Hope it works with you!
this is because iTunes videos are DRM protection, what you need to do is removing DRM from iTunes videos. i always use iTunes M4V Converter to help me to convert, it is a software designed by DRmare, i think it works better. If necessary, you could take a try of it.
Reference URL's