Full Version: Should /run/rpcbind be owned by xbian
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I was having hard time to mount a nfs share to my xbian

Raspberry Pi, 512 MB (though reported 376 BM by system??)

Xbian 1.0Beta1.1

uname -a
Linux xbian 3.9.8+ #2 PREEMPT Tue Jul 2 17:38:12 CEST 2013 armv6l GNU/Linux

The mount command:
sudo mount -t nfs /media/MyBookLive

The error output was:

mount.nfs: rpc.statd is not running but is required for remote locking.
mount.nfs: Either use '-o nolock' to keep locks local, or start statd.
mount.nfs: an incorrect mount option was specified

I edited the /etc/default/nfs-common conf file, but the problem persissted. nsf-common refused to start anyway, because
[warn] Not starting: portmapper is not running ... (warning).

After some fiddling, it turned out that

is owned by xbian, not by root. I changed ownership and the service started and i managed to mount.
My question is this a bug, or this intended design and I am missing the point how to use the start the service here?

/run is recreated on each boot from scratch. when you was doing your best to mount nfs, you probably started rpcbind process manually under xbian user (or mount - which tried to launch rpcbind via helper mount.nfs). then the run directory was of course created with ownership xbian.

to setup properly, check your /etc/default/nfs-common that NEED_STATD is not "no" if you use NFS(2,3) (what was beta1 bug), then as root (or under xbian with sudo) run:

insserv -f rpcbind
insserv -f nfs-common


btw: the memory is ok, 512mb is total ram. GPU has no dedicated memory and is shared with main. by default it is set to be 128MB (for GPU).
Thank you.
I was just looking for a way to start up the services on each boot, and was was planning to see if I update-rc.d will do this for me. insserv seems to be an elegant answer Wink
Thank you, case is solved!
Reference URL's