Full Version: Samba not sharing external USB drive
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hi there,

I'm having a problem with SMB and I'm having some trouble figuring it out. Here's the deal:

XBian version: 1.0Beta2
XBMC version:12.2
Overclock settings: default

Power supply rating: ?
RPi model (B 512mb):
SD card size and make/type: 8 GB (from Rpi)
Network (wireless or LAN): LAN
Connected devices (TV, USB, network storage, etc.): 2 USB Drives

Didn't see anything relevant in xbmc log

Problem description:

I have two USB drives connected to the RPi through a powered USB hub. Lets call them DiskA and DiskB. For some time, everything has been working fine. They both get automounted, and automatically shared with the auto share feature in Xbian. In my library, the source folders are set with the smb addresses because I have shared libraries with mysql.
Recently, for some reason XBMC could not find media files in diskB. I later noticed the diskB wasn't available in the previous smb address. Usually the shared addresses were:


Now the weird thing is, I have only one

and within diskA I can find a folder called DiskB with everything from DiskB inside it. Like this


So, I turned the RPi off, Disconected DiskA and started it only with DiskB connected.
What happens is that It gets auto mounted but doesn't get shared. In log.smbd, I get a warning like
WARNING: No path in service DiskB - making it unavailable!

Since XBMC is looking for a network address that doesn't exist, it can't find any of my files...

So, any ideas how this happened, and how can I get arround it?

Thanks for your time.
Just an update on something I tried.

Tried editing the shares.conf file in /etc/samba and added a section to share the DiskB drive. Rebooted (tried restarting samba only but it did nothing) and the drive got shared without any problems.
Obviously, I want to use the auto share feature, and not an explicit share, so I commented out that same section, rebooted again, and back to the same problem.

I'm no expert here, but It looks like the auto share feature is trying to share the DiskB in a folder inside the DiskA, but since I currently have the DiskA disconnected, it fails to share... That's just my guess...

Any comments on this?

can you provide

sudo net conf list

exactly at the time when the shares are mixed up? it was reported already by one user, unfortunately we could not pin point the issue.
what XBian version you run and what is version of packages?

dpkg-query -W xbian-\*
Hi. Sorry for the delay. I've been away for a while.

Here's the net conf list
        browseable = yes
        write list = xbian
        force user = xbian

        path = /media/Joao1TBs
        guest ok = yes
        read only = no
        write list = xbian
        force user = xbian
        browseable = yes

        path = /xbmc-backup
        read only = no
        guest ok = yes
        force user = root
        browseable = yes

ANd the package versions

xbian-package-cec       1.1-0.4
xbian-package-config-shell      2.1.6-51a
xbian-package-config-xbmc       1.1.4-3
xbian-package-couchpotato       2.0.7
xbian-package-firmware  1.4.14-0
xbian-package-initramfs-tools   1.3.1-5b
xbian-package-kernel    1.3-5.5
xbian-package-libshairport      1.0-1
xbian-package-libtag    1.0-2
xbian-package-lirc      1.4-8.8
xbian-package-samba     2.0.0-4
xbian-package-shairplay 1.0.2-1
xbian-package-sickbeard-tpb     1.1
xbian-package-splash    2.0.2-6
xbian-package-transmission      2.82
xbian-package-upstart-xbmc-bridge       1.1.1-3
xbian-package-usbmount  1.0.5-5
xbian-package-vnc-server        1.0.4
xbian-package-xbmc      2.9-10.20
xbian-package-xbmc-scripts      1.0.5-11
xbian-package-zram-swap 1.0.5
xbian-update    1.0.2-8e

Hope it helps pin pointing the issue.
I've been using that workaround in the shares.conf file but it would be great to get this fixed.

i have a simialr situation... my external USB shared to Samba just fine then I upgraded andI cant see it on the network any more ...any help?

if you (on the fly while RPI running) remove USB disk and plug it in again, will the share re-appear ?

if yes, edit please /etc/usbmount/mount.d/00-clean , put "set -x" as 2nd line and reboot. then after all started and USB disk again mounted, send me /var/log/upstart/openbsd-inet.log

please use git issue tracker for this
Reference URL's