Full Version: Xbian won't pull IP address on wireless
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Xbian won't pull an IP address. I can't figure out why because it's worked for months. Now even reboots won't help. I've tried connecting to the network again but it just hangs. The network strength is good. How do I fix this?
Please explain what you are trying to do, and what you have tried so far.
(6th May, 2014 02:29 AM)IriDium Wrote: [ -> ]Please explain what you are trying to do, and what you have tried so far.

I've configured the wireless for DHCP. Three different USB wifi adapters have been tried with the same results. It seems to be fixed now by removing the extension cable between the port and the adapter.
just got idea

try installing isc-dhcp-client

sudo -i
apt-get install isc-dhcp-client
I just came over this thread and got the same problem.

I already posted it in the RC3 thread, but maybe I should continue right here for a better overview.

(25th Sep, 2014 06:11 PM)josch Wrote: [ -> ][...]

Again, I can scan for wireless networks and also do find my router. But the connection test afterwards
never ends and wlan0 won't get a IP. It just keeps saying "Please wait. Trying to connect to Router".

Here are the outputs from iwconfig and ifconfig:
xbian@xbian ~ $ sudo iwconfig
wlan0     IEEE 802.11bgn  ESSID:"Router"
          Mode:Managed  Frequency:2.427 GHz  Access Point: 1C:C6:3C:42:EE:DA
          Bit Rate=72.2 Mb/s   Tx-Power=20 dBm
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality=70/70  Signal level=-38 dBm
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:97   Missed beacon:0

dummy0    no wireless extensions.

lo        no wireless extensions.

eth0      no wireless extensions.

xbian@xbian ~ $ sudo ifconfig
eth0      Link encap:Ethernet  HWaddr b8:27:eb:d7:c1:0c
          inet addr:  Bcast:  Mask:
          RX packets:372 errors:0 dropped:0 overruns:0 frame:0
          TX packets:307 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:34826 (34.0 KiB)  TX bytes:46419 (45.3 KiB)

lo        Link encap:Local Loopback
          inet addr:  Mask:
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:42 errors:0 dropped:0 overruns:0 frame:0
          TX packets:42 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:2477 (2.4 KiB)  TX bytes:2477 (2.4 KiB)

wlan0     Link encap:Ethernet  HWaddr d8:5d:4c:98:eb:7a
          RX packets:13 errors:0 dropped:0 overruns:0 frame:0
          TX packets:9 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:1134 (1.1 KiB)  TX bytes:2822 (2.7 KiB)

So, it looks like it's connected to "Router" but it won't get any IP. Huh
As I said, in RC2 wifi is working fine.

Would be really nice if someone could support me to get my wifi working with RC3.
Thank you very much!

xbian@xbian ~ $ lsusb
Bus 001 Device 007: ID 0cf3:9271 Atheros Communications, Inc. AR9271 802.11n

xbian@xbian ~ $ lsmod
Module                  Size  Used by
ath9k_htc              46756  0
ath9k_common            7047  1 ath9k_htc
ath9k_hw              387652  2 ath9k_common,ath9k_htc
ath                    17332  3 ath9k_common,ath9k_htc,ath9k_hw
mac80211              293146  1 ath9k_htc
cfg80211              172442  4 ath,ath9k_common,mac80211,ath9k_htc
led_class               2669  1 ath9k_htc

It's a fully updated (today) RC3 and isc-dhcp-client is already the newest version.

Can I deliver any logs or something to help facing the problem?

Cheers Smile
Can you try the new RC3 image?
Unfortunately it didn't help for my problem. It's still the same as before.

Any more ideas?
So you reïnstalled the one from 2 hours ago?
Yes, I've tried it with a fresh install from xbian-image-rpi-20140925.img

Changed nothing, just booted it and tried to setup wifi.
I'm pretty sure it was what you've meant Big Grin

It's the one from 15:10:59 UTC: XBian_1.0_RC_3_Raspberry_Pi.img.gz
And the gz contains: xbian-image-rpi-20140925.img
Those files are still not the same. We've been working on that file the whole day. You can check the md5sums yourself.
It was the latest one when I was downloading it from sourceforge right before my post.
But yap - now there was a new one and I tried it with it too -> still the same problem.
But I organized another wifi stick and now it's working very well!

Thank you much CurlyMo, mk01 and others from the team!
Reference URL's