Full Version: stuck on boot, no SSH available
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2 3
So this afternoon I decided it was high time to update all my xbian packages, and I did so through the XBMC settings interface.
All worked OK.

When I restarted I found my remote was not working correctly, only giving up, down, left, right.

So after a number of re-starts, I found this thread:

Which lead me to this thread:
I promptly read through the lot and followed the instructions on the first post.

but also at the end I rebooted.
When the XBIAN started to reboot, it froze on the first instance of a character which is an underscore I believe, or it might be a dash, not really relevant I guess.
Anyway, a number of power downs and ups, and im still getting the same thing.

Tried to SSH in through putty, but im getting timed out.

Please tell me I can fix this without re-installing the whole thing again, that would be painful!!
Any help would be greatly appreciated.


hmm come to think of it, I don't think I did the last set of commands right
# service lirc restart
# service xbmc restart

I think i left the # in when i pasted the code in one at a time, so the services never restarted prior to doing a reboot.

OH, also I forgot to mention im running xbian from USB instead of the SD card.
You can use telnet to debug when ssh isn't running.
It's not that SSH isn't working, The Pi just isn't able to actually boot at all.
It freezes as it's booting.

I'll have a go at telnet, but im not really sure how it works.
If you use putt, the same. Use tick telnet instead of ssh.
OK tried it, but with no luck. I get a time out still
I've tried reading the USB and SD through my PC.
SD card is fine.
When I plug the USB in, I get told I need to format the disk. I can't remember If it's possible to read the USB or not?
Or maybe the USB stick is corrupt?

OK, im almost certain it's my USB stick that has been corrupted some how.
I have installed Paragon ExtFS and Ext2Fsd-0.52. Neither software will open the drive, I keep getting the "You need to format the disk in blah blah blah...." alert.

Anyway, I guess I need to format my USB. To boot from my SD card again, do I just change the cmdline.txt from "root=/dev/sda1"back to "root=/dev/mmcblk0p2", then run through the process again?

Should I do an apt get/update and upgrade before installing to the USB? I guess it probably doesn't matter as XBMC will only run from the USB anyway.

Is there anyway I can recover all my XBMC files from my USB? I may be able to recover some of the data from it using "getdataback" maybe.
XBian uses BTRFS so you need to use a ubuntu livecd to recover files from it.
currently apt-get upgrade makes xbian un-bootable. Not sure which package is responsible, the upgrade appears to work without errors, but doing a reboot after results in the exact issue the parent poster is having (failure to mount the image and boot)
I thought there must be something like that going on.
Is anybody working on a fix?
Please figure out what package is causing it works or else it will be a long shot.
@all Please post config.txt and cmdline.txt

If config.txt contains initramfs ..... try commenting it out with # and rebooting

@geekness You shout still be able to "See" /boot on your USB stick. How did you create the bootable USB drive?
Apologies for hi-jacking this thread but I'm experiencing the same issue.

Got a message to do a reboot because of an update and now my PI is sat with a black screen and a cursor in the top left of the screen, only difference between my install and geekness is that mine is running totally from the SD card.

Tried commenting out the initramfs as discussed previously, but that's not helped either. It's been working fine until this update!

I've been running the PI and Xbian since June 2013 with this configuration with no problems until now! :-)

XBian version: Beta 2
XBMC version: Unknown
Overclock settings: Unknown

Power supply rating: Default that came with the device
RPi model (model A/B 256mb/512mb): B/513mb
SD card size and make/type: 8gb
Network (wireless or LAN): LAN
Connected devices (TV, USB, network storage, etc.): HDMI CEC enabled TV, USB Powered HUB with 3 Western Digital 1TB My Passport drives attached
Do these changes in the /boot/cmdline.txt
1. Remove quit
2. Set loglevel=2
3. Add debug
the cursor thing is 99% lockup on loader overwriting memory already used by for instance kernel with initramfs -> so bad thing.

for years 0x0a0000 as memory address was working. then condition changed and 0x0a00000 was working. last update is changing to 0x1000000 .

removing initramfs to test should confirm or not. just keep in mind that initramfs might be needed to BOOT from USB media (might / might not). that means remove "initramfs" line only in case you boot from SD - so we are sure kernel MUST be able to boot without it (so we are really checking the initramfs loading memory address issue).

Thanks for the help on this, for me removing the initramfs line (by adding a # before it) didn't help. However I noticed when I placed my SD card into my Windows PC I got the error message asking if I wanted to scan and fix removable disk, normally I wouldn't do this, however this time I did. Placed the SD card back into the PI and it booted.

The system then went into a continuous loop of trying to boot Xbian, however having SSH access I followed the advice in this thread and kept updating until it booted.

Thankfully it's now working and I can get into the system and use, however my next issue is that my 3 Western Digital 1TB drives are not showing up under the SMB shares, but that's another story and another forum thread! :-)

Hope this helps someone else out and hope Geekness gets his sorted too.

Pages: 1 2 3
Reference URL's