Full Version: update-rc.d: /etc/init.d/watchdog: file does not exist
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
i tried to configure watchdog but it seems that there was no init file for watchdog so that the service will start
i tried to reinstall watchdog but
this error appeard

update-rc.d: /etc/init.d/watchdog: file does not exist
dpkg: error processing watchdog (--configure):
subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1

i'm on XBian v1.0RC3

i need watchdog because my raspberry pi randomly freezes
Did you update from RC2? This is a known issue with older images.

By reinstalling you mean "apt-get install --reinstall"? In that case, it doesn't work: you'd need to remove and then install it again (I had the same issue a few months ago):
sudo apt-get remove --purge watchdog
sudo apt-get install watchdog
yes i installed rc2 first and then upgraded
and your suggestion fixed my problem thanks Smile
Reference URL's