Full Version: Getting ALSA to work???
You're currently viewing a stripped down version of our content. View the full version with proper formatting.

I have spent all afternoon trying to do this with no success. RC3 XBMC 13.2 ....My set-up is in my user profile and I have checked the wiki.

I have tried to add alsa so as to be able to use the I2S for an external DAC.

At first I got errors about dependencies on alsa-utils and alsa-base. I installed these as per instructions on a thread in the forum here.

Now via SSH in xbian-config I see alsa available as an upgrade, so I select it and it appears to install successfully (no error or warning messages). Then reboot.

After reboot there's nothing in the system menu to select alsa output (just analog and hdmi) and when I go back into SSH xbian-config, alsa is still there as an available upgrade! - I have gone in this circle 13 times now!!! - I have also tried installing via the XBMC xbian update menu, with the same result (I guess its just a different front end for the same commands).

If I try to install alsa-utils or alsa-base it tells me that they are already intalled. But Lsmod doesn't show anything 'alsa' afaik.

So please, for the love of music, how do I get alsa working properly? Huh


It gets worse now...Even after removing the xbian-alsa package, xbian-config upgrade still offers the alsa package as an upgrade option!

Something here is really screwed up.

Any ideas out there?

the best if you get all info together with logs an open an ticket on git so guys can see it

by "xbian-alsa" you mean xbian-package-xbmc-alsa package?

1) xbian-package-xbmc-alsa is xbian-package-xbmc replacement (XBMC for RPI able to use Alsa sound cards available in the system. it is not providing the alsa support itself.
2) kernel is the one providing Alsa support (drivers) for available sound cards.
3) if you want HDMI out be provided as Alsa sound card, the load appropriate module
modprobe snd-bcm2835
4) if you have i2s dac, then you have load it's module together with
modprobe snd-soc-bcm2708-i2s

then the XBMC-ALSA variant of XBMC will show you those sound cards in sound output settings.

Thank you for the pointers, as always it's very much appreciated!

I finally got some time today and it's all working now with the latest updates to Xbian and a little 'messing about' with the modules.

Sound is great!

Thanks! Smile

Hello, where I can find xbian-package-xbmc-alsa?
I had issues getting sound today with new reinstall. You no longer need to install xbian-package-xbmc-alsa.

I'll add more help on the other thread you started today here.....

As that is more relevant to the problem.
Reference URL's