Full Version: Audio only stutter
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2 3 4
Hi Folks,

use addon "easyadvancedsettings" for simply modify the advancedsettings-File!

a very cool addon!
(20th Apr, 2015 01:57 AM)mrpi Wrote: [ -> ]Until someone fixes this, the only workaround is to change your default audio player in the advancedsettings.xml file to "dvdplayer" as instructed here:

Same problem for me with a Raspberry Pi Model B 512M with latest Xbian updates.
I tried to change the default audio player. It is better but the music continue to stutte. More, during music playing, the CPU is always 100% and the GUI is slow... The music is good only when the screen saver starts 3 minutes after no action.
Sound in videos are nice, even with HD video...
Any idea ?
I tried some things a few minutes ago :

- I downloaded the XBian_2015.04.04_rpi.img.gz (Kodi 14.2) and installed it on my SD card. I opened an MP3 file : sound stuttering directly. But I noticed it slutters only when text is scrolling on the screen. When there is no scrolling, the sound is OK.

- I tried XBian_Stable_rpi.img.gz which I downloaded this week-end but no longer available on sourceforge. With this version, everything is ok. Sound don't stutter, even when text is scrolling on the screen. More, the sound is nice even with the 3D visualization in background. I only notice that this image uses Kodi 14.1

So, it seems that there is a sound playing problem with Kodi 14.2 on RPi model B (version 14.1 OK). What is the problem ? I don't know... Maybe a GUI problem...
I'm wondering why just we few guys have this audio issue...
I have the same problem on Raspberry B and Raspberry 2. Newest xbian Build.
I am using Yatse to Control and a centralised database running on a third Raspberry B.

Are there some bugfixes allready?


Doesn't look like it. Sad

Nothing in the FAQ or wiki on how to solve this issue either.

I try every few weeks to get Xbian working again with DAC, but always with no success.

I even had to remove the DAC tutorial I spent a lot of time researching and writing on here as it no longer works.

I had to find another (non-xbian) solution for my needs, but still check xbian from time to time as it has potential, just not stability nor usibility in recent months.

I'm using a DAC since october and never had issues. Maybe that's one of the reasons nobody is looking at it. Was this already posted on github?
(9th Jun, 2015 05:32 PM)CurlyMo Wrote: [ -> ]I'm using a DAC since october and never had issues. Maybe that's one of the reasons nobody is looking at it. Was this already posted on github?

Would you be able to post how you did this with the latest Xbain?
What is in your config and modules files?
What are the steps to follow to get it all working again?


Nothing, just connected the DAC over USB and it showed up in Kodi.
So it works OK for you with USB but not for me with I2S and some others with I2S and HDMI.

One day someone will figure it all out!

I spent some time with this yesterday and have found it to be a performance issue.

The cure is to overclock xbian to 'high' and then the performance is like Gotham on ''xbian' overclock. So it seems to be a CPU issue which suggests that something is not as optimised as it used to be.

I have reported this on github so maybe someone will find the cause and maybe be able to fix it. In the mean time, if you want to try overclocking to eliminate the stuttering, you can do so from within the config page (sudo xbian-config), but anything above medium setting will void your warranty and could damage the pi. But it's working for me for now.

XBian overclock settings never void warranty. All "red" overclock setting can make your pi unstable, that's why they are red. And the red settings can void warranty if you don't take care of manual settings you might add.
Thanks for the info. I believed that any overvolt would set a flag that would void the warranty, but I stand corrected!

Sadly the stuttering is still there when navigating menus, sometimes it drops the sound for many seconds at a time(!).

I have updated this info on github, maybe someone can look into it and see what has changed from Gotham to Kodi that is responsible.

Overclocking does not eleminate this problem in my situation.
I posted the issue on github and the following response did the trick for me, so if you have this problem I copy below the probable solution.....

1 make sure that the variable DPRIORITY is set to no in /etc/default/xbmc
2 1. is not enough to turn of DP completely. Unfortunately, kodi.bin will be launched with priority 49 and it will newer changed later. So, to turn it completely off you have to modify the file /etc/init/xbmc.conf. Please change the line exec schedtool -R -p 49 -e sudo -u $USER -g $GROUP -s $DAEMON $DAEMON_ARGS $DAEMON_LIRC $DEBUG 2>&1 | grep -v ES30 || : to sudo -u $USER -g $GROUP -s $DAEMON $DAEMON_ARGS $DAEMON_LIRC $DEBUG 2>&1 || :

Reboot and see if it helps you too.

Pages: 1 2 3 4
Reference URL's