Full Version: Todays update kills I2S sound.
You're currently viewing a stripped down version of our content. View the full version with proper formatting.

As above, after todays update/upgrade (from xbian-config) aplay -l no longer shows a sound card connected.

It was all working yesterday. Now no sound at all.

Tested on Rpi model b and Rpi 2 model b.

Will have more time to look into this tomorrow, but in the meantime if anyone else can confirm or deny (or spot the probem) then please post here. A btrfs snapshot rollback to yesterday did not solve the problem on one pi, the other won't rollback at all...

Update, with VNC not working I have moved a monitor and found that one pi has it's audio out reset to HDMI and the option for Alsa is no longer in the menu. Maybe this will help?

Update 1.

The Rpi 2 now seems to be stuck in a reboot loop. Whatever is happening, it's really screwed things up here!
I tried re-flashing another (new) memory card, but still no luck....

The Rpi 1 has been re-flashed to an earlier image and all is working again (but need to reinstall SSH keys and a few other things).

And the culprit is......

xbian_package_kernel 4.1.2+

As soon as this is installed, I2S audio stops working.....
You might want to join this issue:
Join it? I started it!

As of today the following are working with I2S dac.

Rpi model B - Kernel 4.1.2+
Rpi2 model B - Kernel 4.1.0 RC8

So if you have been affected then these are the ones to try first!

Reference URL's