Full Version: DVD files crash
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2
When i start a DVD file from one of my HDDs (one connected to my pc in the network and the other connected directly to my pi) the DVD menu apears But when i make a choice in the menu like play, The pi crashes back to its start screen.

any thoughts?
Do you have DVD iso's or VIDEO_TS folder on disk?
Both, And all seem to do it. Never had this problem before so my first thought was maybe something went wrong with the latest update or...
Hmmm, I can confirm the issue - happens also here Sad

Here is a workaround:
If you have an RPi2, you can disable hardware acceleration in Video settings (both OMX and MMAL has to be disabled) before watching DVD's
Thanks for the confirmation and workaround.
I understand you have added your codec licences to be able to play MPEG2?

If you asked me - sure. License is installed. The issue happens also on Cubox-i/Hummingboard. So it is not a license issue
This issue has been solved. Tested with Rpi1 and Rpi2, both are playing DVD iso files again Smile

A new package xbian-package-xbmc has been built and is available in staging repo

To get it, first you have to enable staging repo in file /etc/apt/sources.list.d/xbian.list

deb mirror://      stable  main rpi2-jessie
deb mirror://  staging main rpi2-jessie
### deb mirror://  devel   main rpi2-jessie
(sample file is for RPi2)

and then running following commands:

sudo apt-get update
sudo apt-get install xbian-package-xbmc
sudo stop xbmc;sudo start xbmc

Please test it and report if it also works for you.
Then I'll move this package to stable repo
Wish i could, Im a total noob at this and have no clue how to ad this repo. If anyone else could test it that be great.
Could somebody either test this, Or tell me step by step how to do this?
I already told it how to do it

1: log in to your RPi. This can be done locally (stop Kodi and then login with user xbian/password raspberry) if you have an usb keyboard attached or remote via ssh connection (if you have Windows putty is your friend)
2. edit file /etc/apt/sources.list.d/xbian.list: sudo nano /etc/apt/sources.list.d/xbian.list (see my post above) (nano is editor)
3. run the 3 commands (see my post above)
Ok got it done, And can now confirm the playback of the dvd files are back to normal.
Good news Smile

Thanks for reporting
After i had a few system updates the problem returned.
Please revert to the previous version.

Unfortunately this commit was lost during last rebase. It is already fixed but package has not yet built.
Pages: 1 2
Reference URL's