Full Version: RPi2 USB power: is there a conclusive answer?
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I know that this is probably hardware related, but still some of you could give a good advice or opinion.
I have been browsing the web, and I am seeing contradictory statements on non-powered USB HDDs:
One says that it should work if the power supply is 2A, if it is of a good quality and if one of these two lines (usb_max_power=1 or usb_max_current=1) is in the config file.
Another one says that it will not work, even with the best power supply, and that a powered USB hub is necessary.
In my case (RPi2 with XBian 20150407-0) I have tried to investigate the thing. I have run these commands:

xbian@XBIAN ~ $ usb-devices | grep 'Product=\|MxPwr'
S: Product=DWC OTG Controller
C: #Ifs= 1 Cfg#= 1 Atr=e0 MxPwr=0mA
C: #Ifs= 1 Cfg#= 1 Atr=e0 MxPwr=2mA
C: #Ifs= 1 Cfg#= 1 Atr=e0 MxPwr=2mA
S: Product=External HDD
C: #Ifs= 1 Cfg#= 1 Atr=c0 MxPwr=2mA
xbian@XBIAN ~ $ lsusb -v 2>/dev/null | grep -e 'MaxPower' -e 'Bus [0-9]'
Bus 001 Device 002: ID 0424:9514 Standard Microsystems Corp.
MaxPower 2mA
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
MaxPower 0mA
Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp.
MaxPower 2mA
Bus 001 Device 013: ID 1058:1003 Western Digital Technologies, Inc. Elements 100
MaxPower 2mA

I don't know what the "2mA" values mean here (if two Ampères are being provided by the power supply to the RPi2 or if there are two Ampères on the USB ports or only that these USB ports can supply up to two Ampères). So is this command output saying that the power supply is working as expected or not necessarily?
Then I added the below shown lines to the config, alternating the hash symbol on two different boots. But still I cannot use a non-powered HDD or CD-ROM (it's fine on a powered on a powered one, the above shown Western Digital, or on USB keys):

xbian@XBIAN ~ $ less /boot/config.txt

#initramfs initramfs.gz 0x1000000

What do you think?
There is only one answer:

External non-powered HDD's and CD-ROM's are usually working beyond the USB2.0 limits (which only allows 500mA). So, connecting such a device may work, or not. You always have to try it

usb_max_current=1 doubles the current which can be delivered to the USB ports. So if the power supply is good enough and the current consumption is hot higher than the current allowed by the onboard fuse, again, it may work or not.

The 2mA value is the maximum current the USB device will consume from the USB port and has nothing to do with the power supply or the max current which can be delivered by the USB port

In my case (a WLAN and a DVB-C stick is connected) I get


Bus 002 Device 002: ID 0cf3:7015 Atheros Communications, Inc. TP-Link TL-WN821N v3 802.11n [Atheros AR7010+AR9287]
MaxPower 500mA
Bus 001 Device 003: ID 0ccd:008e TerraTec Electronic GmbH Cinergy HTC XS
MaxPower 500mA

both devices reports max current of 500mA. But, if I connect one of these devices without parameter usb_max_current=1
to the RPi2, it won't work.
I had two external HDDs and a WIFI stick connected to my Pi 2 and it worked for the most part after setting

But I faced occasional freezes and reboots from time to time, so I assume this was already a very close call and have now moved to a powered hub for the HDDs
This is a very serious issue, I do not understand it very well yet. But thanks to you everything becomes clear.
bitpim alternative
Reference URL's