Full Version: GUI, weird characters with putty
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hi everyone,

Im a xbian user since a a couple of months ago. Everything goes well but I have this issue that annoy me. Here my problem in the template.

XBian version: 1.0
XBMC/Kodi version: 16.1
Overclock settings: none

Device type and model (e.g. Raspberry Pi Model A/B 256/512 MB, CuBox-i i4Pro, ...): Raspberry Pi 3 Model B
Power supply rating: 2.5 A, original
SD card size and make/type: 2GB
Network (Ethernet or wireless): Wireless
Connected devices (TV, USB, network storage, ...): TV via HDMI

Log files
Link to logfile(s): not provided

Problem description:
When I use putty to connect to xbian, the xbian-config script always show characters when I have to see a "table". If I log in directly by a keyboard connected to the raspberry, the table is correct. If I use mobaxterm, the table is correct. I have try to look for a solution on internet but without success. The solutions is always this one:

I have found this as well but I think that it's old and resolved.

How to reproduce:
Just connect with windows (8.1 in my case) and putty.

Usually I do not use putty (no Windows user) Smile

I tested it in a W7 virtual machine, all my semi graphic characters are displayed as expected. Only German umlauts are not displayed correctly (I'm using default setting in putty). But when I select UTF-8 in putty, all semi graphic characters are NOT displayed correctly but umlauts are ok.

Running a ssh session from my Linux boxes (Debian Jessie and openSUSE 13.1), everything is displayed correctly (semi graphic and umlauts)

So best is you're using putty defaults an post a picture here what you are getting. IMO it is windows/putty console issue.
(5th Sep, 2016 05:33 AM)naox Wrote: [ -> ]I have found this as well but I think that it's old and resolved.

Don't think that it is solved for windows. If you read last comment, windows has probably still issues with code pages
Thanks Nachteule.

I have change from "UTF-8" in putty to "Win1252 (Western)" and now it works.
Fine, then we can set this thread to solved Smile
Reference URL's