Forum

Full Version: Choppy sound after upgrade
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2
Good afternoon.

Two days ago I updated my xbian, but had to downgrade because, while displaying TV shows, the sound was getting very choppy after 1 minute.

Code:
apt-get install linux-image-bcm2836=4.14.58+-1532545509 xbian-package-tvheadend=4.2.5-72-1532487463 xbian-package-config-shell=20180626-0
and it works again


Don't know what the culprit is. I use a brand new class 10 sdcard.
TVheadend: No changes in code since 2 months
config-shell: don't believe that this package is culprit
kernel: one version between current (4.14.66+ and 4.14.58+ (its .58 not .50) version). Can you please test those 2 kernel's again to see if kernel package (and if yes, which one) is the culprit
Hello, sorry for the delay. :-)
I've fully updated and then I've downgraded the kernel, version by version, and seen what happened.

the available versions
[code]
apt-cache madison linux-image-bcm2836
linux-image-bcm2836 | 4.14.68+-1536170138 | http://apt.xbian.org stable/rpi2-stretch armhf Packages
linux-image-bcm2836 | 4.14.66+-1535023184 | http://apt.xbian.org stable/rpi2-stretch armhf Packages
linux-image-bcm2836 | 4.14.62+-1534333153 | http://apt.xbian.org stable/rpi2-stretch armhf Packages
linux-image-bcm2836 | 4.14.58+-1532545509 | http://apt.xbian.org stable/rpi2-stretch armhf Packages
linux-image-bcm2836 | 4.14.56+-1532352834 | http://apt.xbian.org stable/rpi2-stretch armhf Packages
linux-image-bcm2836 | 4.14.54+-1531266666 | http://apt.xbian.org stable/rpi2-stretch armhf Packages
linux-image-bcm2836 | 4.14.52+-1530495366 | http://apt.xbian.org stable/rpi2-stretch armhf Packages
linux-image-bcm2836 | 4.9.108+-1530490703 | http://apt.xbian.org stable/armv7l-stretch armhf Packages
[code]
The two versions more recent than linux-image-bcm2836=4.14.62+-1534333153 have the problem of choppy sound.
The other packages I mentioned earlier are unrelated to the problem.
(10th Sep, 2018 07:48 AM)Chiron Wrote: [ -> ]Hello, sorry for the delay. :-)

No problem Smile

Quote:The two versions more recent than linux-image-bcm2836=4.14.62+-1534333153 have the problem of choppy sound.
The other packages I mentioned earlier are unrelated to the problem.

Ok, that's what I expected. There is a revert of a commit which is included since 4.14.66+ (I suppose it is this commit)
This should solve some sound issues, seems that does not work of everybody Angry

Can you please describe your system a bit more in detail
Does that sound stuttering also appears when watching a normal video?
my system:
Code:
xbian@xbian ~ $ cat /proc/cpuinfo
processor    : 0
model name    : ARMv7 Processor rev 5 (v7l)
BogoMIPS    : 38.40
Features    : half thumb fastmult vfp edsp neon vfpv3 tls vfpv4 idiva idivt vfpd32 lpae evtstrm
CPU implementer    : 0x41
CPU architecture: 7
CPU variant    : 0x0
CPU part    : 0xc07
CPU revision    : 5

processor    : 1
model name    : ARMv7 Processor rev 5 (v7l)
BogoMIPS    : 38.40
Features    : half thumb fastmult vfp edsp neon vfpv3 tls vfpv4 idiva idivt vfpd32 lpae evtstrm
CPU implementer    : 0x41
CPU architecture: 7
CPU variant    : 0x0
CPU part    : 0xc07
CPU revision    : 5

processor    : 2
model name    : ARMv7 Processor rev 5 (v7l)
BogoMIPS    : 38.40
Features    : half thumb fastmult vfp edsp neon vfpv3 tls vfpv4 idiva idivt vfpd32 lpae evtstrm
CPU implementer    : 0x41
CPU architecture: 7
CPU variant    : 0x0
CPU part    : 0xc07
CPU revision    : 5

processor    : 3
model name    : ARMv7 Processor rev 5 (v7l)
BogoMIPS    : 38.40
Features    : half thumb fastmult vfp edsp neon vfpv3 tls vfpv4 idiva idivt vfpd32 lpae evtstrm
CPU implementer    : 0x41
CPU architecture: 7
CPU variant    : 0x0
CPU part    : 0xc07
CPU revision    : 5

Hardware    : BCM2835
Revision    : a01041
Serial        : 00000000bf32efdc

I think you already know which remote I own. ;-)
Code:
xbian@xbian /proc $ lsusb
Bus 001 Device 005: ID 07ca:3835 AVerMedia Technologies, Inc. AVerTV Volar Green HD (A835B)
Bus 001 Device 004: ID 0bc7:0004 X10 Wireless Technology, Inc. X10 Receiver
Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp. SMSC9512/9514 Fast Ethernet Adapter
Bus 001 Device 002: ID 0424:9514 Standard Microsystems Corp. SMC9514 Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
The sdcard is 1 month old
Code:
xbian@xbian /proc $ df -h
Filesystem      Size  Used Avail Use% Mounted on
udev            256K  4.0K  252K   2% /dev
tmpfs            75M  1.3M   74M   2% /run
/dev/mmcblk0p2   15G  1.2G   14G   9% /
/dev/mmcblk0p2   15G  1.2G   14G   9% /lib/modules
/dev/mmcblk0p2   15G  1.2G   14G   9% /home
/dev/mmcblk0p2   15G  1.2G   14G   9% /home/xbian/storage
/dev/mmcblk0p1   68M   34M   35M  50% /boot
none            4.0K     0  4.0K   0% /sys/fs/cgroup
/dev/mmcblk0p2   15G  1.2G   14G   9% /xbmc-backup
tmpfs            75M     0   75M   0% /run/user/1000
The pi is connected a samsung TV Syncmaster T220HD

The choppy sound problem occurs only with TV, not with videos.
Ok, and you're watching SD TV Live stream (DVB-T), PVR backend is TVheadend, and TV resolution is set to 1920x1080, sound over HDMI, right?

Are you using TVH's timeshift function - means buffering stream on sd-card?
(11th Sep, 2018 07:52 AM)Nachteule Wrote: [ -> ]Ok, and you're watching SD TV Live stream (DVB-T), PVR backend is TVheadend, and TV resolution is set to 1920x1080, sound over HDMI, right?

Are you using TVH's timeshift function - means buffering stream on sd-card?
SD TV Live stream (DVB-T) yes
PVR backend is TVheadend yes
TV resolution is set to 1920x1080 no it's 1024x768p
sound over HDMI yes
timeshift function yes, it's set to 60mns, path /home/xbian/timeshift, maximum size 1808 (I've just increased it to 5000, since I have a 16gb card)
(12th Sep, 2018 05:26 AM)Chiron Wrote: [ -> ]timeshift function yes, it's set to 60mns, path /home/xbian/timeshift, maximum size 1808 (I've just increased it to 5000, since I have a 16gb card)

Thanks for your info. Already tried to disable timeshift? IMO it is a bad idea putting timeshift buffer on sd card (that will stress sd card too much)
Something strange: I have another install of kodi on a laptop with another dvb-t usb dongle.
On this one timeshift is not enabled.
If I run the same tv show on both devices, I've noticed that on the raspi the show will be more and more late compared to the latop.

If I disable timeshift on the raspi, the devices stay synchronized.
That's why I don't use TVH for live tv - timeshift is still absolutely unsusable for me

But what about sound? Still garbage sound after disabling timeshift?
The problem seems to be gone.
That could also explain why sometimes the image freezes during a show, and I have to do a stop/play.
That's strange that this feature has an effect, even if you don't have used it since the last reboot...

However it is very useful. What could be the solution? Connect a hard disk through an AC/DC powered usb hub, and create a mount point in the fstab?
Or through an nfs mount on my nas?
(12th Sep, 2018 07:10 AM)Chiron Wrote: [ -> ]The problem seems to be gone.

Nice Smile

Quote:That could also explain why sometimes the image freezes during a show, and I have to do a stop/play.
That's strange that this feature has an effect, even if you don't have used it since the last reboot...

TVH has 3 timeshift settings: Off, On, OnDemand
On means, timeshift buffer is written always
OnDemand means, buffer is written after the first time you'll pause live stream

Quote:However it is very useful. What could be the solution? Connect a hard disk through an AC/DC powered usb hub, and create a mount point in the fstab?
Or through an nfs mount on my nas?

You can try it on a mounted nfs share, maybe network for SD streams is fast enough. I tested that some years ago, but with 720p streams and over WLAN (AFAIR) connection - and under those conditions it was absolutely impossible to get a smooth live stream
thanks very much. Smile
I've given a try with an nfs share, it's working flawlessly.
My network is ethernet, gigabit.

I only lost one hour figuring out why this damn fedora nfs server would'nt let me connect. the answer was no_acl in /etc/exports
Code:
/home/jyl/TVstream 192.168.30.3(rw,no_root_squash,no_acl,sync)

Edit: I've been too optimistic, the choppy sound is back, but now after 5 minutes, instead of 1. :-D
(13th Sep, 2018 06:51 AM)Chiron Wrote: [ -> ]Edit: I've been too optimistic, the choppy sound is back, but now after 5 minutes, instead of 1. :-D

Hmmm, that's weird.

I was testing it today with my devel Pi3B+, Kodi 18.0 Beta 2, Kernel 4.14.68+, DVB-C (spare part), SD and HD (720p) channels:

Was not able to get sound issues. But, my DVB-C device seems to have some issues, I'm always getting errors like that in the tvheadend log:

Code:
Sep 13 19:22:46 kmxbilr2 TS: dvb-c Home/402MHz/ServusTV: MPEG2VIDEO @ #2371 Continuity counter error (total 64)
Sep 13 19:23:00 kmxbilr2 TS: dvb-c Home/402MHz/ServusTV: MPEG2VIDEO @ #2371 Continuity counter error (total 68)
Sep 13 19:23:32 kmxbilr2 TS: dvb-c Home/402MHz/ServusTV: MPEG2VIDEO @ #2371 Continuity counter error (total 72)
Sep 13 19:23:43 kmxbilr2 TS: dvb-c Home/402MHz/ServusTV: MPEG2VIDEO @ #2371 Continuity counter error (total 75)
Sep 13 19:24:04 kmxbilr2 TS: dvb-c Home/402MHz/ServusTV: MPEG2VIDEO @ #2371 Continuity counter error (total 77)
Sep 13 19:24:04 kmxbilr2 TS: dvb-c Home/402MHz/ServusTV: MPEG2AUDIO @ #2372 Continuity counter error (total 7)
Sep 13 19:24:44 kmxbilr2 TS: dvb-c Home/402MHz/ServusTV: MPEG2VIDEO @ #2371 Continuity counter error (total 81)

This depends on the DVB-C stick - I know that this part does not work very well here (that's why it's spare part only Sad )
.
I think, I have same audio glitches on Pi2 after recent upgrade. This happens while playing 720p mkv videos. Any suggestions how to resolve it?
Pages: 1 2
Reference URL's