Full Version: Hauppauge 950Q how-to-install request
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2
Thank you for this resource.

The xbian-XBMC r-pi does a remarkable job of displaying streamed content from the household LAN. If I can add PVR functionality to it, I'll have a really decent media center.

I'm trying to make a Hauppauge 950Q tuner work with tvheadend. I understand that the necessary drivers are supposed to be included with this build ( The required firmware (dvb-fe-xc5000-1.6.114.fw) exists in /lib/firmware. However, the drivers apparently are not loading automatically. The tuner does not appear in tvheadend's TV Adapters list.
  • Is there a listed procedure for installing all necessary drivers for this device? I've been unsuccessful in finding this on the web.
  • Are there other things that must be done to the system to make this tuner work?

Thanks again-Dan
What are the driver/modules this device needs?
Thanks for the reply. Sorry my reply took so long.

As near as I can tell, drivers are needed for the following:

Xceive XC5000 (tuner and analog demodulator)
Auvitek AU8522 (A/V decoder analog demodulator [not used], and digital demodulator)
Auvitek AU0828 (USB bridge)

Assuming that these would be included with the v4l drivers I've attempted to use the procedure outlined at,_Build_and_Install_V4L-DVB_Device_Drivers, but I see a failure when I run the build script:
File not found: /lib/modules/3.6.11+/build/.config at ./scripts/ line 33, <IN> line 4.

I just compiled a massive amount of linuxtv driver, can you check if your's is included as well:

can you add this one?

if too many work , try to managed myself, but have to install kernel headers before.

That driver has been supported for a while...
That's a boatload of drivers you've got there...

I see the following entries in the list:
I will assume that these will work. I'll try them next opportunity.

Thanks again-
I have removed these boatload of drivers again because it broke other drivers as well. Nasty side effects. So can you confirm what files you needed and i make sure they are properly included.
To the best of my knowledge, the six files listed in my previous post are what I need.

The webpage lists this device, but does not elaborate on which particular device drivers are needed. indicates that
Quote:The digital side of the device is supported under Linux since kernel 2.6.26. Analog support was merged into the mainline v4l-dvb tree on March 18, 2009.
so it's been supported for awhile, apparently.

Quote:That driver has been supported for a while...

don't look deeper yet,
in dmesg :

[431532.408103] usb 1-1.2.2: new high-speed USB device number 8 using dwc_otg
[431532.510339] usb 1-1.2.2: New USB device found, idVendor=048d, idProduct=9135
[431532.510369] usb 1-1.2.2: New USB device strings: Mfr=0, Product=0, SerialNumber=0
[431533.213601] it913xv1: Chip Version=02 Chip Type=9135
[431533.214665] it913xv1: Dual mode=0 Tuner Type=38
[431533.214682] it913xv1: Unknown tuner ID applying default 0x60
[431533.216146] dvb-usb: found a 'ITE 9135 Generic' in cold state, will try to load a firmware
[431533.286335] dvb-usb: did not find the firmware file. (dvb-usb-it9135-02.fw) Please see linux/Documentation/dvb/ for more details on firmware-problems. (-2)
[431533.286355] it913xv1: DEV it913x Error
[431533.286477] usbcore: registered new interface driver it913xv1
[431533.296868] usbcore: registered new interface driver it913xv2
Attempts to install these drivers results in the following:
ERROR: could not insert 'au0828': Exec format error
ERROR: could not insert 'xc5000': Exec format error
ERROR: could not insert 'au8522_common': Exec format error
ERROR: could not insert 'au8522_decoder': Exec format error
ERROR: could not insert 'au8522_dig': Exec format error
What version of the kernel were these built for? I have 3.6.11+

Yes, they where build on 3.6.11+. Did you download all the kernel files? Because of dependencies, you need all those new files before you load a single module.
I can't get them to work with our current kernel, sorry...
And yet again, failure was not an option. I did get them to work but with another approach. I added the linuxtv drivers from the kernel 3.8.4 to kernel 3.6.11. Took me some hours so i hope it was worth it. Can you confirm if the modules worked? If so, then i'll create a new kernel update.
Thanks for the help on this.

I'm still getting the error when trying to install these.
xbian@xbian /lib/modules $ sudo depmod
xbian@xbian /lib/modules $ sudo modprobe au0828
ERROR: could not insert 'au0828': Exec format error
xbian@xbian /lib/modules $ sudo modprobe xc5000
ERROR: could not insert 'xc5000': Exec format error
xbian@xbian /lib/modules $ sudo modprobe au8522_control
FATAL: Module au8522_control not found.
xbian@xbian /lib/modules $ sudo modprobe au8522_common
ERROR: could not insert 'au8522_common': Exec format error
xbian@xbian /lib/modules $ sudo modprobe au8522_dig
ERROR: could not insert 'au8522_dig': Exec format error
xbian@xbian /lib/modules $ sudo modprobe au8522_decoder
ERROR: could not insert 'au8522_decoder': Exec format error
xbian@xbian /lib/modules $ cd $home
I don't see any missing dependencies when using depmod...
xbian@xbian ~ $ sudo depmod -v > wazoo.txt
xbian@xbian ~ $ grep "au0828" wazoo.txt
xbian@xbian ~ $ grep "au8522" wazoo.txt
/lib/modules/3.6.11+/kernel/drivers/media/dvb-frontends/au8522_decoder.ko needs "au8522_get_state": /lib/modules/3.6.11+/kernel/drivers/media/dvb-frontends/au8522_common.ko
/lib/modules/3.6.11+/kernel/drivers/media/dvb-frontends/au8522_dig.ko needs "au8522_init": /lib/modules/3.6.11+/kernel/drivers/media/dvb-frontends/au8522_common.ko
xbian@xbian ~ $ grep "xc5000" wazoo.txt
xbian@xbian ~ $
The only dependencies I see are in the au8522, where the au8522_common.ko module is referenced. I attempted to load this before loading the other two au8522 modules.
An attempt to install the au0828 driver using insmod results in a slightly different error:
xbian@xbian /lib/modules/3.6.11+/kernel/drivers/media/usb/au0828 $ sudo insmod au0828.ko
Error: could not insert module au0828.ko: Invalid module format
xbian@xbian /lib/modules/3.6.11+/kernel/drivers/media/usb/au0828 $

Perhaps I need to reload the SD card with a fresh image and start over. I must've damaged something. Are you using Alpha 5? That's what I'm attempting to use.

Thanks again-Dan
Pages: 1 2
Reference URL's