Thank you for your donation


Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
XBIAN + RetroPie
11th Oct, 2015, 07:30 AM
Post: #1
XBIAN + RetroPie
Hello boys and girls.

Today I had a free day and I decided to do some work relate to XBIAN. I like XBIAN and I have been using it for the last year and one of the things I like is that is snapy ...

Few days back I bought myself an RPi2 and while I was browsing for optimal Media Center for it (I wanted to test something else, but I got back to XBIAN) I found the RetroPie ... The thought I had was - can't I have both?

Today, as I said, I had the time to make it happen ... and I did it after few hours of work.

The script is not foolproof and I have not tested all emulators ... and there are few small hitches, but I hope you can help me fix it.

This is the base install script (it should prepare the system):

Code:
echo "Adding REPOS!"
echo "Add raspbian"
echo "deb http://mirrordirector.raspbian.org/raspbian/ wheezy main contrib non-free rpi" > /etc/apt/source.list

echo "Add collabora"
echo "deb http://raspberrypi.collabora.com wheezy rpi" > /etc/apt/source.list.d/collabora.list

echo "Add raspi"
echo "deb http://archive.raspberrypi.org/debian/ wheezy main" > /etc/apt/source.list.d/raspi.list


echo "Add keys"

wget http://mirrordirector.raspbian.org/raspbian.public.key -O - | apt-key add -
wget http://archive.raspberrypi.org/debian/raspberrypi.gpg.key -O - | sudo apt-key add -


echo "Update (We still have no key for collabora so allow unauthenticated)"
apt-get --allow-unauthenticated update

echo "Install all deps"
apt-get --allow-unauthenticated install -y libsdl1.2-dev \
unzip \
libsdl-ttf2.0-dev \
libboost-filesystem-dev \
libsdl-image1.2-dev \
libsdl-gfx1.2-dev \
libzip2 \
libzip-dev \
libudev-dev \
libxkbcommon-dev \
libboost-locale-dev \
libboost-date-time-dev \
libfreeimage-dev \
libeigen3-dev

#Try to install things that should not go
apt-get --allow-unauthenticated install -y libcurl4-openssl-dev \
libraspberrypi-dev \
libraspberrypi-doc \


echo "INSTALL GIT!!!"
apt-get install -y git dialog

Here I get the first and second snag:

I can't get the Collabora Public Key which forces me to use the --allow-unauthenticated.

Second snag is when I try to install libcurl4-openssl-dev
Terminal
libcurl4-openssl-dev : Depends: libcurl3 (= 7.38.0-4+deb8u2) but 7.37.1-1 is to be installed

After this is done - continue with RetroPie instructions (from here).

I used the binary installation. Few hours later we have the working RetroPie ... now comes the hard part.

We need to add the following:

Code:
, /bin/openvt, /usr/sbin/service


to /etc/sudoers.d/xbian at the end of the line concerning xbian user.

Now the script that makes the work with the dynamical switching between KODI and EmulatorStation (I used scrip from project called RetroSMC):

Code:
#!/bin/bash

sudo openvt -c 7 -s -f clear

sudo openvt -c 7 -f "$(emulationstation)" &

sleep 8

sudo service xbmc stop

while [ true ]; do
        VAR1="$(pidof /opt/retropie/supplementary/emulationstation/emulationstation)"

        if [ ! "$VAR1" ]; then
                sudo openvt -c 7 -s -f clear
                killall emulationstation
                sudo service xbmc start
                echo "Emulation station down. Strating KODI"
                exit
        else
                sleep 2
        fi
done
exit

Here are the other snags:

When I stop KODI my TV goes offline (KODI and CEC - I need to disable it but I can't find a way).
And ... I don't know how to add the script to the skin I use ... preferably I want to add it next to shutdown button.

Feel free to use this and please help me fix the issues and make it seamless (I will add videos tomorrow)

There are few thing I need to do - I will add roms and BIOS to SAMBA share.

And I have one more question - How can I create an IMG that has the free space striped out?
Visit this user's website Find all posts by this user
Quote this message in a reply
10th Feb, 2016, 09:34 PM
Post: #2
RE: XBIAN + RetroPie
Did you manage to get this working? I've tried several times using your instructions and no go. Would you be willing to post a bare bones IMG with emulationstation already setup?
Find all posts by this user
Quote this message in a reply
11th Apr, 2016, 12:57 AM
Post: #3
RE: XBIAN + RetroPie
Yeah it works.

I wold post such an image, but I don't know how to do it ... someone tried to explain it to me, but ...

There are some changes with the last retropie 3.5 and it's easyer.

Also I found that there is a change to be made in retropie.

Basicly it works for me Tongue

Here is a video preview (in Bulgarian but you could can see what works and what not and how)

https://www.youtube.com/watch?v=ZEyn63gknmU
Visit this user's website Find all posts by this user
Quote this message in a reply
11th Apr, 2016, 01:43 AM
Post: #4
RE: XBIAN + RetroPie
(11th Apr, 2016 12:57 AM)Lucifer Wrote:  Yeah it works.

I wold post such an image, but I don't know how to do it ... someone tried to explain it to me, but ...

Nice work. Smile

To build an ready to flash image please run sudo xbian-config and select menu selection 6 (xbian copier)
Find all posts by this user
Quote this message in a reply
11th Apr, 2016, 09:02 AM
Post: #5
RE: XBIAN + RetroPie
(11th Apr, 2016 01:43 AM)Nachteule Wrote:  
(11th Apr, 2016 12:57 AM)Lucifer Wrote:  Yeah it works.

I wold post such an image, but I don't know how to do it ... someone tried to explain it to me, but ...

Nice work. Smile

To build an ready to flash image please run sudo xbian-config and select menu selection 6 (xbian copier)

Ah! This kind of image! I will have one in few days.
Visit this user's website Find all posts by this user
Quote this message in a reply
21st Apr, 2016, 02:34 AM
Post: #6
RE: XBIAN + RetroPie
OK ... So I think this should be it.

All seems to work OK ... except sound.

https://mega.nz/#!dskSkYwQ!bxVaStu7QcNwpuYly0q9QbxWpLV-mLRxT-ga0v_dEks
Visit this user's website Find all posts by this user
Quote this message in a reply
26th May, 2016, 12:08 PM
Post: #7
RE: XBIAN + RetroPie
Thanks for the guide! I'm able to run RetroPie with latest XBIAN on a Raspberry 2.
The audio problem was solved, following this guide: https://www.raspberrypi.org/forums/viewtopic.php?f=28&t=147302&p=970041

But i have some kind of issue with the tty and virtual terminals.

Running your script, after i select a game it doesnt lunch.
The only way to play is to stop kodi (service xbmc stop), then log in in the tty1, and run emulationstation.

Other way to run it, is running emulationstation from a ssh remote console.
Any idea of what can be happening?

Thanks in advance,
Flavio.
Find all posts by this user
Quote this message in a reply
9th Jan, 2017, 06:45 AM
Post: #8
RE: XBIAN + RetroPie
Hi,

I'm new to this forum, using the current version of XBIAN (20161221-0) on a brand new Raspberry PI 3.

So far, everything works like a charm, but unfortunately I am not able to install RetroPie.
RetroArch and emulationstation refuse to install because of missing libraspberrypi-dev.

When I try to install this package I get:

Code:
Package libraspberrypi-dev is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
However the following packages replace it:
  xbian-package-firmware xbian-update

E: Package 'libraspberrypi-dev' has no installation candidate

Sorry if this is a stupid question but I've been googling for many hours without getting any clue how to fix this.

Any hint will be highly appreciated. I've spent many hours on configuring XBIAN and would hate to have to switch to another distribution.
Find all posts by this user
Quote this message in a reply
10th Jan, 2017, 02:04 AM
Post: #9
RE: XBIAN + RetroPie
@Tozzi
(9th Jan, 2017 06:45 AM)Tozzi Wrote:  Hi,

I'm new to this forum, using the current version of XBIAN (20161221-0) on a brand new Raspberry PI 3.

So far, everything works like a charm, but unfortunately I am not able to install RetroPie.
RetroArch and emulationstation refuse to install because of missing libraspberrypi-dev.

When I try to install this package I get:

Code:
Package libraspberrypi-dev is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
However the following packages replace it:
  xbian-package-firmware xbian-update

E: Package 'libraspberrypi-dev' has no installation candidate

Sorry if this is a stupid question but I've been googling for many hours without getting any clue how to fix this.

Any hint will be highly appreciated. I've spent many hours on configuring XBIAN and would hate to have to switch to another distribution.

Seems all files needed are in package xbian-package-firmware.
I'll build new firmware package tonight which should fix this isssue
Find all posts by this user
Quote this message in a reply
10th Jan, 2017, 07:36 AM
Post: #10
RE: XBIAN + RetroPie
(10th Jan, 2017 02:04 AM)Nachteule Wrote:  Seems all files needed are in package xbian-package-firmware.
I'll build new firmware package tonight which should fix this isssue

Thank you!
There's an update showing up, however I can't install it (kept back).
Trying to force it with apt-get dist-upgrade -y --force-yes broke my installation. Good thing I had a backup.

Here's the full output:
Code:
Calculating upgrade... The following packages were automatically installed and are no longer required:
  alsa-base alsa-tools autofs avahi-daemon bind9-host cifs-utils consolekit exfat-fuse exfat-utils fontconfig-config
  fonts-dejavu-core fuse hdparm hfsplus hfsprogs hfsutils ifplugd iptables ir-keytable libaacs0 libafpclient0 libass5
  libatasmart4 libavahi-core7 libbind9-90 libbluetooth3 libbluray1 libcaca0 libcdio13 libcec libcec-dev libck-connector0
  libcurl3 libcurl3-gnutls libdaemon0 libdbus-glib-1-2 libdevmapper-event1.02.1 libdirectfb-1.2-9 libdns100 libenca0
  libfontconfig1 libfribidi0 libfuse2 libgeoip1 libgif7 libgraphite2-3 libgudev-1.0-0 libharfbuzz0b libhfsp0 libimobiledevice4
  libisc95 libisccc90 libisccfg90 libiw30 libjasper1 libjbig0 liblcms2-2 liblvm2app2.2 liblwres90 libmad0 libmicrohttpd10
  libmpeg2-4 libmysqlclient18 libnfnetlink0 libnfs4 libnl-3-200 libnl-genl-3-200 libpcrecpp0 libperl4-corelibs-perl librtmp1
  libsamplerate0 libsdl-image1.2 libsdl1.2debian libsgutils2-2 libsmbclient libspeex1 libsqlite0 libssh-4 libssh2-1
  libtag1-vanilla libtag1c2a libtiff5 libtinyxml2.6.2 libudisks2-0 libupower-glib3 libusb-1.0-0 libusbmuxd2 libva1
  libvorbisfile3 libwebp5 libwebpdemux1 libwebpmux1 libxslt1.1 libyajl2 lsof mysql-common ntfs-3g openssh-client
  openssh-server openssh-sftp-server patch pv python-apt-common python-imaging python-libcec python-pil python-sqlite
  python3-apt sudo ttf-dejavu-core udisks udisks2 unattended-upgrades upower usbutils wireless-tools wpasupplicant
Use 'apt-get autoremove' to remove them.
Done
The following packages will be REMOVED:
  xbian-package-config-xbmc xbian-package-xbmc xbian-update
The following packages will be upgraded:
  xbian-package-firmware
WARNING: The following essential packages will be removed.
This should NOT be done unless you know exactly what you are doing!
  xbian-update
1 upgraded, 0 newly installed, 3 to remove and 0 not upgraded.
Need to get 3,241 kB of archives.
After this operation, 66.5 MB disk space will be freed.
You are about to do something potentially harmful.
Find all posts by this user
Quote this message in a reply
10th Jan, 2017, 07:42 AM
Post: #11
RE: XBIAN + RetroPie
No idea what you did before, but remember:

apt-get dist-upgrade should NEVER be used
Find all posts by this user
Quote this message in a reply
10th Jan, 2017, 08:27 AM
Post: #12
RE: XBIAN + RetroPie
(10th Jan, 2017 07:42 AM)Nachteule Wrote:  No idea what you did before, but remember:

apt-get dist-upgrade should NEVER be used

I know...
Still... the new package won't install.
Not even on a fresh install of XBian_latest_rpi3.
I've tried xbian-config first, of course, same thing, no joy.

The following packages have been kept back:
xbian-package-firmware
0 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.

apt-get install xbian-package-firmware throws the same warning quoted in my previous post above.
apt-get install xbian-package-firmware xbian-update shows:

Code:
xbian-update is already the newest version.
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
xbian-update : Conflicts: libraspberrypi-bin
E: Unable to correct problems, you have held broken packages.

Something's still not right there...
Find all posts by this user
Quote this message in a reply
10th Jan, 2017, 08:47 AM
Post: #13
RE: XBIAN + RetroPie
Ok, I see.

libraspberrypi-bin is already provided by xbian-update. My fault, sorry

Fixed and new firmware package will be available soon
Find all posts by this user
Quote this message in a reply
10th Jan, 2017, 08:52 AM
Post: #14
RE: XBIAN + RetroPie
(10th Jan, 2017 08:47 AM)Nachteule Wrote:  Ok, I see.

libraspberrypi-bin is already provided by xbian-update. My fault, sorry

Fixed and new firmware package will be available soon

Thanks a lot! Smile
Find all posts by this user
Quote this message in a reply
10th Jan, 2017, 11:11 AM
Post: #15
RE: XBIAN + RetroPie
I managed to update to the new version now, looks good.
Even got a new kernel now.

But the problem persists.

apt-get install libraspberrypi-dev reports (probably correctly):
Code:
Note, selecting 'xbian-package-firmware' instead of 'libraspberrypi-dev'
xbian-package-firmware is already the newest version.

Trying to install retroarch (from source or binary, doesn't matter) says however:
Code:
Did not find needed package(s): libraspberrypi-dev. I am trying to install them now.
Reading package lists...
Building dependency tree...
Reading state information...
xbian-package-firmware is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Could not install package(s): libraspberrypi-dev.

emulationstation throws this error:
Code:
Could not install package(s): libcurl4-openssl-dev.

and if I try to install it,

Code:
The following packages have unmet dependencies:
libcurl4-openssl-dev : Depends: libcurl3 (= 7.38.0-4+deb8u4) but 7.37.1-1 is to be installed

Basically same thing. I managed to install all the other dependencies, but these 2 still won't work.
Seems to me like it's a retropie issue rather than an xbian one.
I'll try and contact them; for now I'm afraid I'll have to give up... Confused
Find all posts by this user
Quote this message in a reply
Post Reply 


Possibly Related Threads...
Thread: Author Replies Views: Last Post
Rainbow [SOLVED] Xbian with working: Sopcast and XSopcast, Retropie and Rom Collection Browser JuStAdsor 4 6,733 14th May, 2014 06:47 AM
Last Post: pvlietst

Forum Jump: