Trouble using ContextMenu - cannot launch irw, irrecord or mode2 - Printable Version

+- Forum (
+-- Forum: Hardware (/forum-7.html)
+--- Forum: Remotes and CEC support (/forum-26.html)
+--- Thread: Trouble using ContextMenu - cannot launch irw, irrecord or mode2 (/thread-1099.html)

Trouble using ContextMenu - cannot launch irw, irrecord or mode2 - christov - 12th Jul, 2013 12:43 AM

I've been searching for a solution for this issue for hours but had no luck in resolving the problem.

Basically I upgraded to XBian Beta 1, was on the previous Alpha install before this and all was working great. The only small problem I have now is that the button on my remote that is acting as an MCE remote presses a key which I had assigned to ContextMenu within XBMC.
I had assigned the key 'volume_mute' to this ContextMenu command, as I use the actual mute button on my remote to trigger mute elsewhere in my setup (Yamaha receiver).
All was working great until upgrading to beta1; I have gone into keyboard.xml in this path:
and tried to edit the line:
To read this instead:

I'm 90% sure this is what I did last time to edit the key and get it working but can't be 100% as this was some time ago, since forgotten exactly what I did.
Unfortunately editing the keyboard.xml does not do the trick and button does not work. I've also tried using the xbmc app and the context menu does not appear at all if using either the default keyboard.xml or my modified keyboard.xml.

I tried following the tutorial here:

But the first point was my stumbling block, I cannot even run irw, irrecord or mode2.

irw shows a blank line and nothing happens when I press a key yet the remote is still working with xbmc.

mode2 gives me this error:
mode2: could not get file information for /dev/lirc0
mode2: default_init(): No such file or directory

and irrecord shows this error:
Usage: irrecord [options] file
irrecord: invalid argument count

I've tried what was suggested over here:
But still nothing... I get the same errors, running the commands as sudo or within root ssh.

Using what CurlyMo suggested here:
I was able to get mode2 to show me a blank line but with the same behaviour as irw.

I've also tried creating Lircmap.xml and keyboard.xml in
but this does not solve the problem.

... all to get the contextmenu working! So basically not sure where to go now. Any suggestions would be very much appreciated!

RE: Trouble using ContextMenu - cannot launch irw, irrecord or mode2 - christov - 14th Jul, 2013 08:30 PM


Any thoughts anyone?


Managed to get the context menu button working by using some info found over here:

My remote behaves as a keyboard so you have to find the button that you're pressing, I originally programmed this as volume_mute but for some reason xbian is now seeing this as f13. Possibly due to an MCE remote configuration but regardless here's how to find it for anyone else suffering with this problem, despite the fact my irw wasn't working; thanks to CurlyMo for posting this elsewhere!

Enable debugging in XBMC
Then enter this command in ssh:
tail -n 10 -f /home/xbian/.xbmc/temp/xbmc.log
And press the buttons you want to know what they do, look for something like this:
12:16:36 T:3042897920   DEBUG: OnKey: f13 (f09c) pressed, action is Mute=

So I'm pressing the button on the remote but XBMC is seeing this as F13, so all we then need to do is edit the keyboard.xml (I made a copy at ~/.xbmc/userdata/keyboard.xml):
then do this:
sudo xbmc stop
sudo xbmc start

Voila! Now it works properly.... sadly I've somehow broke my app that used to work with XBMC so we'll see how we get on with that!