beta2 - Printable Version

+- Forum (
+-- Forum: Software (/forum-6.html)
+--- Forum: Testing & Experimental (/forum-21.html)
+--- Thread: beta2 (/thread-1312.html)

beta2 - mk01 - 3rd Sep, 2013 07:14 PM


we need to test beta2. to jump on it, edit /etc/apt/sources.list and change
deb mirror:// wheezy main


deb wheezy main

then in terminal


apt-get clean; apt-get update; apt-get upgrade

this will install any upstream package updates.

after this step finishes run next one without doing reboot between them.


apt-get install xbian-update

for future updates you can use XBIAN-CONFIG within XBMC and "Update all".

to speed up the process, stop XBMC before. by QUIT from XBMC menu, or "stop xbmc" from console. all the command should be run with "sudo", or just log as xbian, then type "sudo -i". this will open console with root privileges where sudo before command is not needed anymore.

I can also prepare an image, if really needed (img is at . this is still not official release, but another way to test beta2 beside updating via deb packages from A5/B1/B1.1)

impotant info as of Oct-17-2013:
Debian released Wheezy 7.2 update released the day before yesterday will add additional ~30 packages to the update process of Beta2 install with regularly updated XBian / system packages. Could be more for Beta1/Beta1.1 and specially Alpha5. Update process from Alpha5 (and possibly also Beta1 and Beta1.1) will install initscripts package and trigger dpkg configure error and stop on processing updates. Beta2 update package is correcting the specific (and even more conflicts), but as this is not yet installed. so we do it manually by. Already existing installations with Beta2 should be fine. These below a steps needed to solve issue:

rm -f /etc/init.d/mountall*
insserv -f
apt-get upgrade (again)

apt-get upgrade in step three will start where previous update process stopped - by configuring initscripts package again and this time will finish successfully.
For most simple and automated finish of the update process it is preferred to list all packages reported as "kept back" as parameters to "apt-get install xbian-update" command described on top of this post. It all depends on combination or age of actual installed packages as well on the order in which apt-get will process updates in each specific case. Than means simple "apt-get install xbian-update" can do just fine for one user, but can require explicitly named another package on command line for different user.

This means if apt-get will report:
xbian-package-lirc, xbian-package-cec and others to upgrade
xbian-package-xbmc, xbian-update, xbian-package-config-shell as "kept back"

proceed better with:

apt-get install xbian-package-xbmc xbian-update xbian-package-config-shell
instead of simple
apt-get install xbian-update

Beta2 has more changes in the area of update / upgrade implemented which should once and for all make use of command line tools via ssh not needed anymore. xbian-config-shell and -xbmc should then be able to handle updates with more ease.

on this question (and similar if encountered)
Configuration file `/etc/apt/apt.conf.d/15update-stamp'
==> File on system created by you or by a script.
==> File also in package provided by package maintainer.
   What would you like to do about it ?  Your options are:
    Y or I  : install the package maintainer's version
    N or O  : keep your currently-installed version
      D     : show the differences between the versions
      Z     : start a shell to examine the situation
The default action is to keep your current version.

just press Y (or you '-y' command line option to apt-get install)

errors about not being able to start LIRC or RNG-TOOL can be ignored. it is caused by dependency to kernel which is just going to be installed or services which xbian-update package will install later and will be started only after reboot.


RE: beta2 - brantje - 3rd Sep, 2013 09:42 PM

What should we test?

RE: beta2 - mk01 - 3rd Sep, 2013 10:35 PM

update over any beta -> daily usage.

I don't expect more.

1) If you had issues with any beta, you should not have them anymore.
2) If you had no issues, it should not introduce new. So you should have no issues.
3) If you have stickies since alpha5/betaX about function/property which was declared as "there" but never really worked, it maybe should work.
4) If we pass few days with 1 and 2 (3), we can take a closer look to brand new functions.

RE: beta2 - IriDium - 3rd Sep, 2013 11:28 PM

So far....... it is looking good. "Famous last words" Blush

I assume "Configuration file `/etc/default/xbmc'" should be "Y" as well?

No known errors, except the xbian-config USB & backup which are known about.

Also the xbian-root-btrfs popup needs to be mentioned to users as this might confuse a lot of people.

I wouldn't create an image just yet, we need as many upgrades to see what issues occur - if any :-)

I've looked for all of the known Beta 1.1 errors, and they do not seem to occur anymore.

I cannot test much more as I have fully used up all of my available H/W and it all works. So all I can do is just use it now and see what happens.

What needs to be tested:
1) USB DVD drive
2) Airplay
3) Different CEC and IR remotes.
4) NFS
5) Various WiFi dongles (Realtek 8188 chip works)

RE: beta2 - IriDium - 4th Sep, 2013 01:23 AM

LG remote - On start error message in XBMC "Failed to start device"
16:12:14 T:3030094912 ERROR: CecLogMessage - failed to release the previous LA
16:12:14 T:3030094912 ERROR: CecLogMessage - could not open a connection (try 1)

Left for a bit and it started working!

Restarted XBMC and all worked.

RE: beta2 - mk01 - 4th Sep, 2013 01:28 AM

LG - CEC ?

RE: beta2 - IriDium - 4th Sep, 2013 01:59 AM

(4th Sep, 2013 01:28 AM)mk01 Wrote:  LG - CEC ?
No idea Cool Was the only error I saw in xbmc.log. How can I tell? The arrow keys work on the Menu and the video play/pause ff/rw work.

I normally don't use it as my Logitech K400 kb and mouse usually do all the work.

Also seen in xbmc.log
ERROR: SetPriority: error Permission denied

No idea what it means or what caused it.

@mk01 - Just curious - why a 628Mb swap? seems a funny value.

RE: beta2 - mk01 - 4th Sep, 2013 02:38 AM

(4th Sep, 2013 01:59 AM)IriDium Wrote:  @mk01 - Just curious - why a 628Mb swap? seems a spurious number.

it is because the zramswap parameter.

it creates swap on device which holds currently booting rootfs. so if you booted from SD card, 256mb created. then sda, 256mb created.

+ virtual swap on sram which is 128mb (max 1/3 of system mem).

during boot and run, system activates each and every swap part it will find.

if you disable LIRC as service, will the LG functionality change ?

RE: beta2 - IriDium - 4th Sep, 2013 02:46 AM

Ok - that will explain it as I am booting off a USB.

BTW: Thanks for all the work you have put into Beta 1.2 it's a marked improvement on Beta 1(.1).

Performance is great:
Music ~ 25% CPU
720P DTS - 60%
1080p DTS - 75%
(I don't have a DTS receiver, only AC3)

Is it "normal" to see "init: xbian-xbmc-bridge main process ended, respawning" in dmesg?

RE: beta2 - mk01 - 4th Sep, 2013 03:20 AM

(4th Sep, 2013 02:46 AM)IriDium Wrote:  Ok - that will explain it as I am booting off a USB.

Is it "normal" to see "init: xbian-xbmc-bridge main process ended, respawning" in dmesg?

1) if you don't use /dev/mmcblk0p2 currently, reformat it with
mkfs.btrfs -L beta2 -l 16384 -m single -f /dev/mmcblk0p2

then copy usb to it with (while booted on usb)

btrfs-auto-snapshot xbiancopy --no-create /dev/root /dev/mmcblk0p2

then change cmdline.txt "root=LABEL=beta2" and reboot. it should fragment less, metadata should save space and latency will improve specially while running more tasks with high io and io wait.

2) normally this should not happen. but can. all is ok if it re-spawn successfully.

also, you will see it at the moment xbmc is exiting. then is fully ok.

RE: beta2 - IriDium - 4th Sep, 2013 04:31 AM

Ok- stopping Lirc stops function of remote - so it's IR not CEC.

Will try the rest tomorrow.

RE: beta2 - mk01 - 4th Sep, 2013 04:51 AM

xbiancopy is fixed (output)

RE: beta2 - IriDium - 4th Sep, 2013 05:00 AM

(4th Sep, 2013 04:51 AM)mk01 Wrote:  xbiancopy is fixed (output)
Ok - Will test tomorrow.

Is this a minor fix?

I'm just trying to stabalise Beta 1.2 so I don't want anything too drastic.

RE: beta2 - mk01 - 4th Sep, 2013 05:58 AM

no. just the screen output of xbiancopy function within xbian-config

and finally start to believe me, you can just install and reinstall all the packages as many times you want. you won't see a difference between clean beta1 + updates and this x-times updated version !

save your time.

RE: beta2 - IriDium - 4th Sep, 2013 07:58 PM

Trying to upgrade via xbian-config - say "new version of xbian is available" answered Y. Quits with syntax error
/usr/local/include/xbian-config/modules/updates/functions: line 143: xbian-update;1.0-1.2;1.0-1.2: syntax error: invalid arithmetic operator (error token is ";1.0-1.2;1.0-1.2")
(standard_in) 1: syntax error
(standard_in) 1: syntax error

and returns "The packages versions you are trying to install cannot be found."

#apt-get upgrade - works