SD card corruption after legal shutdown - Printable Version

+- Forum (
+-- Forum: Software (/forum-6.html)
+--- Forum: Installation (/forum-16.html)
+--- Thread: SD card corruption after legal shutdown (/thread-1413.html)

SD card corruption after legal shutdown - kriticar - 27th Sep, 2013 09:31 PM


My xbian 1.0 beta 1.1 was working fine for weeks and I decided to make a backup of it.
In order to do that, I have executed shoutdown with remote controller from xbmc interface, waited to see only power led on, than I turned off the charger, pulled out the sd card from pi and put it in the laptop.

On my laptop, I have used win32diskimager-v0.8 to create an image.
After backup has been done, I returned a sd card back to the pi, but now I was unable to boot.
Xbian, starts but at boot time after init process, “loading…” faze never ended, so I was unable to boot at all.

I tried to write win32diskimager-v0.8 image to the sd card, which went well, but with the same problem at loading faze.
The image file is OK, and after new fresh installation of xbian to the same sd card, I was able to restore everything from the image and my xbian works fine again.

This happened to me twice.

What would be the possible cause of the problem?
How to debug it?
Does anyone have a clue?


RE: Does this happen to anyone? - IriDium - 27th Sep, 2013 10:19 PM

I've always had problems restoring a backup - however there are rules that need to be followed.

Always format before writting and alway sync (unmount) the SD card after writing. Either by "eject" or that little icon in the task bar.

I'm currently testing on Ver 0.9 and will let you know (I should have used a 2G card, not a 8G!)

Ok - It seems to be working. What I did.
Using Win32diskimager v0.9
Read SD card to folder.
Remounted and formatted.
Remounted and wrote image to SD card.
Plugged into RPi and it worked.

Re: Does this happen to anyone? - rikardo1979 - 27th Sep, 2013 11:17 PM

the problem would be elswhere here.
I think that when he shutdown XBMC that it didnt go well and the SD card get corrupted (SW not HW) and he made an image afterwards and unfortunately with the corruption on so that would be the reason why it wont work after restoration back to SD card.

RE: Does this happen to anyone? - kriticar - 28th Sep, 2013 01:02 AM

Well, it happened twice to me, so now I am afraid to do the backup of the sd card.
Anyway, how can I precisely determine what part of the boot process got corrupted?

RE: Does this happen to anyone? - IriDium - 28th Sep, 2013 01:25 AM

Reading the SD card shouldn't cause the issue. If you are not unmounting correctly from Windows - this could be causing the issue

Try these:
1) Reflash the card, boot into the RPi. Shudown. Remove the card. Put it back in - boot. Does it work?
If so:
2) Shutdown again, remove the card, read via Win32diskimager - unmount (as mentioned before) put back in the RPi - does it boot correctly?
If not, then there is a problem.

Do you know your memory chip manufacturer? It can be read from the top of the chip.
Have you modified anything? Overclocking, added anything extra - bar standard addons.

Also - can you rename the Thread to something more conducive to the problem.