Does your RPi freeze? - Printable Version

+- Forum (
+-- Forum: Software (/forum-6.html)
+--- Forum: Configuration (/forum-17.html)
+--- Thread: Does your RPi freeze? (/thread-2186.html)

Pages: 1 2 3

Does your RPi freeze? - JD Patxiku - 17th Mar, 2014 11:00 AM

I have a 512mb Raspberry connected via Wi-Fi to my NAS.

I have modify cache buffer size on advancedsettings.xml and it does not seem to work, I've checked on the logfile and advancedsettings.xml loads. After reading some threads I decided to create a swap on my SD and when I check if it is working it doesnt. (Now I have no advancedsettings.xml or swap).
When I try to play HD movies on my RPi it freezes and then stops, buffers some time and it plays again but this does not take long.
I have checked this thread and observed that people is not having problems with video streams. I'm using NFS for streams.
Does anyone have a WI-FI connected RPi working without freezes?
I was wondering if "saving" the cache on a USB device or a SD card is possible.

RE: Does your RPi freeze? - mk01 - 17th Mar, 2014 11:04 PM

@JD Patxiku

in general caching NFS could have some benefits (depending on network infrastructure, server setup etc). but won't bring you any benefit for our usage case.

imagine the situation as follows - normally XBMC fetches directly from NFS, one big file. it loads a portion of the file into memory, decode, display and this repeats.

if you add local cache, XBMC will not use it. as XBMC by default accesses NFS directly. so you can mount NFS locally and reindex you library / XBMC to use "local folder". and now to the process - XBMC tries to fetch a portion of file -> local NFS cache will report not available -> nfs subsystem fetches from NFS -> this needs to be stored locally and then redelivered from local cache to XBMC.

this will only bring OVERHEAD and will not make any profit (on the contrary). because XBMC will not report demand for piece of the file in advance so you won't have any pre-buffers on disk available. never ever.

so don't bother with that.

you are right that with XBian report about streaming problems are very very rare. most of the time they indicate different problem.
what I would do in your case is FOR TESTING PERIOD switching to LAN. that way you can track down if the issue is outside your RPI or inside it and whether it is related to WIFI only or not.

check this out and report back. according to your feedback we can discuss what's next.

RE: Does your RPi freeze? - jona9 - 20th Mar, 2014 02:28 AM

It could be a limitation of the WiFi adapter you use. I had the same problem initially, with a 256Mb Pi. All videos would freeze up every few seconds.

Fortunately my router showed that the Pi was connected at 5Mb/second, while all the other WiFi devices in my network connected at 50 Mb/s. After replacing the no-name adapted with an Edimax 7811, the Pi connected at 50Mb/s and there was no lag -my files are 5Mbit/second at most.

You could have issues if the WiFi access point signal is too weak. Or if the access point does not support 801.11n

RE: Does your RPi freeze? - JD Patxiku - 20th Mar, 2014 06:42 PM

I'm not at home until friday.
I have my NAS in local, so its not about the connection problem.
I have tested my NAS with 10 devices watching films at the same time and it has 0 lag.
If it helps, my NAS has OpenMediaVault OS (don't know if you know it).

I can't certainly know the model.
It's a nano wifi adapter 802.11b/g/n 150Mbps.
I can't test the local speed until friday.
I have one repeater and the signal comes 100%.


Tomorrow I'll test this more.
I can watch online SD streams without any freeze (I mean internet streams not local) so I don't know why I cant do the same with 790 /1080 at local.
Is there any way to test the RPi speed?

I hope you understand my english Wink

RE: Does your RPi freeze? - m_abs - 23rd Mar, 2014 05:53 AM

I have a similar problem, my 512mb raspberry pi often freezes. I experience these freezes with both playback and navigating trough files and collection.
I have a 1Gbit network and the files are shared over NFS. The shares are not mounted on the RPI, XBMC fetches the files directly.

I started having these problems right after the old microSD card died and I had to replaced it with a class-4 (because it was the only one I had), so I thought that this was the problem.
Unfortunately the problem didn't go away then I switched to a class-10.

Did you find a solution for your problem?

RE: Does your RPi freeze? - mk01 - 24th Mar, 2014 06:40 AM


DB, Thumbs etc are stored locally on RPI? how big is the library? can you post output of
lsattr /home/xbian/.xbmc/userdata/Database

RE: Does your RPi freeze? - m_abs - 27th Mar, 2014 10:14 PM

(24th Mar, 2014 06:40 AM)mk01 Wrote:  @m_abs,

DB, Thumbs etc are stored locally on RPI? how big is the library? can you post output of
lsattr /home/xbian/.xbmc/userdata/Database

The DB, Thumbs etc. are stored locally.
#lsattr /home/xbian/.xbmc/userdata/Database
---------------C .xbmc/userdata/Database/Addons15.db
---------------C .xbmc/userdata/Database/CDDB
---------------C .xbmc/userdata/Database/Epg7.db
---------------C .xbmc/userdata/Database/MyMusic32.db
---------------C .xbmc/userdata/Database/MyVideos75.db
---------------C .xbmc/userdata/Database/TV22.db
---------------C .xbmc/userdata/Database/Textures13.db
---------------C .xbmc/userdata/Database/ViewModes4.db

# du -hs .xbmc/userdata/{Database,Thumbnails}
19M     .xbmc/userdata/Database
444M    .xbmc/userdata/Thumbnails

RE: Does your RPi freeze? - NitSuA - 27th Mar, 2014 10:23 PM


I experienced freezes with Xbian as well.
Xbian is overclocked by default (840 instead of 700 I guess).

removing the overclock solved my problem (set it to none in Xbian config in XBMC).

By the way, using a USB to store data (see other thread) made a much bigger speed increase compared to overlocking the device. Once I used USB, there is no need to overclock for me at all.

RE: Does your RPi freeze? - mailmark - 1st Apr, 2014 05:09 AM


Not sure if this is the correct thread to post to, so please let me know if it should go to a separate one.

I tried releases 1.0 beta 2 and 1.0 RC1. They both freeze during playback of any video and sometimes when navigating through the menu (the video overview screen). Characteristics: during playing the video the audio gets lost, the video keeps playing for some seconds but then also stops. The RPi is then not reachable via ssh anymore

I tried some other power adaptors (all 1A) and bought a separate USB hub to power the Wifi and Bluetooth, unfortunately that didn't work. Also lowering the overclocking did not work.

Before these versions I used version 1.0 beta 1.1. That version did not ever gave me any freezes. I re-installed the version last week and Xbian did not freeze since that the re-installation.

Power supply rating: Blue Starr Micro usb Output 1A
RPi model (model A/B 256mb/512mb): B 512mb
SD card size and make/type: 8Gb Sandisk Ultra (30Mb/s class 10)
Network (wireless or LAN): Wifi Skylink SL 1504N (RTL8191SU 802.11n)
Connected devices (TV, USB, network storage, etc.): Bluetooth keyboard receiver and Wifi receiver

If more information is needed, just let me know. I'm also willing to re-install Xbian to a specific version if needed for logging, etc. I'd really want to make use of Xbian's future releases, it's a great project!

RE: Does your RPi freeze? - mk01 - 3rd Apr, 2014 02:55 PM


what you can do is (just for testing) remove BT receiver & Wifi and attach just LAN.
second test would be using ANY old shitty SD card (class 4 preferably).

based on that we can try preserve /boot and /lib/modules files from B1.1 and use them with B2+. this should show us what is the problem.

RE: Does your RPi freeze? - mailmark - 4th Apr, 2014 06:35 AM

Thank you for the reply. I will try to do both this weekend and let you know the result.


RE: Does your RPi freeze? - JD Patxiku - 5th Apr, 2014 12:31 AM

Here I come again!

First of all sorry about my dc time, I was working hard this week and couldn't check the forum.
I bought a D-Link DWA-121 WI-FI adapter for my RPi, the RPi keeps freezing.
The only way I can connect my RPi is Wifi.
I have tried with Repeaters etc but the problem keeps here.
My Macbook PRO can watch all films with any problems so I don't think it is a connection speed problem.
Quote:Is there any linux command for lan speedtest?
As I said I have my NAS mounted on lan and it shares fast in other devices.
Could the problem be that I'm using NFS? What kind of sharing service should I use?
I hope my RPi finally achieves a good lan stream speed.

Sorry about my "English".

Thank you for sharing your knowledge with me.

RE: Does your RPi freeze? - mk01 - 5th Apr, 2014 12:37 AM

@JD Patxiku

mount the NFS locally and test resulting speed with copying file over to RPI. there are some "automatic" scripts to check that ... somewhere at raspbmc site I remember such. let's see if google helps:

if you list the pages, you will find also link to the script and small how-to.

RE: Does your RPi freeze? - JD Patxiku - 5th Apr, 2014 12:56 AM

Sorry, but I don't understand what you mean.
¿Copying whole file into the RPi?

RE: Does your RPi freeze? - mk01 - 5th Apr, 2014 01:05 AM

@JD Patxiku

use the script. copy over doesn't mean to store it locally (as this would be no measurement of NET bandwidth). but again, script will do all for you.

(with "dd if=/nas/file of=/dev/null")