update failed for xbian-package-config - Printable Version

+- Forum (
+-- Forum: Software (/forum-6.html)
+--- Forum: Installation (/forum-16.html)
+--- Thread: update failed for xbian-package-config (/thread-2321.html)

update failed for xbian-package-config - min - 31st May, 2014 09:15 PM

My little pi crashed during an update, and now there's no xbian-config!

Regular update and force install gives following error:

Unpacking replacement xbian-package-config-shell ...
dpkg: error processing xbian-package-config-shell_2.1.7-4_armhf.deb (--install):
unable to make backup symlink for `./usr/local/include/xbian-config/modules/enableauto/functions': No such file or directory
Errors were encountered while processing:

How can I fix this?

RE: update failed for xbian-package-config - IriDium - 1st Jun, 2014 01:05 AM

What release are you on?
How are you doing the upgrade?
Apt-get upgrade, apt-get dist-upgrade, ssh xbian-config, XBMC xbian-config or auto updates?

I'd try ssh xbian-config - it seems to resolve a lot of errors.

RE: update failed for xbian-package-config - min - 1st Jun, 2014 02:46 AM

I'm on rc2 with Gotham nightly installed.

First I tried to update via xbian menu, system crashed.

Second I tried to do apt-get upgrade, then I get the error above.

Now I cannot access xbian-config via ssh or xbmc menu, as if there is no xbian-config on my system. Xbmc gives a 'script failed!' on boot.

I have tried downloading the xbian-config deb and installing manually but I get the error about not being able to backup symlink.

Is there a way to purge and reinstall xbian-config safely?

RE: update failed for xbian-package-config - IriDium - 1st Jun, 2014 03:10 AM

There is a thread about "script failed!" - something to do with editing the file