[SOLVED] Could not play videos - iso, mp4 etc from hdd - Printable Version

+- Forum (
+-- Forum: Hardware (/forum-7.html)
+--- Forum: Video and Audio (/forum-28.html)
+--- Thread: [SOLVED] Could not play videos - iso, mp4 etc from hdd (/thread-2886.html)

Could not play videos - iso, mp4 etc from hdd - StartledCat - 24th Mar, 2015 06:08 AM

Hi Folks,

I am posting this up as Solved, as I sorted this one out myself...and am posting it as I think it will help others:

Last week I got hold of an external hdd - the plan being I could put my dvds on it and play them from my RPi2/kodi/xbian.

Without going in to too much detail, the first batch of films when on to the hdd and played back fine - DVD Shrink coped with the majority...some had to be done using a trail version of DVD Fab.

All was going well, until yesterday, when the file transfer to the hdd seemed to slow down. Having scanned the hdd, found no problems - back to the copy...not faster, but they got there in the end.

Today, I connected the hdd to the rpi2 - none of the films I had done the day before ran.

After much head-banging and file re-generation, I finally resorted to trying mp4 format, rather than iso - still didn't work.

So, back to basics:
Am on Windows 7, with a Toshiba 1TB hdd.
Run the mp4 from Windows - runs ok
Run the mp4 from hdd under rp12/xbian - error reading file (from log).
Run the mp4 from hdd under Windows - error reading file.
Files appear to be the same, but....

Having trawled the web, found some 'similar' issues with hdd/usb drives/sd cards etc., all advising the same kind of thing...e.g. corrupt file/corrupt disk - not a real help.

DING! then the penny dropped...a few days ago when the hdd was connected to Win7, I changed the drive/folder optimization option from General to Videos (seemed like a good idea at the time).

So, I have changed this option back to 'General' and it all works fine.

Hope this helps others, as I spent a while trying to get to the bottom of this one.

RE: Could not play videos - iso, mp4 etc from hdd - menakite - 24th Mar, 2015 09:48 AM

Thanks for sharing your experience!

Sounds pretty odd for an "optimization" option.

RE: Could not play videos - iso, mp4 etc from hdd - StartledCat - 25th Mar, 2015 07:33 PM

Tested a bit more: (Windows 7 SP1, Toshiba HDTB310EK3AA 1TB Canvio Basics USB 3.0 2.5 Inch External Hard Drive)

Coupled with this, some copies still do not run. On comparing the HDD content with the source, files are the same size, but not complete (zero bytes filling to the end of the file). A couple of changes to copying:

1. Do not use File Explorer to copy, as if it fails, does not always inform the user;
2. Use xcopy with /j /v from the command prompt – this will report I/O failures correctly;
3. Some USB ports don’t work, some do – so sticking with the ones that do! Thought it might be the cable - it was the slot.

As mentioned in the first post - this still stands i.e. need to keep as General Items, and verify the copy to the hdd.