[PROBLEM] not booting anymore (switching to root) - Printable Version

+- Forum (
+-- Forum: Software (/forum-6.html)
+--- Forum: Installation (/forum-16.html)
+--- Thread: [PROBLEM] not booting anymore (switching to root) (/thread-2931.html)

not booting anymore (switching to root) - mindless - 11th Apr, 2015 11:13 PM


I successfully installed Xbian on my Pi2 since about a month now and everything was finally running smoothly, but a few days ago, I rebooted to test init scripts and the system could boot anymore.

It stays stuck on Switching to root and sometimes passes one step further (setting up x socket directories ...)

not relevant anymore (Click to View)
I just tried to add rescue_early to the cmdline.txt and i was able to get a shell.
The btrfs partition was mounted already and i was able to do "chroot /rootfs" where I could find all my usual files.
I ran btrfs check on the unmounted partition and it found no error.

I guess all this means that my filesystem is fine but I'm still stuck on swithching root during the boot process.

Can someone help me fix this ?