[PROBLEM] LIRC repeats - Printable Version

+- Forum (
+-- Forum: Hardware (/forum-7.html)
+--- Forum: Remotes and CEC support (/forum-26.html)
+--- Thread: [PROBLEM] LIRC repeats (/thread-2967.html)

Pages: 1 2

LIRC repeats - makon - 28th Apr, 2015 11:12 PM

Hello! I have problem with LIRC:
1) I run irw command
2) I press right button (for example). But in kodi interface I see a jump through one element. For example: 1->3->5->1...etc (in 1-2-3-4-5-6 sequence). But irw displays only one button press!
000000037ff07be1 00 KEY_UP mceusb
3) If i hold down this button, in kodi interface i see one jump through one element, after that jumps occur elementwise. For example: 1->3->4->5->6->1->2->3->4.... etc (in 1-2-3-4-5-6 sequence). irw show me the repetition:
000000037ff07be1 00 KEY_UP mceusb
000000037ff07be1 01 KEY_UP mceusb
000000037ff07be1 02 KEY_UP mceusb
000000037ff07be1 03 KEY_UP mceusb
000000037ff07be1 04 KEY_UP mceusb
000000037ff07be1 05 KEY_UP mceusb
000000037ff07be1 06 KEY_UP mceusb
000000037ff07be1 07 KEY_UP mceusb

It does not depend from remote control (I tried different RC's). What i am doing wrong?

RE: LIRC repeats - zurdar - 10th May, 2015 03:37 PM

Same issue here. IRW shows single keypresses and KODI skips two elements. Completely not usable. Reverting to OE.

RE: LIRC repeats - CurlyMo - 11th May, 2015 06:34 AM

Did you try stopping lirc altogether?

RE: LIRC repeats - zurdar - 11th May, 2015 02:08 PM

No. Can you elaborate a bit more? What to do, how and how to check then?

RE: LIRC repeats - CurlyMo - 11th May, 2015 08:13 PM

Just stop lirc and check if the problem is gone:
service lirc stop

RE: LIRC repeats - zurdar - 14th May, 2015 10:50 PM

Didn't even think about it, but of course will check. But isn't lirc service necessary for GPIO IR remote to work??

RE: LIRC repeats - CurlyMo - 15th May, 2015 12:00 AM

Depends. XBMC has a lirc like implementation itself. If both standalone Lirc and XBMC Lirc are triggered by the same remote you get double keypresses.

RE: LIRC repeats - zurdar - 15th May, 2015 05:20 AM

Just checked it and as I suspected remote just stopped working. Interesting is that TV remote (via CEC interface) works without any issues.

RE: LIRC repeats - CurlyMo - 16th May, 2015 12:41 AM

Did you try the various supress repeat settings? Google for them.

RE: LIRC repeats - zurdar - 16th May, 2015 12:43 AM

Yest tried them. But in IRW I don't have multiple keypresses even with supress repeat = 2. In KODI on the other hand it always skips to every second item. No issue with CEC remote. I think It's some problem with KODI not LIRC but don't know how to debug this.

RE: LIRC repeats - CurlyMo - 16th May, 2015 04:08 AM

Did you try the Kodi supress repeat options.

RE: LIRC repeats - zurdar - 16th May, 2015 05:05 AM

You mean remoterepeat and remotedelay? They have no effect at all neither in Xbian nor in OpenElec.

RE: LIRC repeats - Colin Burton - 11th Aug, 2015 11:58 PM

Did you ever find an answer to this? I just setup my remote and encountered the same issue.

RE: LIRC repeats - zurdar - 12th Aug, 2015 12:25 AM

No. Gave up on XBian and reverted to OE. Much better support and works flawlessly.

RE: LIRC repeats - eauland - 26th Aug, 2015 03:13 AM

I resolve this problem:

I add 2 lines in the rc.local (/etc/rc.local)

modprobe lirc_rpi
/etc/init.d/lirc start