[SOLVED] Bluetooth ok, "hcitool dev" OK, and "No such adapter" - Printable Version

+- Forum (
+-- Forum: Software (/forum-6.html)
+--- Forum: Configuration (/forum-17.html)
+--- Thread: [SOLVED] Bluetooth ok, "hcitool dev" OK, and "No such adapter" (/thread-2981.html)

[SOLVED] Bluetooth ok, "hcitool dev" OK, and "No such adapter" - bolbit - 4th May, 2015 03:16 AM

on my brand new raspberry 2, i have installed the latest img from xbian (XBian_2015.04.04_rpi2), and every thing works as expected (cec, kodi, ..). But i have not been able to get the bluetooth working well with my keyboard. The bluetooth adapter works well with Openelec and everything seems ok on xbian :
xbian@xbian-franck ~ $ hcitool dev
hci0 00:15:83:15:A3:10
xbian@xbian-franck ~ $ sudo hciconfig -a
hci0: Type: BR/EDR Bus: USB
BD Address: 00:15:83:15:A3:10 ACL MTU: 339:8 SCO MTU: 128:2
RX bytes:466 acl:0 sco:0 events:18 errors:0
TX bytes:74 acl:0 sco:0 commands:18 errors:0
Features: 0xff 0x3e 0x85 0x30 0x18 0x18 0x00 0x00
Packet type: DM1 DM3 DM5 DH1 DH3 DH5 HV1 HV2 HV3
Name: ''
Class: 0x000104
Service Classes: Unspecified
Device Class: Computer, Desktop workstation
HCI Version: 2.0 (0x3) Revision: 0xc5c
LMP Version: 2.0 (0x3) Subversion: 0xc5c
Manufacturer: Cambridge Silicon Radio (10)
xbian@xbian-franck ~ $ dmesg | grep -i blue
[ 5.480725] Bluetooth: Core ver 2.19
[ 5.480850] Bluetooth: HCI device and connection manager initialized
[ 5.480899] Bluetooth: HCI socket layer initialized
[ 5.480924] Bluetooth: L2CAP socket layer initialized
[ 5.480946] Bluetooth: SCO socket layer initialized
[ 5.980642] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
[ 5.980671] Bluetooth: BNEP filters: protocol multicast
[ 5.980724] Bluetooth: BNEP socket layer initialized
[ 15.380507] Bluetooth: RFCOMM TTY layer initialized
[ 15.380575] Bluetooth: RFCOMM socket layer initialized
[ 15.380586] Bluetooth: RFCOMM ver 1.11

but :

xbian@xbian-franck ~ $ sudo bluez-simple-agent hci0
Traceback (most recent call last):
File "/usr/bin/bluez-simple-agent", line 102, in <module>
path = manager.FindAdapter(args[0])
File "/usr/lib/python2.7/dist-packages/dbus/", line 70, in __call__
return self._proxy_method(*args, **keywords)
File "/usr/lib/python2.7/dist-packages/dbus/", line 145, in __call__
File "/usr/lib/python2.7/dist-packages/dbus/", line 651, in call_blocking
message, timeout)
dbus.exceptions.DBusException: org.bluez.Error.NoSuchAdapter: No such adapter

note that if i install the stable release (XBian_2015.02.07_rpi2) this command works after the install, but then i get the same error after an upgrade ...! i tried to use the same kernel as the stable img after the update (sudo apt-get install linux-image-bcm2836=3.18.5+-1423158723) but the "no such adapter" is still here....

I want to get kodi & retropie working and the retropie script force an upgrade, and with the upgrade no more bluetooth for my gamepad...

am i the only one with the error ?

RE: Bluetooth ok, "hcitool dev" OK, and "No such adapter" - bolbit - 5th May, 2015 07:48 AM

an update, i just download the latest "stable" witch seems to be the 04.04 version (the old stable was 02.07). and i was able to connect my BT Keyboard just after the fresh install !! after the successful installation of the bt keyboard i reboot, and then, one more time "no such adapter" when i want to reconnect the keyboard :-(... but after a "sudo service bluetooth restart", it works back ! i don't know exactly what was the changes, but it is solved (just have to find a way to auto reconnect now)