[SOLVED] SD movies stutter, HD movies play fine - Printable Version

+- Forum (
+-- Forum: Software (/forum-6.html)
+--- Forum: Kodi (/forum-18.html)
+--- Thread: [SOLVED] SD movies stutter, HD movies play fine (/thread-3006.html)

SD movies stutter, HD movies play fine - flanker - 24th May, 2015 06:21 AM

HW is Pi2.
Running latest version of Xbian (14.2 i believe) with all the updates.
Movie library is on another Pi2 connected via Samba and Ethernet cable.

My problem is as title says. I can play Blueray movies no problem. Yet whenever I try to play 480p movies it stutters like mad. And it's not just the video. Whole UI becomes sluggish.

Tried to downgrade to 14.1.(sudo apt-get install xbian-package-xbmc=14.1-1423177674
) Same results. I'm not 100% sure, but I believe I used to play SD movies without issue a few weeks ago. I did an update 3-4 days ago and there were tons of stuff on the list. I think one of them is messed up.

Only other thing that comes to mind is, maybe I need licences for the codecs in the settings?

Ayone else having such a problem?

<Edit 1> I think I got the problem. All the movies that stutter has AC3 audio codec. Ones with AAC doesn't stutter. Did we get an update to AC3 codec recently?
<Edit 2> MP3 audio encoded videos also stutters, Dolby files don't.
<Edit 3> Did a snapshot restore to a month ago. Didn't help. Updating all again. Also deleted advancedsettings file. I used to have caching related stuff in it. Also didn't help.
<Edit 4> Enabled debugging. FPS counter shows solid 24 fps yet what I'm getting at is definitely not 24fps. CPUs don't go above 20% While looking at the log files I noticed some weird stuff going on with FFmpeg. Someone more knowledgable could make something out of it hopefully... Debug file is attached.

<Edit 5> Fixed! Reverted all playback options and video options to default and increased buffer size. Now it's working as it should. I wonder what caused it. I'll keep messing with it. Tongue

<Edit 6> Found the culpit. It's my fckin logitech wireless headphones again... I switched to xbian just so that I could use these things, now they are giving me headache here too... Here is the deal: when I output audio tru HDMI I get butter smooth playback. When I route it thru my wireless headphones, I get stutter. I tried passthrough, didn't work. I know that I didn't have such a problem a week ago. So one of the recent updates caused this. I'll keep looking at it.

It's really weird tho, I feel like I'm the only one who uses his pi media station with wireless headphones.

RE: SD movies stutter, HD movies play fine - flanker - 24th May, 2015 08:30 AM

OK. Here is the final situation.

-If I go with default settings for all and use TV's hdmi, all is well.

-If I disable MMAL hardware accel. movie runs smooth with headphones or HDMI. But then I can't watch HD movies(software decoder isn't beefy enough I guess...)

-If I try to watch an SD video with default settings + Headphones as audio output, I get flashing subtitles and choppy video.

Possible Solution: I need an addon that can disable HW acceleration for SD movies and enable them for HD.

RE: SD movies stutter, HD movies play fine - flanker - 26th May, 2015 07:36 AM

Gave up. Switched to OpenElec. The latest beta doesn't seem to have the stable one's cracking sound problem with Logitech headphones.