[PROBLEM] ssh password - Printable Version

+- Forum (
+-- Forum: Software (/forum-6.html)
+--- Forum: Configuration (/forum-17.html)
+--- Thread: [PROBLEM] ssh password (/thread-3037.html)

ssh password - warp2 - 14th Jun, 2015 06:03 AM

Raspberry PI B+ - keybd K400 - HDMI 1280x1024 - Ethernet w fixed IP-Adr
XBian 1.0 - kernel 3.18.8+
Kodi 14.2

This installation works fine as far as I tested it till now. Updates come in w/o problems.

Quote:office@linux-6600:~> ssh xbian @ 192.168....
office@xbian's password:
Permission denied, please try again.
office@xbian's password:

Apparently the connection is OK, however any of the numerous variations of the PW I tried failed and YES:
xbian / raspberry or raspbrrz were the first to fail.

Please let me know how to proceed. Further, is there an easy way to set up a root account and a root PW?

RE: ssh password - Skywatch - 14th Jun, 2015 06:36 AM

Username = xbian
password = raspberry
default port=22

I assume that you have started the ssh service from xbian-config?

I installed a fresh copy today and had no problems with this....


PS Are you sure it's the right ip address? I once spent a long time trying to figure out why I couldn't log in only to find that I had a different pi ip address that wasn't running xbian! Blush

RE: ssh password - deHakkelaar - 14th Jun, 2015 09:13 PM

Drop all the spaces in "ssh xbian @ 192.168...." like so:

ssh xbian@192.168....

RE: ssh password - warp2 - 14th Jun, 2015 09:14 PM

Thank you for coming back right away.

To make sure we do not talk about different matters:

I take it you mean: Confluence => xbian=>Services=>ssh

There is nothing to start or stop but it says "running".

About the IP-Address and login data - I verified them over and over knowing little differences can cause real problems.
The only thing I did not explicitly adjust is port 22.

As far as I see it the ssh starts nicely, the xbian account is found and within the password check things go wrong.
Even this behaves more or less as expected, as it gives me 3 tries and then kicks me out.

I wonder if the German localization I use might be causing it. Do you run the English version out of the box?

RE: ssh password - Skywatch - 14th Jun, 2015 09:30 PM

One thing to try would be to stop kodi/xbmc and from the command prompt type sudo xbian-config.

That will take you to the set up menu where you can check the network settings and what services are running. Maybe it's just a bad install and a fresh install might be another option?


RE: ssh password - deHakkelaar - 14th Jun, 2015 10:26 PM

Hmmm, your making a mistake.
If you type "ssh xbian @ 192.168...." you will be logging into a machine who's hostname is "xbian" as user "office" (see the "office@xbian's password:" bit response).
Ditch the spaces!

RE: ssh password - warp2 - 14th Jun, 2015 10:42 PM

Success - Thank you both of you,

first I tried to find out how to start a CLI

Quote:One thing to try would be to stop kodi/xbmc and from the command prompt type sudo xbian-config.

This was not at all clear for me, as my only way to a command line would be ssh which did not work. While searching for a solution I turned on the advanced option in the Confluence screen.

Thereafter I tried to login without whitespaces as you suggested. And this worked, however, very strange, with "raspberrz". It finally opened the old ANSI-C user interface (for first setup) and allowed to change the password to non critical letters. There is an option to open up a root account which I tried to do but without success. I shall try it again with sudo which is logical from the safety point of view.

Finally a suggestion for improvement (you certainly will have a way to pass it on to the right guys) use absolutely uncritical default passwords such as 1234. There are too many languages in the world to avoid all traps. In the end it is the users responsibility to set up an individual password and only this makes sense.

RE: ssh password - yishay - 29th Jan, 2016 04:47 AM

The user:xbian and Password:raspberry are not valid

RE: ssh password - Smultie - 29th Jan, 2016 05:41 AM

They are the standard. Maybe you changed something?

RE: ssh password - Nachteule - 30th Jan, 2016 12:58 AM

Maybe most common error: wrong keyboard layout y -> z

RE: ssh password - IriDium - 30th Jan, 2016 04:04 AM

"There are too many languages in the world to avoid all traps"

Too true: but every language can never be tested.

By default, it should all work - in this case it becomes apparent that you need to change the locale and keyboard, and then change the password of pi and root to match the keyboard.

Localisation is always going to be a problem, so if it ain't broke - don't fix it.