Network problem with PPPoE-connection - Printable Version

+- Forum (
+-- Forum: Hardware (/forum-7.html)
+--- Forum: Network (/forum-25.html)
+--- Thread: Network problem with PPPoE-connection (/thread-315.html)

Network problem with PPPoE-connection - Yhdiste - 23rd Jan, 2013 05:32 AM

Problem: Xbian cannot connect to the Internet.

Basic info:
XBMC version: XBMC 12.0-RC1 Git:2012212-afbae11 (Compiled Dec 13 2012).
Overclocked/Turbo: No.
Power Supply Rating: 5.0V,  1A
USB connections: 0
Network: LAN
SD card: SanDisk Extreme 4GB (30MB/s) - Class 10

Additional info:
I have a PPPoE-connection, whichh requires username and password. I cannot seem to find a place where I could do this on the Xbian.

Contents of /etc/network/interfaces:
auto lo

iface lo inet loopback
iface eth0 inet dhcp

allow-hotplug wlan0
iface wlan0 inet manual
wpa-roam /etc/wpa_supplicant/wpa_supplicant.conf
wireless-power off
iface default inet dhcp

I had the same problem on the "Raspbian wheezy", which I solved by installing "pppoeconf" from a USB-stick. However, I cannot install it for Xbian because of dependency errors such as:
pppoeconf : Depends: gettext-base (>= 0.13) but it is not installable

The solution:
A network-manager software, which supports PPPoE-connections (is there any?)

Would I get it working by installing ppoeconf on the "wheezy" and copying the contents of "/etc/network/interfaces"-file to the Xbian's file? Or it doesn't really work like that?

Any help is greatly appreciated.

PS: I have tried xbian-config, but it only has two options for LAN and neither one of them "works" for my issue.

RE: Network problem with PPPoE-connection - Koenkk - 25th Jan, 2013 11:35 PM

I can install pppoeconf without any problems here. Be sure to do a apt-get update


xbian@xbian ~ $ sudo apt-get install pppoeconf
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following extra packages will be installed:
gettext-base libasprintf0c2
Suggested packages:
The following NEW packages will be installed:
gettext-base libasprintf0c2 pppoeconf
0 upgraded, 3 newly installed, 0 to remove and 35 not upgraded.
Need to get 214 kB of archives.
After this operation, 1294 kB of additional disk space will be used.
Do you want to continue [Y/n]? y
Get:1 wheezy/main libasprintf0c2 armhf [26.4 kB]
Get:2 wheezy/main gettext-base armhf [138 kB]
Get:3 wheezy/main pppoeconf all 1.20 [50.1 kB]
Fetched 214 kB in 1s (196 kB/s)
Selecting previously unselected package libasprintf0c2:armhf.
(Reading database ... 29195 files and directories currently installed.)
Unpacking libasprintf0c2:armhf (from .../libasprintf0c2_0.18.1.1-9_armhf.deb) ...
Selecting previously unselected package gettext-base.
Unpacking gettext-base (from .../gettext-base_0.18.1.1-9_armhf.deb) ...
Selecting previously unselected package pppoeconf.
Unpacking pppoeconf (from .../pppoeconf_1.20_all.deb) ...
Processing triggers for man-db ...
Setting up libasprintf0c2:armhf ( ...
Setting up gettext-base ( ...
Setting up pppoeconf (1.20) ...

RE: Network problem with PPPoE-connection - Yhdiste - 26th Jan, 2013 04:24 AM

Thanks for your answer Koenkk, however, this does not solve my issue.
As I cannot connect to the Internet, I cannot download any files through apt-get update or with apt-get install pppoeconf.

Either way, thanks to your screenshot, I can now see what files I was missing (libasprintf0c2_0.18.1.1-9_armhf.deb and gettext-base_0.18.1.1-9_armhf.deb).

I can now download them from another computer (where I have a working Internet connection) and store them on the USB-stick. I can then install the files through the USB-stick to the Xbian. The pppoeconf doesn't seem to show text for me, but that is fine, since I know what it should say. I have now successfully configured my PPPoE-connection and it works!

I really appreciate the time you took to help me. Thank you once again!

The moderators can now mark this as solved.