[SOLVED] Loss of Video during Boot - 15.2 - Xbian add-on error - Printable Version

+- Forum (
+-- Forum: Software (/forum-6.html)
+--- Forum: Installation (/forum-16.html)
+--- Thread: [SOLVED] Loss of Video during Boot - 15.2 - Xbian add-on error (/thread-3211.html)

Loss of Video during Boot - 15.2 - Xbian add-on error - StartledCat - 6th Nov, 2015 03:18 AM

I thought it time to upgrade (with the 14.x updates not performing as they should) went of the latest img 2015-10-31.

But, during startup, the boot screen switches off near the end of the Loading Kodi splash screen....tried the other video socket on the pi, but still no joy.

Checked the config.txt files on both versions - they are the same...the 14.x boots fine and displays ok, 15.2 starts off ok, but then loses the display (still getting sound).

Thought it might be the card, so tried a trusted one - still no joy.
Reverted back to the previous img - still not joy.

To recap - starts off ok but then drops the hdmi video.

Raspberry Pi 2 - HMDI->RCA->Panasonic TX-26LXD1

Power all ok - known to be working with the same config.txt what has changed? KODI? There must be some setting I've not found that can be set on sd card in this or another file?

RE: Loss of Video during Boot - 15.2 - StartledCat - 6th Nov, 2015 05:35 AM

I've trimmed down the config, basically enabling the disables...config.txt is now:

initramfs initramfs.gz 0x1000000

kodi.log file in the attached:

RE: Loss of Video during Boot - 15.2 - StartledCat - 7th Nov, 2015 03:13 AM

Having tested a bit more and on checking settings, the video is being reset to 640x480 (that's what I'm getting from /opt/vc/bin/tvservice -s)....however, my settings are also supported (/opt/vc/bin/tvservice -m CEA).

What is really mad, is that if I try and plug in a VGA via the jack plug (I get nothing) and pull it out, (repeat until something happens...)...then MAYBE....just maybe the video appears on the TV, but this is not a preferred method to get it working!

First up, a version check message it's telling me I have 15.2 rc3 whilst v15.2 stable is available - so am guessing the Xbian img has the wrong/old kodi version in it? Can anyone confirm/deny?

Secondly, Setting->Xbian does not work...neither does Programs Xbian-config 1.1.8

But, I have managed to change the kodi settings and (at last) it boots up.

So, looks like a hdmi hotplug event sorted out the display, but still do not have xbian (to sort out the wifi) - there may be something in the log file...yep, here it is:

17:11:18 134.221085 T:1797792688 ERROR: EXCEPTION Thrown (PythonToCppException) : -->Python callback/script returned the following error<--
Error Type: <class 'bsddb.db.DBFileExistsError'>
Error Contents: (17, 'File exists -- BDB0002 __fop_file_setup: Retry limit (100) exceeded')
Traceback (most recent call last):
File "/usr/local/share/kodi/addons/plugin.xbianconfig/", line 7, in <module>
from services.firstrun import firstrun
File "/usr/local/share/kodi/addons/plugin.xbianconfig/services/", line 5, in <module>
from resources.lib.utils import *
File "/usr/local/share/kodi/addons/plugin.xbianconfig/resources/lib/", line 2, in <module>
from xbianconfig import xbianConfig
File "/usr/local/share/kodi/addons/plugin.xbianconfig/resources/lib/", line 27, in <module>
cacheDB =,CACHEFILE),'c',writeback=True)
File "/usr/lib/python2.7/", line 239, in open
return DbfilenameShelf(filename, flag, protocol, writeback)
File "/usr/lib/python2.7/", line 223, in __init__
Shelf.__init__(self,, flag), protocol, writeback)
File "/usr/lib/python2.7/", line 85, in open
return, flag, mode)
File "/usr/lib/python2.7/", line 18, in open
return bsddb.hashopen(file, flag, mode)
File "/usr/lib/python2.7/bsddb/", line 364, in hashopen, db.DB_HASH, flags, mode)
DBFileExistsError: (17, 'File exists -- BDB0002 __fop_file_setup: Retry limit (100) exceeded')
-->End of Python script error report<--

RE: Loss of Video during Boot - 15.2 - Xbian add-on error - StartledCat - 18th Nov, 2015 02:14 AM

Still an issue with the latest build...and all those before...anyone out there?

RE: Loss of Video during Boot - 15.2 - Xbian add-on error - CurlyMo - 19th Nov, 2015 05:25 AM

You need to poll @hackedbellini

RE: Loss of Video during Boot - 15.2 - Xbian add-on error - StartledCat - 28th Nov, 2015 08:09 AM

Currently using OSMC as that works :-) but would prefer Xbian :-(

RE: Loss of Video during Boot - 15.2 - Xbian add-on error - StartledCat - 28th Nov, 2015 10:49 PM

OK, started today thinking about what is happening, and came to the conclusion that the install is losing the video at the end of Starting Kodi and just before the Xbian setup bits. Subsequent reboots with or without video were prone to disaster due the the missing/mis-configured Xbian during setup i.e. user interaction required, but no video.

Back to the drawing board....with another RPi2, an HDMI to VGA adapter and a 7" car monitor, I started again with the 24/11 img file.

So far, this is working, but if I plug the SD card into my main Xbian setup (RPi2, HDMI to RCA, Panasonic TV) it still fails at the same point and the video is gone (but not audio).

Back to the test setup - the screen res setting in KODI/Xbain is telling me it's 0,0 ...changed to something else and lost the video. Rebooted and it's back.

But at least I have a SD card I can have more faith in.

I will do some more testing later today and let you know if I have any joy in getting it working on my main setup.....

RE: Loss of Video during Boot - 15.2 - Xbian add-on error - StartledCat - 30th Nov, 2015 04:49 AM

...following on from further testing...err not sure what is going on at all Huh, but have taken the following steps:

1. booted....Xbian startup screens showing, video lost at end of Starting KODI;
2. booted with NO HDMI cable connected. Reconnected HDMI cable are a cuple of minutes - KODI up and running.
3. reboot - same as #1
4. redo #2, check/change KODI system settings...
5. I get no video during XBain startup, but do get video when KODI starts

Anyone know what is going on? There must be some setting that I have overlooked?

Seems to be losing network connection (wlan) on each reboot i.e. have to re-selected and enter pwd each boot. Error on screen but nothing in the main log file.
SSH'd to see under xbian-config - all seems ok APART from Config > Settings > System 4. System locale - just have # [ Letter] to select from e.g.
1 A
2 B
3 C
etc i.e. no locations????

RE: Loss of Video during Boot - 15.2 - Xbian add-on error - StartledCat - 30th Nov, 2015 08:30 PM

Today I tried the latest 29-11 img with my tailored config.txt to force hmdi....and it worked Rolleyes

To be sure, I updated the config.tx, unplugged the HDMI cable and did a first boot...plugged the HDMI in and could then go through the Xbian setup screens.

Have rebooted a number of times and all is as expected Smile

Not sure about the system locale settings - they remain as stated above, but does not seem to have any effect (have left well alone) far so good, hence marked as solved (but no definite confirmation of what went wrong with the previous images).

RE: Loss of Video during Boot - 15.2 - Xbian add-on error - StartledCat - 11th Dec, 2015 08:49 AM

I have just been trying to clean install using the XBian_2015.12.06_rpi2.img - bottom line, it is still causing the loss of video, but can confirm the following:
1. if all plugged in, fails and corrupts the first time installation (xbian missing/corrupt);
2. sd card...
3. Unplug HDMI
4. Power up
5. Wait....
6. Plug in HDMI...
7. ...if waited long enough in step 5, can then go through the Xbian setup ok BUT - could not change the resolution (could before?...but may have changed the config.txt at some point).

Having played a bit more, my one-time-work-around should have had an extra step i.e.

8. Edit config.txt to add new lines:

9. remove hdmi
10. reboot
11. wait...
12. plug in hdmi
13. change resolution under video settings in kodi interface
14. reboot = success!!! i.e. no loss of video