Forum
[SOLVED] CEC stopped working in Kodi - Printable Version

+- Forum (http://forum.xbian.org)
+-- Forum: Software (/forum-6.html)
+--- Forum: Kodi (/forum-18.html)
+--- Thread: [SOLVED] CEC stopped working in Kodi (/thread-3850.html)



CEC stopped working in Kodi - Roy Terhaar - 22nd Oct, 2016 10:11 PM

Software
XBian version:1.0 (knockout) (kernel: Linux 4.6.7+)
XBMC/Kodi version:17.0-BETA4 Git:2016-10-21-b8acb84
Overclock settings:default

Hardware
Device type and model (e.g. Raspberry Pi Model A/B 256/512 MB, CuBox-i i4Pro, ...):RPI 3
Power supply rating:Original power supply adapter
SD card size and make/type:16Gb
Network (Ethernet or wireless):Kodi using Ethernet; wireless adapter active too on different network
Connected devices (TV, USB, network storage, ...):Philips TV, External USB harddisks Seagate and Hitachi

Log files
Link to logfile(s):
13:09:22 52.201862 T:1827103664 DEBUG: GetMappingForDevice - device (2708:1001) mapped to CEC Adapter (type = cec)
13:09:22 52.205425 T:1827103664 ERROR: Detected version of libCEC interface (30001) is lower than the supported version 30100.


Problem description:
CEC used to work and is not working anymore (see error above in kodi.log).
At startup of Kodi it briefly displays same message on screen and basically I can not use the Phillips Remote Control to navigate Kodi. Also in System Settings menu of Kodi, Input -> Peripherals settings is grayed out so not available anymore.
I have had this problem since a few weeks, but I did not have the time yet to dig into it until now.

How to reproduce:
The error message always pops up briefly when (re)starting Kodi.
What I already tried is reinstalling CEC support following this (found in another thread in the forum):
--
sudo apt-get update
dpkg -l | grep cec # this lists all cec packages

sudo dpkg -r --force-all cec-utils libcec libcec-dev libcec3:armhf python-libcec # unstall all cec packages
, ignore everything
sudo apt-get install -f # Should reinstall all cec packages
--

Unfortunately it does not fix the problem.
I googled the error message for any leads, but no success so far.
So right now I don't know what to do to get it fixed.
Any help would be appreciated..

Thanks.


RE: CEC stopped working in Kodi - Nachteule - 22nd Oct, 2016 10:40 PM

Required 3.1 CEC packages are in staging repo. So you have to enable this repo to get them

Terminal

apt-cache policy libcec
libcec:
Installed: 3.1.0.1~xbian-1462859882
Candidate: 3.1.0.1~xbian-1462859882
Package pin: 3.1.0.1~xbian-1462859882
Version table:
*** 3.1.0.1~xbian-1462859882 1001
500 mirror://apt.xbian.org/mirror.txt/ staging/rpi2-jessie armhf Packages
100 /var/lib/dpkg/status
3.0.1-1~xbian-1453442348 1001
500 mirror://apt.xbian.org/mirror.txt/ stable/rpi2-jessie armhf Packages
3.0.1-1~xbian-1438209384 1001
500 mirror://apt.xbian.org/mirror.txt/ stable/rpi2-jessie armhf Packages
3.0.1-1~xbian-1436247103 1001
500 mirror://apt.xbian.org/mirror.txt/ stable/rpi2-jessie armhf Packages



RE: CEC stopped working in Kodi - Roy Terhaar - 22nd Oct, 2016 11:39 PM

Problem is solved!
I added the staging repo in my xbian.list:
deb mirror://apt.xbian.org/mirror.txt stable main rpi2-jessie
deb mirror://apt.xbian.org/mirror.txt staging main rpi2-jessie
#deb mirror://apt.xbian.org/mirror.txt devel main rpi2-jessie

followed by:
sudo apt-get update
sudo apt-get upgrade
sudo reboot

Done


Thanks for the help; thread can be closed.


RE: CEC stopped working in Kodi - Nachteule - 22nd Oct, 2016 11:51 PM

Set to solved


RE: CEC stopped working in Kodi - dgarciam - 23rd Dec, 2016 11:48 PM

(22nd Oct, 2016 10:40 PM)Nachteule Wrote:  Required 3.1 CEC packages are in staging repo. So you have to enable this repo to get them

Terminal

apt-cache policy libcec
libcec:
Installed: 3.1.0.1~xbian-1462859882
Candidate: 3.1.0.1~xbian-1462859882
Package pin: 3.1.0.1~xbian-1462859882
Version table:
*** 3.1.0.1~xbian-1462859882 1001
500 mirror://apt.xbian.org/mirror.txt/ staging/rpi2-jessie armhf Packages
100 /var/lib/dpkg/status
3.0.1-1~xbian-1453442348 1001
500 mirror://apt.xbian.org/mirror.txt/ stable/rpi2-jessie armhf Packages
3.0.1-1~xbian-1438209384 1001
500 mirror://apt.xbian.org/mirror.txt/ stable/rpi2-jessie armhf Packages
3.0.1-1~xbian-1436247103 1001
500 mirror://apt.xbian.org/mirror.txt/ stable/rpi2-jessie armhf Packages

I have used "devel" repo in order to install beta/rc versions of kodi. Now, what can i find on staging repo? bleeding edge alpha stuff?


RE: CEC stopped working in Kodi - Nachteule - 23rd Dec, 2016 11:56 PM

We have 3 active repos:

1) Stable: Packages which are safe for use
2) Staging: mostly stable package, will be moved to stable soon
3) Devel: Development packages or new packages which have to be tested more. Use it for your own risk


RE: CEC stopped working in Kodi - Yaodgelo - 7th Oct, 2017 05:53 AM

What I read I really liked it. Thank you for your information!
192.168.l.0