Forum
Xbian-copier not working.... - Printable Version

+- Forum (http://forum.xbian.org)
+-- Forum: Software (/forum-6.html)
+--- Forum: Configuration (/forum-17.html)
+--- Thread: Xbian-copier not working.... (/thread-3955.html)

Pages: 1 2 3


Xbian-copier not working.... - Skywatch - 11th Jan, 2018 03:05 AM

After a big power outage and dsl down for over a day I am back getting things put back again.

One task was to copy Xbian system img to USB for booting pi - but it is not working from Xbian-config.

When I select option 6 xbian copier, it just goes straight back to the menu! - Any ideas? Pi is a pi2 update today before this was tried....


RE: Xbian-copier not working.... - Nachteule - 11th Jan, 2018 06:00 AM

Tell me exactly what you are entering into field destination


RE: Xbian-copier not working.... - Skywatch - 11th Jan, 2018 06:13 AM

I can't even get that far.... Sad

I use xbian-config, option 6 xbian-copier and it goes right back to the main xbian-config menu....I do have a usb plugged in ready for the copy.

I tried update and reboot, still get that issue. Strange.

I just tried another pi2 and it is doing the same thing..... ???

Now tried all 3 pi2 xbian builds (all slightly different and all updated/upgraded today) and they all exhibit tha same behaviour.


RE: Xbian-copier not working.... - Nachteule - 11th Jan, 2018 09:31 AM

Hmmm, that's weird Huh

Just checked on my test Pi3 (mostly unconfigured), works as it should Dodgy

Could you please post your language settings (sudo locale) and output of sudo dpkg-query -s xbian-package-config-shell

Terminal

root@kmxbilr2 ~ # locale
LANG=en_US.UTF-8
LANGUAGE=
LC_CTYPE="en_US.UTF-8"
LC_NUMERIC="en_US.UTF-8"
LC_TIME="en_US.UTF-8"
LC_COLLATE="en_US.UTF-8"
LC_MONETARY="en_US.UTF-8"
LC_MESSAGES="en_US.UTF-8"
LC_PAPER="en_US.UTF-8"
LC_NAME="en_US.UTF-8"
LC_ADDRESS="en_US.UTF-8"
LC_TELEPHONE="en_US.UTF-8"
LC_MEASUREMENT="en_US.UTF-8"
LC_IDENTIFICATION="en_US.UTF-8"
LC_ALL=en_US.UTF-8
root@kmxbilr2 ~ # dpkg-query -s xbian-package-config-shell
Package: xbian-package-config-shell
Status: install ok installed
Priority: optional
Section: utils
Installed-Size: 3583
Origin: XBian
Maintainer: mk01 <development@xbian.org>
Architecture: armhf
Version: 20180107-0
Replaces: xbian-package-config, xbian-update
Depends: ipcalc, xbian-package-xbianhome, parted, wget, bc, gettext, dialog, btrfs-progs, kpartx, f2fs-tools, xbian-package-xbmc-scripts (>= 1.0.11), at, python-apt
Pre-Depends: anacron, openbsd-inetd, psmisc
Breaks: xbian-package-config-xbmc (<< 1.1.3-6), xbian-package-initramfs-tools (<< 20171220-0)
Conflicts: xbian-package-config
Description: Configuration utility for XBian 20180107-0
root@kmxbilr2 ~ #



RE: Xbian-copier not working.... - Skywatch - 11th Jan, 2018 09:57 PM

(11th Jan, 2018 09:31 AM)Nachteule Wrote:  Hmmm, that's weird Huh

My thoughts too Wink

Terminal

xbian@lounge2 ~ $ sudo locale
[sudo] password for xbian:
LANG=en_US.UTF-8
LANGUAGE=
LC_CTYPE="en_US.UTF-8"
LC_NUMERIC="en_US.UTF-8"
LC_TIME="en_US.UTF-8"
LC_COLLATE="en_US.UTF-8"
LC_MONETARY="en_US.UTF-8"
LC_MESSAGES="en_US.UTF-8"
LC_PAPER="en_US.UTF-8"
LC_NAME="en_US.UTF-8"
LC_ADDRESS="en_US.UTF-8"
LC_TELEPHONE="en_US.UTF-8"
LC_MEASUREMENT="en_US.UTF-8"
LC_IDENTIFICATION="en_US.UTF-8"
LC_ALL=en_US.UTF-8
xbian@lounge2 ~ $ sudo dpkg-query -s xbian-package-config-shell
Package: xbian-package-config-shell
Status: install ok installed
Priority: optional
Section: utils
Installed-Size: 3583
Origin: XBian
Maintainer: mk01 <development@xbian.org>
Architecture: armhf
Version: 20180107-0
Replaces: xbian-package-config, xbian-update
Depends: ipcalc, xbian-package-xbianhome, parted, wget, bc, gettext, dialog, btrfs-progs, kpartx, f2fs-tools, xbian-package-xbmc-scripts (>= 1.0.11), at, python-apt
Pre-Depends: anacron, openbsd-inetd, psmisc
Breaks: xbian-package-config-xbmc (<< 1.1.3-6), xbian-package-initramfs-tools (<< 20171220-0)
Conflicts: xbian-package-config
Description: Configuration utility for XBian 20180107-0



RE: Xbian-copier not working.... - Nachteule - 12th Jan, 2018 12:35 AM

So, seems to be identical. Did you already tried to reinstall this package?

I'm sorry, but at the moment I do not have a better idea ...

Ah, hold on. I know what the problem is:

Your ssh window is too small. I enlarged the copier window to 82x29, and it seems it does not fit into your screen

Terminal

root@kmxbilr2 ~ # stty size
32 92
root@kmxbilr2 ~ #


Shows your screen size inside of a ssh session

Maybe it would be good idea to check the size and print a warning message Tongue


RE: Xbian-copier not working.... - Skywatch - 12th Jan, 2018 01:57 AM

(12th Jan, 2018 12:35 AM)Nachteule Wrote:  Ah, hold on. I know what the problem is:

Bingo! Smile -- You got it!

But now I get 'fail' message instead! Sad
I have target set to "file: /dev/sda1" as well as the usual "/dev/sda1" and both say error....?

(12th Jan, 2018 12:35 AM)Nachteule Wrote:  Your ssh window is too small. I enlarged the copier window to 82x29, and it seems it does not fit into your screen

Of course you could also not bugger about with ssh terminal window size in the first place Tongue

Cheers!


RE: Xbian-copier not working.... - Nachteule - 12th Jan, 2018 02:14 AM

(12th Jan, 2018 01:57 AM)Skywatch Wrote:  You got it! - But now I get 'fail' message instead! Sad
Is it safe to just follow the instuctions in the window still?

Sure, they are correct.

What I did is to check if all commands returning without an error. So, it seems that your copy command was failing

For example, in the past if copying of a subvolume did not work without errors, image was broken but user was not informed about that

Did you use file: prefix in the destination field?


RE: Xbian-copier not working.... - Skywatch - 12th Jan, 2018 02:38 AM

Tried with and without file prefix (as per last post) Tongue


RE: Xbian-copier not working.... - Nachteule - 12th Jan, 2018 02:43 AM

And your root (source device) is on ... ?

Terminal

root@kmxbilr2 ~ # sudo findmnt -n /
/ /dev/sda8[/root/@] btrfs rw,noatime,compress=lz4,space_cache,autodefrag,subvolid=258,subvol=/root/@
root@kmxbilr2 ~ #



RE: Xbian-copier not working.... - Skywatch - 12th Jan, 2018 02:46 AM

"wrong destination block or is not a device" - This is what I just got copying to /dev/sda1.... but....


Terminal

xbian@lounge2 ~ $ lsusb
Bus 001 Device 004: ID 0781:5571 SanDisk Corp. Cruzer Fit
Bus 001 Device 005: ID 1d57:0008 Xenta
Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp. SMSC9512/9514 Fast Ethernet Adapter
Bus 001 Device 002: ID 0424:9514 Standard Microsystems Corp. SMC9514 Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

So device is there..... Only other usb is the Xenta usb wireless mouse receiver.

I got it - Darned thing was mounted as sda5! - Sorry!


RE: Xbian-copier not working.... - Nachteule - 12th Jan, 2018 02:49 AM

And you're sure that /dev/sda1 exists?

Terminal

root@kmxbilr2 ~ # sudo lsblk
NAME MAJ:MIN RM SIZE RO TYPE MOUNTPOINT
sda 8:0 0 18.6G 0 disk
├─sda1 8:1 0 63M 0 part /media/RECOVERY
├─sda2 8:2 0 1K 0 part
├─sda5 8:5 0 32M 0 part /media/SETTINGS
├─sda6 8:6 0 5G 0 part /media/root
├─sda7 8:7 0 8.9G 0 part /media/kmxbilr2-usb-root
├─sda8 8:8 0 2.5G 0 part /xbmc-backup
├─sda9 8:9 0 1.8G 0 part /media/kmxbilr2-usb-le
└─sda10 8:10 0 335.2M 0 part [SWAP]
sdb 8:16 0 55.9G 0 disk
└─sdb1 8:17 0 55.9G 0 part
mmcblk0 179:0 0 14.9G 0 disk
├─mmcblk0p1 179:1 0 63M 0 part
├─mmcblk0p2 179:2 0 1K 0 part
├─mmcblk0p5 179:5 0 32M 0 part
├─mmcblk0p6 179:6 0 66M 0 part
├─mmcblk0p7 179:7 0 63M 0 part
├─mmcblk0p8 179:8 0 63M 0 part /boot
├─mmcblk0p9 179:9 0 512M 0 part
├─mmcblk0p10 179:10 0 63M 0 part
└─mmcblk0p11 179:11 0 63.6M 0 part
zram0 254:0 0 128M 0 disk [SWAP]



RE: Xbian-copier not working.... - Skywatch - 12th Jan, 2018 02:54 AM

See my previous post Tongue


RE: Xbian-copier not working.... - Nachteule - 12th Jan, 2018 02:56 AM

... was reading it already ... Rolleyes


RE: Xbian-copier not working.... - Skywatch - 12th Jan, 2018 03:17 AM

Heheh..... Wink

Strange as it's always been sda1 since the first time I added usb for running this pi (and the other 2 systems as well) - So not sure why suddenly it decided to do this, but a quick df and it was obvious what the problem probably was.

Now copy completed and so I changed /boot/cmdline.txt to sda5......rebooted....Nothing!

I'll investigate this more when I can. No worries.

Cheers again