bluetooth device address showing AA:AA:AA:AA:AA:AA - Printable Version

+- Forum (
+-- Forum: Hardware (/forum-7.html)
+--- Forum: Video and Audio (/forum-28.html)
+--- Thread: bluetooth device address showing AA:AA:AA:AA:AA:AA (/thread-4036.html)

bluetooth device address showing AA:AA:AA:AA:AA:AA - feign - 24th Jun, 2019 07:50 PM

Hi all.

my bluetooth on latest bian on RPi 3. is not working. I can manipulate it through bluetoothctl but nothing can connect. And the address is showing all As. As shown here:

root@xbian ~ # bluetoothctl
[NEW] Controller AA:AA:AA:AA:AA:AA xbian [default]
root@xbian ~ # hciconfig -a
hci0:   Type: BR/EDR  Bus: UART
        BD Address: AA:AA:AA:AA:AA:AA  ACL MTU: 1021:8  SCO MTU: 64:1
        UP RUNNING
        RX bytes:1032 acl:0 sco:0 events:49 errors:0
        TX bytes:2252 acl:0 sco:0 commands:49 errors:0
        Features: 0xbf 0xfe 0xcf 0xfe 0xdb 0xff 0x7b 0x87
        Packet type: DM1 DM3 DM5 DH1 DH3 DH5 HV1 HV2 HV3
        Link policy: RSWITCH SNIFF
        Link mode: SLAVE ACCEPT
        Name: 'xbian'
        Class: 0x000000
        Service Classes: Unspecified
        Device Class: Miscellaneous,
        HCI Version: 4.1 (0x7)  Revision: 0x0
        LMP Version: 4.1 (0x7)  Subversion: 0x2209
        Manufacturer: Broadcom Corporation (15)

root@xbian ~ # uname -a
Linux xbian 4.19.50+ #1 SMP PREEMPT Mon Jun 17 11:52:13 CEST 2019 armv7l GNU/Linux

I've tried searching for this solution but found only that i should downgrae bluez to 5.23 which i tried to do from bluez source and it didn't work. I'm not sure this is also a valid solution.

On previous version (based on debian jessie) all worked good an address was shown normal.

Thank you

RE: bluetooth device address showing AA:AA:AA:AA:AA:AA - Nachteule - 26th Jun, 2019 05:21 AM

Hmmm, just looked here (Pi3B+). BT is working as expected

Could you please replace /etc/init/rpi-bluetooth.conf with this file and try again