[PROBLEM] Losing sound with pulseaudio - Printable Version

+- Forum (
+-- Forum: Software (/forum-6.html)
+--- Forum: Kodi (/forum-18.html)
+--- Thread: [PROBLEM] Losing sound with pulseaudio (/thread-4159.html)

Losing sound with pulseaudio - grandcanyon - 1st Jan, 2023 03:41 PM

I just installed Xbian and then I enabled the repo to install Nexus on a RPi 3+. I've been using kodi for awhile as I originally was on arch and then I moved to Raspberry OS Lite. I wanted a complete OS/Kodi system that allows some flexibility with adding packages so I went with Xbian. On Arch and Rpi OS Lite, I was dogged by issues with inputstream.ffmpedirect since I had to compile it. I followed the instructions but still ended up with intermittent issues. I've also had issues with pulseaudio

I am still having issues where pulseaudio drops out on Xbian. I just want pulseaudio so I can connect my BT headphones every so often. I have my Rpi connected to my TV with an HDMI cable. Sometimes when I have PA issues with Xbian I can just change the audio profile to a different source like PI: HDMI and for some reason a bit later I can switch to the Default PA profile and it starts working again. Sometimes I lose audio completely and have to reboot (log said something about can't flush) The kodi log was complaining about the passthrough module not being loaded so I added this to the /etc/pulse/ Kodi does seem to work best for pulseaudio when I set it to default PA and enable passthrough to PI:HDMI.

Anyone have any tips. I guess I could keep the audio profile at PI:HDMI and just switch to default (pulseaudio when I need to connect my headphones as they connect automatically when I turn them on and kodi will pipe it out to the headphones if I'm set to default pulse audio profile.

RE: Losing sound with pulseaudio - Nachteule - 2nd Jan, 2023 03:10 AM

My impression is that you have a general problem with your BT headphones or you have a very bad BT connection.

RE: Losing sound with pulseaudio - grandcanyon - 2nd Jan, 2023 10:39 AM

(2nd Jan, 2023 03:10 AM)Nachteule Wrote:  My impression is that you have a general problem with your BT headphones or you have a very bad BT connection.

Thanks for the help. I have issues without the BT headphones connected. If the profile is set to default pulseaudio, I will eventually lose audio without ever connecting the headphones.

RE: Losing sound with pulseaudio - Nachteule - 3rd Jan, 2023 05:09 AM

Aha, but I still think you have a general hardware problem.
As a test I switched to Pulseaudio on my Pi3+ for a while. But do not think that leads to problems here

Something else about passthrough:
If you enable this on PI:HDMI, it will only affect this device. So if you switch to Pulseaudio, this setting is completely irrelevant.

This must be activated differently, see for example
how this should work without running X desktop I can't tell you. But it doesn't matter, as long as Pulseaudio doesn't run stable in general it's a wasted time to deal with passthrough further

RE: Losing sound with pulseaudio - grandcanyon - 4th Jan, 2023 10:34 AM

Thanks for the help. I disabled the passthrough. I don't remember ever enabling it but I did see some errors in the kodi.log complaining about not having the module loaded so I added it to the

I installed Audio Profiles and I am switching to pulseaudio when I need my headphones and back to I assume alsa (PI:HDMI) when I am done. I'd rather do this instead of ssh'ing in and rebooting. I am glad xbian gives me the choice. I'll probably try just going pulseaudio to see if it works as I've been tinkering with my kodi system. I'm using wifi and on board BT. I thought there was a bug with the Rpi 3+ that caused issues. At least on Rpi OS Lite, PA would go south on me sometime after I switched off my headphones.

Thanks for proving a solid OS integrated Kodi system.