[PROBLEM] LIRC doesnt load custom lircd.conf - Printable Version

+- Forum (
+-- Forum: Software (/forum-6.html)
+--- Forum: Configuration (/forum-17.html)
+--- Thread: [PROBLEM] LIRC doesnt load custom lircd.conf (/thread-901.html)

LIRC doesnt load custom lircd.conf - xternal - 15th May, 2013 05:33 PM

I have an issue where when i start the lirc using the init.d script i.e
sudo service lirc start or restart

it loads just fine but it doesnt seem to read my lircd.conf in /etc/lirc. If I do irw nothing shows up.

however if i manually start lirc with

lircd /etc/lirc/lircd.conf

irw works perfectly. However xbmc doesnt recongnise it now as lirc didnt start before xbmc.
Any ideas why this would be, or how i can force the init.d script to call /etc/lirc/lircd.conf

Banging my head on this one! HahaHuh

Well I figured out how to "fix" the lirc init.d script, if anyone else wants to use a custom remote with a supported receiver.

Where start-stop-daemon executes lircd i changed the
-- /etc/lirc/lircd.conf

I then had to copy /usr/local/share/xbmc/system/Lircmap.xml to ~/.xbmc/userdata/Lircmap.xnl

You then edit that xml file and either change the <remote device="mceusb"> line to <remote device="YOUR REMOTE NAME"> or if your remote has different layout/buttons to a stock mceusb remote you can customize the Lircmap.xml file to suit you/change the name on one of the other ones if its similar to your custom remote.

Im using a hauppauge remote which is pretty much identical to a mce remote.

Use irrecord to generate a custom lircd.conf file if you dont have one for your remote all ready.

RE: LIRC doesnt load custom lircd.conf - IriDium - 13th Aug, 2013 02:40 AM

Glad you found your own solution. Can you change the status from "Problem" to "Solved"

RE: LIRC doesnt load custom lircd.conf - mk01 - 13th Aug, 2013 04:10 AM

(13th Aug, 2013 02:40 AM)IriDium Wrote:  Glad you found your own solution. Can you change the status from "Problem" to "Solved"

this probably should be on the plan to beta2. I migrated most of the sysvinit scripts to upstart, lirc and iguana are not.

second issue was, that /etc/modules file was by bug emptied with beta1. for lircd successful start, the right module needs to be loaded before. with empty modules file, nothing is loaded, so lircd can't auto detect the device : right config file.

i'm going to move lirc to upstart, but have no device to test.

can you please elaborate more, check the /etc/modules file, if not put your module in, reboot, check how lircd start works now etc.

can you please ?