Thank you for your donation


Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Hifiberry
30th Sep, 2014, 06:23 PM
Post: #16
RE: Hifiberry
@Gunnarhaus,

I tried this at the weekend and it doesn't work currently. Tried on 2 pi's with the the same issue.

If you do try it then let us know how you get on!

Skywatch
Find all posts by this user
Quote this message in a reply
30th Sep, 2014, 07:23 PM
Post: #17
RE: Hifiberry
(30th Sep, 2014 06:23 PM)Skywatch Wrote:  @Gunnarhaus,

I tried this at the weekend and it doesn't work currently. Tried on 2 pi's with the the same issue.

If you do try it then let us know how you get on!

Skywatch

What have you done so far?

First install alsa-base and alsa-utils and then the package?
Or did you only install the package?

(30th Sep, 2014 06:23 PM)Skywatch Wrote:  @Gunnarhaus,

I tried this at the weekend and it doesn't work currently. Tried on 2 pi's with the the same issue.

If you do try it then let us know how you get on!

Skywatch

What have you done so far?

First install alsa-base and alsa-utils and then the package?
Or did you only install the package?
Find all posts by this user
Quote this message in a reply
30th Sep, 2014, 09:04 PM
Post: #18
RE: Hifiberry
I can see the Hifiberry in Xbmc (system-settings-audio output) .

Now i can select between Pi:HDMI , Pi:Analog , ALSA:Default (snd_rpi_hifiberry_dac Analog) !


BUT, if select last one (ALSA:Default (snd_rpi_hifiberry_dac Analog)) my System crashes/freezes (no ssh possible)!
Have to plug out the Powersupply and plug in to reboot. Then the Audio Output is again at Pi:HDMI .

What is this?????

I wrote these lines to /etc/modules :
snd_soc_bcm2708
snd_soc_bcm2708_i2s
bcm2708_dmaengine
snd_soc_pcm5102a
snd_soc_hifiberry_dac

Any other type of modules dont show me the hifiberry in audio output.

And only with these modules i can see the hifiberry in aplay -l .


What to do now???
Find all posts by this user
Quote this message in a reply
1st Oct, 2014, 03:15 AM
Post: #19
RE: Hifiberry
Has anybody an idea, what to do now?
Find all posts by this user
Quote this message in a reply
1st Oct, 2014, 04:45 AM
Post: #20
RE: Hifiberry
I tried a straight forward SSH upgrade via Xbian-config and that had dependancy issues.

Then I installed alsa utils (which also installs alsa-base) and tried again, and again, and again. No Luck....It installed but no option in the audio menu under xbmc (did you have the dac connected when doing the alsa upgrade?).

After removing xbmc alsa package and rebooting and then confirming it's removal in xbian-config, it is still offered as an upgrade in xbian-config upgrade option.

But you did get a little further then me! Smile

Skywatch
Find all posts by this user
Quote this message in a reply
1st Oct, 2014, 04:56 AM
Post: #21
RE: Hifiberry
The DAC+ ist always connected.

i`m also talking to the dev of hifiberry and he said, that some driver must be on the blacklist.

BUT where can i found a blacklist in xbian? is it always under /etc/modprobe.de/ ... .conf ???

ok, found blacklist under /etc/modprobe.d/xbian.conf .

ok, after edit blacklist, same procedure as before. i dont know where the problem is....
Find all posts by this user
Quote this message in a reply
1st Oct, 2014, 06:26 AM
Post: #22
RE: Hifiberry
0xFF got his working, but that might have been on RC2, I'm not sure.

I am on RC3 with XBMC 13.2 - I guess you are on the same.

Have you tried to install volumio to test if it works? That will be my next step.

Skywatch
Find all posts by this user
Quote this message in a reply
1st Oct, 2014, 06:33 AM
Post: #23
RE: Hifiberry
I haven't tried Volumio. You think it'd run?
Find all posts by this user
Quote this message in a reply
1st Oct, 2014, 07:03 AM
Post: #24
RE: Hifiberry
Not with Xbian, it's a stand alone hifi audio player and I don't have a spare empty SD card to use to test it.

Maybe tomorrow I will backup Xbian and try and install volumio just to prove that the hardware works and to see if it's any good ( I have 2 different DACs to test now).

Sorry I can't offer a solution to the problem. - But if we both post our experiences and logs on git there's a good chance that it will get some attention.

Skywatch.
Find all posts by this user
Quote this message in a reply
1st Oct, 2014, 04:52 PM
Post: #25
RE: Hifiberry
(1st Oct, 2014 07:03 AM)Skywatch Wrote:  Not with Xbian, it's a stand alone hifi audio player and I don't have a spare empty SD card to use to test it.

Maybe tomorrow I will backup Xbian and try and install volumio just to prove that the hardware works and to see if it's any good ( I have 2 different DACs to test now).

Sorry I can't offer a solution to the problem. - But if we both post our experiences and logs on git there's a good chance that it will get some attention.

Skywatch.


My Kernel was 3.15.8+ , now i saw on github this message:

"rpi: update config for 3.16.2. Untested yet.
Changes:
* disabled MEMCG_KMEM as it's marked as "incomplete" and "under development";
* enable support for Hifiberry+ (module);
* enable new BCM2835 MMC driver. Speed improvements were noticed, no issues were reported so far. "


How can i make an update via github, to get the latest kernel of 3.16.2 ???
Find all posts by this user
Quote this message in a reply
1st Oct, 2014, 05:04 PM
Post: #26
RE: Hifiberry
Being patient.

pilight - modular domotica solution
Visit this user's website Find all posts by this user
Quote this message in a reply
1st Oct, 2014, 05:53 PM
Post: #27
RE: Hifiberry
It's my Birthday in a week, will it be ready for then? Smile

Skywatch
Find all posts by this user
Quote this message in a reply
1st Oct, 2014, 05:59 PM
Post: #28
RE: Hifiberry
Let's hope so. Just consider it a birthday present already that there is actually a xbmc alsa version available although experimental.

pilight - modular domotica solution
Visit this user's website Find all posts by this user
Quote this message in a reply
1st Oct, 2014, 07:27 PM
Post: #29
RE: Hifiberry
But in general, how do i update via github (xbiab-package-kernel)?

I'm at the beginning of learning about the pi... So i don't know everything. I have to read very very very much to understand those linux things....
Find all posts by this user
Quote this message in a reply
2nd Oct, 2014, 03:40 AM
Post: #30
RE: Hifiberry
we`ll wait until the update comes. Then try again.

can i get the update through xbian-config?
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump: