Thank you for your donation


Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[1.0RC3] XBMC keeps restarting
19th Oct, 2014, 12:49 AM
Post: #31
RE: [1.0RC3] XBMC keeps restarting
So I experienced the same problem if you continue to experience this problem edit: /etc/init/xbmc-failed-start.conf

This script typically waits 100 seconds running a status check on xbmc, if the status is still pending or not started it forcefully kills xbmc.

To fix simply adjust the line:
exec sleep 100

replace with

exec sleep 300

This will increase the wait time to 300 seconds.

The core issue here is when you start installing plugins. They slow the boot up time of xbmc.
Find all posts by this user
Quote this message in a reply
24th Oct, 2014, 07:28 PM
Post: #32
RE: [1.0RC3] XBMC keeps restarting
Many thanks for this information. I had to roll back to a working snapshot (RC2) and haven't had a chance to look at this again until now. I installed all the updates since RC2 to make sure I was on the latest release and the XBMC restarts came back as before. I changed the value to 300 as you suggested but this didn't fix my issue. In frustration I decided to try 900 just to be sure that my problem was completely different, and ... no restarts ... everything solid and running fine. I'm sure that the value doesn't need to be that large, but I required a number bigger than 300.

I'm betting that the XBMC restarts which a number of people are affected by is exactly this issue - I use samba and that's working fine so the on-screen messages appear to be a red herring as previously suggested.

(19th Oct, 2014 12:49 AM)junwin Wrote:  So I experienced the same problem if you continue to experience this problem edit: /etc/init/xbmc-failed-start.conf

This script typically waits 100 seconds running a status check on xbmc, if the status is still pending or not started it forcefully kills xbmc.

To fix simply adjust the line:
exec sleep 100

replace with

exec sleep 300

This will increase the wait time to 300 seconds.

The core issue here is when you start installing plugins. They slow the boot up time of xbmc.
Find all posts by this user
Quote this message in a reply
25th Oct, 2014, 10:33 PM
Post: #33
RE: [1.0RC3] XBMC keeps restarting
Seems I spoke too soon .... the next day when I booted the xbmc restarts returned. I've increased the timeout in xbmc.conf now as well and the restarts appear to have initially stopped again - I'll see if they return.
Find all posts by this user
Quote this message in a reply
14th Dec, 2014, 12:47 AM
Post: #34
RE: [1.0RC3] XBMC keeps restarting
(25th Oct, 2014 10:33 PM)badmonkey Wrote:  Seems I spoke too soon .... the next day when I booted the xbmc restarts returned. I've increased the timeout in xbmc.conf now as well and the restarts appear to have initially stopped again - I'll see if they return.

Yeah, takes a little tweaking, the timeout should be enough for all the plugins to release the startup process. Good luck.
Find all posts by this user
Quote this message in a reply
16th Dec, 2014, 05:43 PM
Post: #35
RE: [1.0RC3] XBMC keeps restarting
@all

this issue is caused by combination of few factors and that's why it is not reproducible for all configurations, users and ... a bit confusing.

anyhow with menakite we implemented a fix today. xbmc needs to be recompiled - any xbmc(rpi/imx6) or kodi(rpi/imx6) with suffix higher than -1418714780 (today) should have the fix included (without any additional job conf modding etc).

if anyone install new package and will still feel this issue be present, let us know.

Please read rules and do a search before you post! . FAQs . How to post log file? . Looking for answers? Please start here
Find all posts by this user
Quote this message in a reply
20th Dec, 2014, 01:47 AM
Post: #36
RE: [1.0RC3] XBMC keeps restarting
I think you broke it...

I've never had the whole restart thing happen then I did some updates today and now I'm stuck in the XBMC reboot cycle Sad
Find all posts by this user
Quote this message in a reply
20th Dec, 2014, 01:56 AM
Post: #37
RE: [1.0RC3] XBMC keeps restarting
I installed (today, 19th Dec) the 2014-12-xx image from the xbian-installer, upgraded and have not experienced the reboot issue..

Please read before you post
How to post a log file

If you liked my help, click on "Thanks" to show your appreciation.
Find all posts by this user
Quote this message in a reply
20th Dec, 2014, 02:08 AM
Post: #38
RE: [1.0RC3] XBMC keeps restarting
Just rolled back to a snapshot from a couple of days ago when I last ran the update and fingers crossed it hasn't rebooted so far. I ran the deb upgrades and now it relists xbian-package-config-shell 2.1.15-1 if that helps track down the issue.
Find all posts by this user
Quote this message in a reply
21st Dec, 2014, 01:14 AM
Post: #39
RE: [1.0RC3] XBMC keeps restarting
In my case I solved the reboot issue by downgrading xbian-package-upstart-xbmc-bridge to version 1.1.3:

apt-get install xbian-package-upstart-xbmc-bridge=1.1.3

The problem occurs with versions 1.1.4 and 1.1.6 (and presumably also with 1.1.5) with the older xbmc package (13.2-RLS-1411559513).

On a related note, I noticed that I can get the newer xbmc packages (suffix 1418714780 and higher) by adding component "rpi-wheezy" to the apt.xbian.org repository. Is it recommended to add this component besides the standard "main"?
Find all posts by this user
Quote this message in a reply
21st Dec, 2014, 04:41 AM
Post: #40
RE: [1.0RC3] XBMC keeps restarting
Did you follow the steps described in the frontpage FAQ? That should set the repositories to what they should be on your device.

pilight - modular domotica solution
Visit this user's website Find all posts by this user
Quote this message in a reply
21st Dec, 2014, 07:04 AM
Post: #41
RE: [1.0RC3] XBMC keeps restarting
Thanks for fixing the restart loop.
However I need to run the -alsa package and that one still is on -1418714780 hence I get in the restart loop Sad

Will the alsa package be updated anytime soon or should I give up?

--Sjimmie

(16th Dec, 2014 05:43 PM)mk01 Wrote:  @all

this issue is caused by combination of few factors and that's why it is not reproducible for all configurations, users and ... a bit confusing.

anyhow with menakite we implemented a fix today. xbmc needs to be recompiled - any xbmc(rpi/imx6) or kodi(rpi/imx6) with suffix higher than -1418714780 (today) should have the fix included (without any additional job conf modding etc).

if anyone install new package and will still feel this issue be present, let us know.
Find all posts by this user
Quote this message in a reply
21st Dec, 2014, 09:04 AM
Post: #42
RE: [1.0RC3] XBMC keeps restarting
(21st Dec, 2014 04:41 AM)CurlyMo Wrote:  Did you follow the steps described in the frontpage FAQ? That should set the repositories to what they should be on your device.

My bad, I followed the initial instructions on the forum back then to simply replace brantje with apt.xbian.org and never looked back.
Find all posts by this user
Quote this message in a reply
22nd Dec, 2014, 12:21 AM
Post: #43
RE: [1.0RC3] XBMC keeps restarting
with these latest changes the conf hacks previously required appear to be a thing of the past - cheers
Find all posts by this user
Quote this message in a reply
30th Dec, 2014, 05:56 AM
Post: #44
RE: [1.0RC3] XBMC keeps restarting
(16th Dec, 2014 05:43 PM)mk01 Wrote:  @all

this issue is caused by combination of few factors and that's why it is not reproducible for all configurations, users and ... a bit confusing.

anyhow with menakite we implemented a fix today. xbmc needs to be recompiled - any xbmc(rpi/imx6) or kodi(rpi/imx6) with suffix higher than -1418714780 (today) should have the fix included (without any additional job conf modding etc).

if anyone install new package and will still feel this issue be present, let us know.

I have updated to the latest of everything, and I am still seeing this issue.

(21st Dec, 2014 04:41 AM)CurlyMo Wrote:  Did you follow the steps described in the frontpage FAQ? That should set the repositories to what they should be on your device.

That FAQ is not very clear. Running XBian on a Raspberry Pi, I can't tell if I should have a sources.list file and an xbian.list file, or if the xbian.list file should take care of everything. I have been trying different configurations, and my XBMC continues to restart.

My sources.list:
Code:
#deb http://mirrordirector.raspbian.org/raspbian/ wheezy main contrib non-free rpi
deb http://mirrordirector.raspbian.org/raspbian/ jessie main contrib non-free # rpi

#deb http://xbian.brantje.com jessie main
#deb http://xbian.brantje.com stable main
#deb http://apt.xbian.org stable main
#deb-src http://mirrordirector.raspbian.org/raspbian/ wheezy main contrib non-free rpi

My sources.list.d/xbian.list (after re-installing the xbian-package-repo package):
Code:
deb mirror://apt.xbian.org/mirror.txt stable main
### deb mirror://apt.xbian.org/mirror.txt     staging   main    rpi-n/a
### deb mirror://apt.xbian.org/mirror.txt     devel   main    rpi-n/a

(30th Dec, 2014 05:56 AM)palswim Wrote:  I have updated to the latest of everything, and I am still seeing this issue.

Also, do I have a way to prevent XBMC from trying to restart itself while I troubleshoot this? The constant restarts are causing the system run slower than normal.
Find all posts by this user
Quote this message in a reply
30th Dec, 2014, 08:39 AM
Post: #45
RE: [1.0RC3] XBMC keeps restarting
Can you guys try this:
http://forum.xbian.org/thread-2100-post-25847.html#pid25847

pilight - modular domotica solution
Visit this user's website Find all posts by this user
Quote this message in a reply
Post Reply 


Possibly Related Threads...
Thread: Author Replies Views: Last Post
  [PROBLEM] [1.0RC3] SSH broken, "starting... XBMC" endless loop dafhus 8 7,281 21st Nov, 2014 09:01 AM
Last Post: dafhus

Forum Jump: