Thank you for your donation


Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Problem: TV is waked up by Xbian after TV shutdown
17th Sep, 2015, 05:40 AM
Post: #1
TV is waked up by Xbian after TV shutdown
I have some issue with CEC using lastest xbian version on RPI 2

Software
XBian version: xbian 20150911-3
XBMC/Kodi version: Kodi 15.2-RC2 git:2015-03-13-2d0c3cf
Overclock settings: 900

Hardware
Device type and model (e.g. Raspberry Pi Model A/B 256/512 MB, CuBox-i i4Pro, ...): Rpi 2
Power supply rating: http://www.amazon.fr/Aukru%C2%AE-Alimentation-Chargeur-Adaptateur-Raspberry/dp/B00U88KSHO/ref=pd_bxgy_147_img_y
SD card size and make/type: Samsung 32 Go Pro MicroSDHC UHS-I Grade 1 Classe 10
Network (Ethernet or wireless): ethernet
Connected devices (TV, USB, network storage, ...): Philips TV + usb drive via powered hub

CEC Setting : ignore init : true, other setting is default settings.
It's a fresh install of Xbian from yesterday, I was using xbian for 2 years on rpi 1.

Problem description:
1. I shut down the tv with the remote power button
2. TV is shutted down
3. Xbian wake up the TV, the TV is now ON (and it shoundn't !)

Log files
Here is the cec-client log just after powering off the TV :
Code:
TRAFFIC: [           41763]     >> 0f:36
DEBUG:   [           41763]     TV (0): power status changed from 'on' to 'standby'
DEBUG:   [           41764]     >> TV (0) -> Broadcast (F): standby (36)
DEBUG:   [           46663]     GetPhysicalAddress - physical address = 1100
NOTICE:  [           46664]     physical address changed to 1100
DEBUG:   [           46664]     physical address unchanged (1100)
WARNING: [           56730]     unhandled response received: opcode=8f initiator=1 destination=0 response=0
TRAFFIC: [           56810]     >> 01:90:01
DEBUG:   [           56810]     >> TV (0) -> Recorder 1 (1): report power status (90)
WARNING: [           61873]     unhandled response received: opcode=4 initiator=1 destination=0 response=0
WARNING: [           61993]     unhandled response received: opcode=82 initiator=1 destination=f response=0
DEBUG:   [           62566]     GetPhysicalAddress - physical address = 1100
NOTICE:  [           62567]     physical address changed to 1100
DEBUG:   [           62567]     physical address unchanged (1100)
WARNING: [           66792]     unhandled response received: opcode=8f initiator=1 destination=0 response=0
TRAFFIC: [           66871]     >> 01:90:02
DEBUG:   [           66871]     TV (0): power status changed from 'standby' to 'in transition from standby to on'
DEBUG:   [           66871]     >> TV (0) -> Recorder 1 (1): report power status (90)
TRAFFIC: [           70980]     >> 0f:84:00:00:00
DEBUG:   [           70980]     << Recorder 1 (1) -> broadcast (F): physical adddress 1100
TRAFFIC: [           70981]     << 1f:84:11:00:01
DEBUG:   [           70981]     >> TV (0) -> Broadcast (F): report physical address (84)
DEBUG:   [           71017]     GetPhysicalAddress - physical address = 1100
NOTICE:  [           71018]     physical address changed to 1100
DEBUG:   [           71131]     physical address unchanged (1100)
WARNING: [           71281]     unhandled response received: opcode=84 initiator=1 destination=f response=0
TRAFFIC: [           71386]     >> 0f:87:00:90:3e
DEBUG:   [           71387]     TV (0): power status changed from 'in transition from standby to on' to 'on'
DEBUG:   [           71387]     << Recorder 1 (1) -> Broadcast (F): vendor id Philips (903e)
TRAFFIC: [           71387]     << 1f:87:00:15:82
DEBUG:   [           71388]     >> TV (0) -> Broadcast (F): device vendor id (87)
WARNING: [           71687]     unhandled response received: opcode=87 initiator=1 destination=f response=0
DEBUG:   [           71916]     GetPhysicalAddress - physical address = 1000
NOTICE:  [           71916]     physical address changed to 1000
DEBUG:   [           71916]     setting physical address to '1000'
DEBUG:   [           71916]     marking Recorder 1 (1) as inactive source
NOTICE:  [           71917]     >> source deactivated: Recorder 1 (1)
DEBUG:   [           71917]     Recorder 1 (1): physical address changed from 1100 to 1000
DEBUG:   [           71917]     << Recorder 1 (1) -> broadcast (F): physical adddress 1000
TRAFFIC: [           71917]     << 1f:84:10:00:01
DEBUG:   [           72068]     making Recorder 1 (1) the active source
NOTICE:  [           72069]     >> source activated: Recorder 1 (1)
DEBUG:   [           72070]     sending active source message for 'Recorder 1'
NOTICE:  [           72070]     << powering on 'TV' (0)
TRAFFIC: [           72070]     << 10:04
WARNING: [           72307]     unhandled response received: opcode=84 initiator=1 destination=f response=0
NOTICE:  [           72367]     << Recorder 1 (1) -> broadcast (F): active source (1000)
TRAFFIC: [           72368]     << 1f:82:10:00
WARNING: [           72468]     unhandled response received: opcode=4 initiator=1 destination=0 response=0
DEBUG:   [           72578]     << Recorder 1 (1) -> TV (0): menu state 'activated'
TRAFFIC: [           72580]     << 10:8e:00
WARNING: [           72697]     unhandled response received: opcode=82 initiator=1 destination=f response=0
WARNING: [           72757]     unhandled response received: opcode=4 initiator=1 destination=0 response=0
DEBUG:   [           72848]     GetPhysicalAddress - physical address = 1100
NOTICE:  [           72848]     physical address changed to 1100
DEBUG:   [           72848]     setting physical address to '1100'
DEBUG:   [           72848]     marking Recorder 1 (1) as inactive source
NOTICE:  [           72848]     >> source deactivated: Recorder 1 (1)
DEBUG:   [           72848]     Recorder 1 (1): physical address changed from 1000 to 1100
DEBUG:   [           72848]     << Recorder 1 (1) -> broadcast (F): physical adddress 1100
TRAFFIC: [           72848]     << 1f:84:11:00:01
WARNING: [           72967]     unhandled response received: opcode=82 initiator=1 destination=f response=0
DEBUG:   [           73209]     making Recorder 1 (1) the active source
NOTICE:  [           73209]     >> source activated: Recorder 1 (1)
DEBUG:   [           73209]     sending active source message for 'Recorder 1'
NOTICE:  [           73209]     << powering on 'TV' (0)
TRAFFIC: [           73211]     >> 01:00:8e:00

Also, I've notice a notification after tv is waked up but cannot read it before it's dismiss, if you have clue about it it's welcome.

Thank you for your help,

Hugo
Find all posts by this user
Quote this message in a reply
17th Sep, 2015, 08:54 AM
Post: #2
RE: TV is waked up by Xbian after TV shutdown
Excellent format first post!

Where did you disable CEC? In the kodi menus or in the /boot/config.txt?

Do you have other CEC capable devices attached to the TV? What happens if you disconnect them and try again?
Find all posts by this user
Quote this message in a reply
17th Sep, 2015, 05:24 PM
Post: #3
RE: TV is waked up by Xbian after TV shutdown
CEC is not disable, I don't see an option that will fix the issue. I've always used Kodi xbian settings (GUI so). I've also tried ot disable CEC? reboot, enable CEC and reboot, but i didn't have fix the issue.
Find all posts by this user
Quote this message in a reply
25th Sep, 2015, 05:10 PM
Post: #4
RE: TV is waked up by Xbian after TV shutdown
I have the exact same issue after the latest upgrade of xbian.
Also on a pi2 and a philips TV.
I noticed in cec-client that after I try to shut down the TV, xbian keeps on sending 'powering on TV' to the TV.
This wasn't an issue in the past.
Find all posts by this user
Quote this message in a reply
25th Sep, 2015, 05:18 PM
Post: #5
RE: TV is waked up by Xbian after TV shutdown
For now I've disable CEC on xbian, using Yatse as remote control :/
Find all posts by this user
Quote this message in a reply
26th Sep, 2015, 12:31 AM
Post: #6
RE: TV is waked up by Xbian after TV shutdown
Got the same problem.
Philips TV - Yamaha receiver - Raspberry Pi B+.
Somehow Kodi keeps claiming HDMI port as active Input device.
Even if I am actually streaming from Minidlna server that runs on the PI, Kodi still keeps claiming the HDMI port. For now I disabled the option in the settings to wake up the TV on startup.
Find all posts by this user
Quote this message in a reply
26th Sep, 2015, 04:41 PM
Post: #7
RE: TV is waked up by Xbian after TV shutdown
(26th Sep, 2015 12:31 AM)Roy Terhaar Wrote:  Got the same problem.
Philips TV - Yamaha receiver - Raspberry Pi B+.
Somehow Kodi keeps claiming HDMI port as active Input device.
Even if I am actually streaming from Minidlna server that runs on the PI, Kodi still keeps claiming the HDMI port. For now I disabled the option in the settings to wake up the TV on startup.

I also have a Yamaha receiver in between. Disabling CEC entirely works as a workaround but just at startup not. Is there a way to disable just the wake-functionality but keep the capability that I can still use the remote of my yamaha.
Find all posts by this user
Quote this message in a reply
27th Sep, 2015, 11:14 PM
Post: #8
RE: TV is waked up by Xbian after TV shutdown
(26th Sep, 2015 04:41 PM)tvdeynde Wrote:  I also have a Yamaha receiver in between. Disabling CEC entirely works as a workaround but just at startup not. Is there a way to disable just the wake-functionality but keep the capability that I can still use the remote of my yamaha.

I can't answer this question; I have not tried it. I am not using the Yamaha remote at all. For Kodi I use a wireless mouse on Raspberry Pi. (Good thing now in version 15 is that the mouse scroll wheel is supported!)
I am controlling the Yamaha through the Web app on my phone if I need to switch inputs. Only thing with CEC disabled is that I can't control Kodi using TV remote.. Sad But maybe it gets fixed in future; then I'll enable it again.
Find all posts by this user
Quote this message in a reply
1st Oct, 2015, 12:55 PM (This post was last modified: 1st Oct, 2015 12:56 PM by mk01.)
Post: #9
RE: TV is waked up by Xbian after TV shutdown
@HugoG

check /etc/default/xbmc, specially this parts
Code:
HDMIPORT=0
# Turn CEC capable TV off on xbmc entering screensaver (after 'AFTER' minutes)
SCREENOFF=no
AFTER=3

# Stop XBMC when the TV is turned off.  This will also start XBMC again when
# it's turned on.
XBMCOFF=no

# Turn CEC capable TV on when XBMC exits.
XBMCEXITON=no

if you don't have by accident something as yes.
This are parts of CEC / TV on/off support from times, when XBMC had this not implemented yet. This should have been removed, but never was and the XBian logic (scripts) are still there - although by default shouldn't be active (those "unhandled response received" events do strongly indicate that perhaps I'm right).

so check that, between I will slowly start removing that from system completely.

Report back.

Please read rules and do a search before you post! . FAQs . How to post log file? . Looking for answers? Please start here
Find all posts by this user
Quote this message in a reply
1st Oct, 2015, 04:57 PM
Post: #10
RE: TV is waked up by Xbian after TV shutdown
Everything is set to 'no' or off

Terminal

xbian@living ~ $ cat /etc/default/xbmc
# Configuration for XBMC
DAEMON=$(test -x /usr/local/lib/kodi/kodi.bin && nm=kodi || nm=xbmc; echo /usr/local/lib/$nm/$nm.binWink

# Put name of all processes which XBMC should wait for before it will be started.
# e.g. WAITFOR=""
WAITFOR=""

# Niceness levels for XBMC while playing and while in screensaver is active.
PPLAYER="-3"
PSAVER="7"

HDMIPORT=0
# Turn CEC capable TV off on xbmc entering screensaver (after 'AFTER' minutes)
SCREENOFF=no
AFTER=3

# Stop XBMC when the TV is turned off. This will also start XBMC again when
# it's turned on.
XBMCOFF=no

# Turn CEC capable TV on when XBMC exits.
XBMCEXITON=no

# Turn CEC capable TV off on system shutdown. A (just one) custom script can
# also be run.
SCROFFHALT=no
SCROFFRUN="/run.my.special.script.sh"

# Enable dynamic priority handling of XBMC/Kodi process.
DPRIORITY=yes

# Disable overclocking (and overvolting) when the screensaver is started.
# When the screensaver is stopped, it will enable overclocking again.
# It does so by changing the CPUFreq governor to "conservative", which doesn't
# actually disable overclocking, but tries to set it to the minimum required
# by current system load.
SCR_OVERCLOCK_OFF="no"
Find all posts by this user
Quote this message in a reply
1st Oct, 2015, 05:04 PM
Post: #11
RE: TV is waked up by Xbian after TV shutdown
(1st Oct, 2015 04:57 PM)tvdeynde Wrote:  Everything is set to 'no' or off


OK Smile) just you was not sending that log I was commenting Wink

so send log. with xbmc started with --debug (/etc/init/xbmc.conf parameter DEBUG=), also don't forget to select extra logging for CEC.

UNCUT log send via pastebinit or any other.
thx

Please read rules and do a search before you post! . FAQs . How to post log file? . Looking for answers? Please start here
Find all posts by this user
Quote this message in a reply
12th Oct, 2015, 08:31 AM
Post: #12
RE: TV is waked up by Xbian after TV shutdown
@mk01
Have the same Problem, kodi.log attached
How can i create a cec log?

Find all posts by this user
Quote this message in a reply
14th Oct, 2015, 07:25 PM
Post: #13
RE: TV is waked up by Xbian after TV shutdown
Sorry to come back only now but I don't really know how to produce the requested logs/debug files.
Can you walk me through?

Thanks!

Tom
Find all posts by this user
Quote this message in a reply
14th Oct, 2015, 08:14 PM
Post: #14
RE: TV is waked up by Xbian after TV shutdown
(14th Oct, 2015 07:25 PM)tvdeynde Wrote:  Sorry to come back only now but I don't really know how to produce the requested logs/debug files.
Can you walk me through?

Start your Rasp
SSH in
Terminal
stop xbmc
Terminal
start xbmc --debug

The log is in .kodi/temp

But i have now idea with cec log

Edit: google is my friend...

Found this http://kodi.wiki/view/Log_file/Advanced

I will try it
Find all posts by this user
Quote this message in a reply
14th Oct, 2015, 10:18 PM
Post: #15
RE: TV is waked up by Xbian after TV shutdown
OK, here is the kodi log with cec debug on:

kodi.log:
http://pastebin.com/aXPiiJAz

kodi.old.log
http://pastebin.com/nZPUPsdY

Shutdown Rasp two times
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump: