Thank you for your donation


Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Solved: OpenVPN service causes Kodi to stop
4th Oct, 2015, 03:59 PM
Post: #1
OpenVPN service causes Kodi to stop
Hi, hopefully someone has seen this before and I'm just missing something obvious...

Software
XBian version: 20150919-1 (updated 2015-10-3)
XBMC/Kodi version: 15.2-RC2 Git:2015-09-13-2d0c3cf
Overclock settings: Default (off?)

Hardware
Device type and model: Raspberry Pi Model B 512 MB
Power supply rating: 1.2A
SD card size and make/type: Sandisk 16GB class 6
Network: Ethernet
Connected devices (TV, USB, network storage, ...): None / headless

Log files
Link to logfile(s): kodi.log

Problem description:
Installing and running OpenVPN package causes Kodi to be non-functioning. Stopping the VPN service allows Kodi to be restarted but it fails again as soon as OpenVPN is started again.

I'm struggling to find anything in the logfile that highlights a conflict and the upstart log isn't helpful either.

How to reproduce:
Vanilla build of Xbian.
Add "tun" to /etc/modules (or modules.xbian)
apt-get install openvpn (tested with 2.3.4-5 from Jessie and 2.3.7-2 from Stretch)
Copy appropriate .conf, .crt and .pem files to /etc/openvpn
Either service openvpn start or openvpn path/to/profile.conf to start vpn.
Kodi stops. Will not restart until vpn is taken down.

Reboot - same thing - Kodi down until openvpn service stopped.

Edit: forgot to include that I mounted an NFS share from my Synology NAS to copy the files from. xxx.xxx.xxx.xxx:/volume1/downloads /mnt/downloads nfs rw,defaults,intr,vers=3 0 0 added to /etc/fstab
Find all posts by this user
Quote this message in a reply
10th Oct, 2015, 04:55 AM
Post: #2
RE: OpenVPN service causes Kodi to stop
Same issue here. Eth-0 is down, wifi is ok.
Find all posts by this user
Quote this message in a reply
12th Oct, 2015, 06:20 PM
Post: #3
RE: OpenVPN service causes Kodi to stop
I goth similar results with RC2. However I had some apt-get commands manually running in the past, so my results may or may not be authentic.

A segmentation fault is happening, as soon, as I start the service.

I could not get any traces from the system, neither via GUI, nor via the advanced settings XML file.
I planned to re-install a clean system, and re-try, but did not get to it yet.

Did anyone get it working with TUN + ETH + OpenVPN?
Find all posts by this user
Quote this message in a reply
17th Oct, 2015, 07:33 AM
Post: #4
RE: OpenVPN service causes Kodi to stop
Same for me here.
I just freshly installed Xbian because I had a few issues with kodi under raspbian.
Right out of the box, I installed openvpn from repo, flashed my usual conf, and boom: kodi disappeared from the TV.

sadness
any help would be highly appreciated
Find all posts by this user
Quote this message in a reply
17th Oct, 2015, 11:57 AM
Post: #5
RE: OpenVPN service causes Kodi to stop
Did system update today (20151011-1) and the problem persists.
Find all posts by this user
Quote this message in a reply
20th Oct, 2015, 10:00 PM
Post: #6
RE: OpenVPN service causes Kodi to stop
Funny thing, I have the exact same issue with setting up an IPv6 tunnel using Aiccu to Sixxs using: https://www.sixxs.net/tools/aiccu/
Find all posts by this user
Quote this message in a reply
20th Oct, 2015, 11:04 PM
Post: #7
RE: OpenVPN service causes Kodi to stop
Looks like this may be a Kodi issue being fixed in latest builds.
https://github.com/xbianonpi/xbian/issues/762
Find all posts by this user
Quote this message in a reply
20th Oct, 2015, 11:09 PM
Post: #8
RE: OpenVPN service causes Kodi to stop
(20th Oct, 2015 11:04 PM)snarf Wrote:  Looks like this may be a Kodi issue being fixed in latest builds.
https://github.com/xbianonpi/xbian/issues/762

I just updated to kodi 15 rc3 and with am still experiencing the issue with aiccu. Is the OpenVPN issue fixed? Maybe I am looking in the wrong place.
Find all posts by this user
Quote this message in a reply
23rd Oct, 2015, 02:35 AM
Post: #9
RE: OpenVPN service causes Kodi to stop
(20th Oct, 2015 11:09 PM)YoYoost Wrote:  I just updated to kodi 15 rc3 and with am still experiencing the issue with aiccu. Is the OpenVPN issue fixed? Maybe I am looking in the wrong place.

I also updated and the issue persists for me.
Find all posts by this user
Quote this message in a reply
26th Oct, 2015, 08:33 AM
Post: #10
RE: OpenVPN service causes Kodi to stop
I also updated and the issue persists for me.
With latest packages installed, I've ran a gdb session on the source, and got following result:
Terminal

Program received signal SIGSEGV, Segmentation fault.
0x008bf73c in CNetworkLinux::queryInterfaceList (this=this@entry=0x1c5ccb8)
at NetworkLinux.cpp:431
431 NetworkLinux.cpp: No such file or directory.
(gdb) bt
#0 0x008bf73c in CNetworkLinux::queryInterfaceList (this=this@entry=0x1c5ccb8)
at NetworkLinux.cpp:431
#1 0x008bfe76 in CNetworkLinux::CNetworkLinux (this=0x1c5ccb8)
at NetworkLinux.cpp:322
#2 0x007c43e8 in CApplication::SetupNetwork (this=this@entry=0x1c1b170)
at Application.cpp:440
#3 0x007c5940 in CApplication::Create (this=0x1c1b170) at Application.cpp:452
#4 0x008415c8 in XBMC_Run (renderGUI=<optimized out>) at xbmc.cpp:60
#5 0x002f8f3e in main (argc=1, argv=0x7efff754) at main.cpp:77
(gdb) info locals
mask = <error reading variable: Cannot access memory at address 0xfffffff4>
macAddrRaw = "8\225S\001\240\025"
i = <optimized out>
addr = <error reading variable: Cannot access memory at address 0xfffffff5>
name = <error reading variable: Cannot access memory at address 0xfffffff4>
iface = <optimized out>
list = 0x1c5de70
change = <optimized out>
lock = {<XbmcThreads::UniqueLock<CCriticalSection>> = {<XbmcThreads::NonCopyable> = {<No data fields>}, mutex = @0x1c5ccbc, owns = true}, <No data fields>}
pos = warning: Unable to fetch general register.
<unavailable>
cur = warning: Unable to fetch general register.
<unavailable>

Unfortunatelly I could not match the right source from git (even, if I got the 15.2RC3 src).
I suspect, the TUN interface is not digestable for the source, ifconfig brings this for tun0:
Terminal

root@xbian /usr/lib/debug # ifconfig tun0
tun0 Link encap:UNSPEC HWaddr 00-00-00-00-00-00-00-00-00-00-00-00-00-00-00-00
inet addr:10.20.30.1 P-t-P:10.20.30.2 Mask:255.255.255.255
UP POINTOPOINT RUNNING NOARP MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:100
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

root@xbian /usr/lib/debug #
Find all posts by this user
Quote this message in a reply
17th Nov, 2015, 06:52 AM
Post: #11
RE: OpenVPN service causes Kodi to stop
I can confirm that this issue has been resolved with my most recent update (xbian-package-xbmc_15.2-1446621231).
Find all posts by this user
Quote this message in a reply
16th Mar, 2017, 04:57 PM
Post: #12
RE: OpenVPN service causes Kodi to stop
Have you follow all steps on how to setup VPN on Kodi? Check here https://www.purevpn.com/blog/kodi-vpn/

PM me, If you face same issue again.
Find all posts by this user
Quote this message in a reply
17th Apr, 2017, 08:02 PM
Post: #13
RE: OpenVPN service causes Kodi to stop
Thanks, this is helpful.

If you want to install vpn Manager Using Zomboided Repo then follow this guide:
https://www.bestvpnprovider.com/kodi-vpn/
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump: