Thank you for your donation


Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Solved: Another libcurl3 version problem
8th Feb, 2016, 07:31 AM
Post: #1
Another libcurl3 version problem
Hi,

I skipped the problem with libcurl4-openssl-dev a few days ago by ignoring it. But now I'm running into the same problem again -- seems libcurl3 is quite commonly used...

So this time I'm trying to install mopidy, in order to stream spotify (following instructions here: https://docs.mopidy.com/en/latest/installation/debian/#debian-install).

The error I get (see below) is about libcurl3-gnutls, and I got the wrong version installed (need 7.38.0 but have 7.37.1-1).

Is this something I can get fixed / changed?

Terminal

xbian@xbian ~ $ sudo apt-get install mopidy
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
mopidy : Depends: python-tornado (>= 2.3) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

xbian@xbian ~ $ sudo apt-get install python-tornado
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
python-tornado : Depends: python-pycurl but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

xbian@xbian ~ $ sudo apt-get install python-pycurl
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
python-pycurl : Depends: libcurl3-gnutls (>= 7.38.0) but 7.37.1-1 is to be installed
E: Unable to correct problems, you have held broken packages.

Thanks,
nickfx
Find all posts by this user
Quote this message in a reply
16th Feb, 2016, 02:50 AM
Post: #2
RE: Another libcurl3 version problem
I don't know the reason for using an older libcurl3-gnutls, but you can try to comment out the part in /etc/apt/preferences.d/xbian and try again
Find all posts by this user
Quote this message in a reply
19th Feb, 2016, 07:41 AM
Post: #3
RE: Another libcurl3 version problem
(16th Feb, 2016 02:50 AM)Nachteule Wrote:  I don't know the reason for using an older libcurl3-gnutls, but you can try to comment out the part in /etc/apt/preferences.d/xbian and try again

Ah, thanks for that. I didn't realise that's where the version was 'fixed'.

Ok, I've taken it out, updated, and everything still seems to work. I'll let you know if anything breaks.
Find all posts by this user
Quote this message in a reply
18th Mar, 2016, 04:34 AM
Post: #4
RE: Another libcurl3 version problem
Just to update:

This fix worked fine for a while, but preferences.d was replaced with the original version at some point. apt-get upgrade then downgraded libcurl3 and removed the software I had installed (it might have asked me for permission, I can't remember seeing it though). So.. you mileage with this fix will, like Volkswagen emissions, vary depending on whether you're in a test situation or not.

It would be really good to know why libcurl3 is 'pinned' in this way and whether there are plans to change that.

N
Find all posts by this user
Quote this message in a reply
23rd Mar, 2016, 08:16 AM (This post was last modified: 11th Jan, 2017 12:09 AM by Nachteule.)
Post: #5
RE: Another libcurl3 version problem
@nickfx

A file /etc/apt/preferences.d/01user with

Code:
Package: libcurl3 curl libcurl3-gnutls
Pin: release o=Debian
Pin-Priority: 1001
Package: libcurl3 curl libcurl3-gnutls
Pin: release o=XBian
Pin-Priority: -1

will make debian's version a priority again

Edit:
Wrong order in example file, fixed version see below
Find all posts by this user
Quote this message in a reply
3rd Apr, 2016, 04:03 AM
Post: #6
RE: Another libcurl3 version problem
(23rd Mar, 2016 08:16 AM)Nachteule Wrote:  @nickfx

A file /etc/apt/preferences.d/01user with

Code:
Package: libcurl3 curl libcurl3-gnutls
Pin: release o=Debian
Pin-Priority: 1001
Package: libcurl3 curl libcurl3-gnutls
Pin: release o=XBian
Pin-Priority: -1

will make debian's version a priority again

Ah, thanks for that! Will give that a whirl.

Is there a manual to understand what works how here?

nickfx
Find all posts by this user
Quote this message in a reply
11th Jan, 2017, 12:07 AM (This post was last modified: 11th Jan, 2017 12:10 AM by Nachteule.)
Post: #7
RE: Another libcurl3 version problem
The file 01user posted above is not correct. It should be:

Code:
Package: libcurl3 curl libcurl3-gnutls
Pin: release o=XBian
Pin-Priority: -1
Package: libcurl3 curl libcurl3-gnutls
Pin: release o=Debian
Pin-Priority: 1001

And it works, checked by myself Smile
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump: