Thank you for your donation


Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
AUDIOPHONICS I-Sabre V3 DAC ES9023 TCXO
8th Apr, 2016, 03:30 PM (This post was last modified: 8th Apr, 2016 03:35 PM by rikardo1979.)
Post: #16
RE: AUDIOPHONICS I-Sabre V3 DAC ES9023 TCXO
(8th Apr, 2016 07:20 AM)Skywatch Wrote:  Aha.

Here's a guide to help you out.....

In /boot/config.txt add (or edit) the following lines....

Terminal

dtoverlay=hifiberry-dac
dtparam=i2s=on
#dtoverlay=lirc-rpi
hdmi_force_hotplug=1

Then make sure that staging is allowed in /etc/apt/sources.list.d/xbian.list
Then update and then upgrade. DO NOT REBOOT AT THE PROMPT if using xbian-config!

Then make /etc/modprobe.d/xbian.conf look like this.....

Terminal

alias char-major-89 i2c-dev
blacklist snd_bcm2835
blacklist evbug

Then add the line below to /etc/modules.xbian
Terminal

#snd_bcm2835

Now reboot and aplay -l and see what it says.

Let me know which pi, kernel and dac you are using here.

I have tried these steps and I have this card under audio out now and it showing in aplay -l but no sound is passed out.
If I switch back to HDMI in within GUI sound is coming out but switching to ALSA card have nothing

~~~~>>>Please always follow rules and read before you post<<<~~~~
Find all posts by this user
Quote this message in a reply
8th Apr, 2016, 07:50 PM
Post: #17
RE: AUDIOPHONICS I-Sabre V3 DAC ES9023 TCXO
Good....At least we are getting there!

Next check the output of cat /etc/asound.conf ... It should be
Terminal

pcm.!default {
type hw card 0
}
ctl.!default {
type hw card 0
}

If the file does not exist then create it and add those lines above.

Reboot update and upgrade and double check those two "/etc/module" entries are OK and try again.

IF that still fails then you might need to do ' sudo apt-get install alsa-base alsa-utils ' as I have had times when this mysteriously vanishes so it is worth a try. Reboot and try again.
Find all posts by this user
Quote this message in a reply
9th Apr, 2016, 08:10 AM
Post: #18
RE: AUDIOPHONICS I-Sabre V3 DAC ES9023 TCXO
ok, I have tried this now and is the same situation.I can select DAC as audio out but no sound...
I have tried all the steps mentioned (I believe so Big Grin)

~~~~>>>Please always follow rules and read before you post<<<~~~~
Find all posts by this user
Quote this message in a reply
9th Apr, 2016, 08:23 AM (This post was last modified: 9th Apr, 2016 08:31 AM by rikardo1979.)
Post: #19
RE: AUDIOPHONICS I-Sabre V3 DAC ES9023 TCXO
sorry, got it working now
It was my mistake and I just forget comment the
Code:
dtoverlay=lirc-rpi
in /boot/config.txt
Blush

Thanks @Skywatch, good job with this tutorial Wink

~~~~>>>Please always follow rules and read before you post<<<~~~~
Find all posts by this user
Quote this message in a reply
9th Apr, 2016, 08:29 AM
Post: #20
RE: AUDIOPHONICS I-Sabre V3 DAC ES9023 TCXO
now we miss only one thing, make HDMI+Alsa out at the same time Tongue so would not need to switch in between Big Grin

~~~~>>>Please always follow rules and read before you post<<<~~~~
Find all posts by this user
Quote this message in a reply
9th Apr, 2016, 08:34 AM
Post: #21
RE: AUDIOPHONICS I-Sabre V3 DAC ES9023 TCXO
Congratulations Shy
Find all posts by this user
Quote this message in a reply
9th Apr, 2016, 08:37 AM
Post: #22
RE: AUDIOPHONICS I-Sabre V3 DAC ES9023 TCXO
so as this is all working fine now, can I make this working on XBian?
http://forum.audiophonics.fr/viewtopic.php?f=4&t=1578
http://forum.audiophonics.fr/viewtopic.php?f=4&t=1492&sid=37b72354b708cb2d3658e2b55ab72f53


@Nachteule what you think? Can you help this noob? Tongue

~~~~>>>Please always follow rules and read before you post<<<~~~~
Find all posts by this user
Quote this message in a reply
9th Apr, 2016, 09:17 AM (This post was last modified: 9th Apr, 2016 09:23 AM by Nachteule.)
Post: #23
RE: AUDIOPHONICS I-Sabre V3 DAC ES9023 TCXO
Looked to the pictures and commands, don't see any reason why not Shy

Btw, don't understand French. Many many years ago I was on business travel in french part of Switzerland (south from Mount Blanc), they did not speak German or English, and I could not speak or understand French. Was funny, or should better say terrible ... Dodgy
Find all posts by this user
Quote this message in a reply
9th Apr, 2016, 02:23 PM
Post: #24
RE: AUDIOPHONICS I-Sabre V3 DAC ES9023 TCXO
(9th Apr, 2016 09:17 AM)Nachteule Wrote:  Btw, don't understand French.

Me neither Big Grin But this seems to be the only place with support and information for these products Huh
Which is a real shame as these products are at high quality in my opinion.
Once this DAC is finish I going to take it to our local high end hifi studio for comparison test

~~~~>>>Please always follow rules and read before you post<<<~~~~
Find all posts by this user
Quote this message in a reply
9th Apr, 2016, 02:39 PM
Post: #25
RE: AUDIOPHONICS I-Sabre V3 DAC ES9023 TCXO
(9th Apr, 2016 09:17 AM)Nachteule Wrote:  Looked to the pictures and commands, don't see any reason why not Shy

so I followed this guide and all was good to this point
Code:
cd wiringPi
./build

which gives me an error
Code:
root@xbian /home/ft/wiringPi # ./build
wiringPi Build script
=====================


WiringPi Library
sudo: make: command not found

Stuck now HuhShy

~~~~>>>Please always follow rules and read before you post<<<~~~~
Find all posts by this user
Quote this message in a reply
9th Apr, 2016, 06:50 PM
Post: #26
RE: AUDIOPHONICS I-Sabre V3 DAC ES9023 TCXO
Good to see you got it working - Look forward to the results from the test!

install this...

sudo apt-get install build-essential

Then try wiring pi again.

...and how about that page in English?

https://translate.google.com/translate?sl=auto&tl=en&js=y&prev=_t&hl=en&ie=UTF-8&u=http%3A%2F%2Fforum.audiophonics.fr%2Fviewtopic.php%3Ff%3D...t=&act=url

@Nachteule

Would that display script run on xbian without problem do you think? Smile
Find all posts by this user
Quote this message in a reply
9th Apr, 2016, 08:30 PM
Post: #27
RE: AUDIOPHONICS I-Sabre V3 DAC ES9023 TCXO
(9th Apr, 2016 06:50 PM)Skywatch Wrote:  ...and how about that page in English?

yes, auto translate by google works but that is not a solution, is it Smile
And their official support is, well is not...none existent Smile

~~~~>>>Please always follow rules and read before you post<<<~~~~
Find all posts by this user
Quote this message in a reply
9th Apr, 2016, 09:19 PM
Post: #28
RE: AUDIOPHONICS I-Sabre V3 DAC ES9023 TCXO
LOL, translations by google, tried it some times, but output always was very very crappy SmileSadTongue
Find all posts by this user
Quote this message in a reply
9th Apr, 2016, 09:22 PM
Post: #29
RE: AUDIOPHONICS I-Sabre V3 DAC ES9023 TCXO
(9th Apr, 2016 06:50 PM)Skywatch Wrote:  Would that display script run on xbian without problem do you think? Smile

If you expect problems it will work and vice versa. That's my experience Big Grin

So, give it a try and see what happens Tongue
Find all posts by this user
Quote this message in a reply
9th Apr, 2016, 09:35 PM
Post: #30
RE: AUDIOPHONICS I-Sabre V3 DAC ES9023 TCXO
(9th Apr, 2016 06:50 PM)Skywatch Wrote:  Good to see you got it working - Look forward to the results from the test!

install this...

sudo apt-get install build-essential

this did not go very smooth I believe

Code:
root@xbian ~ # sudo apt-get install build-essential
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following package was automatically installed and is no longer required:
  liblockdev1
Use 'apt-get autoremove' to remove it.
The following extra packages will be installed:
  bzip2 dpkg-dev g++ g++-4.9 libc-dev-bin libc6-dev libdpkg-perl
  libstdc++-4.9-dev libtimedate-perl linux-libc-dev make
Suggested packages:
  bzip2-doc debian-keyring gcc-4.9-doc libstdc++6-4.9-dbg glibc-doc
  libstdc++-4.9-doc make-doc
Recommended packages:
  fakeroot libalgorithm-merge-perl manpages-dev libfile-fcntllock-perl
The following NEW packages will be installed:
  build-essential bzip2 dpkg-dev g++ g++-4.9 libc-dev-bin libc6-dev
  libdpkg-perl libstdc++-4.9-dev libtimedate-perl linux-libc-dev make
0 upgraded, 12 newly installed, 0 to remove and 0 not upgraded.
Need to get 18.8 MB of archives.
After this operation, 49.2 MB of additional disk space will be used.
Do you want to continue? [Y/n] y
Get:1 http://www.mirrorservice.org/sites/apt.xbian.org/ staging/rpi2-jessie linux-libc-dev armhf 4.4.6-1458753791 [790 kB]
Get:2 http://http.debian.net/debian/ jessie/main bzip2 armhf 1.0.6-7+b3 [45.3 kB]
Get:3 http://http.debian.net/debian/ jessie/main libc-dev-bin armhf 2.19-18+deb8u4 [231 kB]
Get:4 http://http.debian.net/debian/ jessie/main libc6-dev armhf 2.19-18+deb8u4 [1,748 kB]
Get:5 http://http.debian.net/debian/ jessie/main libstdc++-4.9-dev armhf 4.9.2-10 [1,135 kB]
Get:6 http://http.debian.net/debian/ jessie/main g++-4.9 armhf 4.9.2-10 [11.8 MB]
Get:7 http://http.debian.net/debian/ jessie/main g++ armhf 4:4.9.2-2 [1,510 B]
Get:8 http://http.debian.net/debian/ jessie/main make armhf 4.0-8.1 [335 kB]
Get:9 http://http.debian.net/debian/ jessie/main libtimedate-perl all 2.3000-2 [42.2 kB]
Get:10 http://http.debian.net/debian/ jessie/main libdpkg-perl all 1.17.26 [1,072 kB]
Get:11 http://http.debian.net/debian/ jessie/main dpkg-dev all 1.17.26 [1,545 kB]
Get:12 http://http.debian.net/debian/ jessie/main build-essential armhf 11.7 [6,934 B]
Fetched 18.8 MB in 7s (2,546 kB/s)
Create a snapshot of '/run/btrfs-snap/root/@' in '/run/btrfs-snap/root/@btrfs-auto-snap_apt-run-2016-04-09-1109'
Delete subvolume (no-commit): '/run/btrfs-snap/root/@last_good_known'
Create a snapshot of '/run/btrfs-snap/root/@btrfs-auto-snap_apt-run-2016-04-09-1109' in '/run/btrfs-snap/root/@last_good_known'
Delete subvolume (no-commit): '/run/btrfs-snap/root/@btrfs-auto-snap_apt-run-2016-04-09-0425'
@btrfs-auto-snap_apt-run-2016-04-09-1109, 1 created snapshots, 1 destroyed snapshots, 0 warnings.
Selecting previously unselected package bzip2.
(Reading database ... 28780 files and directories currently installed.)
Preparing to unpack .../bzip2_1.0.6-7+b3_armhf.deb ...
Unpacking bzip2 (1.0.6-7+b3) ...
Selecting previously unselected package libc-dev-bin.
Preparing to unpack .../libc-dev-bin_2.19-18+deb8u4_armhf.deb ...
Unpacking libc-dev-bin (2.19-18+deb8u4) ...
Selecting previously unselected package linux-libc-dev:armhf.
Preparing to unpack .../linux-libc-dev_4.4.6-1458753791_armhf.deb ...
Unpacking linux-libc-dev:armhf (4.4.6-1458753791) ...
Selecting previously unselected package libc6-dev:armhf.
Preparing to unpack .../libc6-dev_2.19-18+deb8u4_armhf.deb ...
Unpacking libc6-dev:armhf (2.19-18+deb8u4) ...
Selecting previously unselected package libstdc++-4.9-dev:armhf.
Preparing to unpack .../libstdc++-4.9-dev_4.9.2-10_armhf.deb ...
Unpacking libstdc++-4.9-dev:armhf (4.9.2-10) ...
Selecting previously unselected package g++-4.9.
Preparing to unpack .../g++-4.9_4.9.2-10_armhf.deb ...
Unpacking g++-4.9 (4.9.2-10) ...
dpkg: error processing archive /var/cache/apt/archives/g++-4.9_4.9.2-10_armhf.deb (--unpack):
cannot copy extracted data for './usr/lib/gcc/arm-linux-gnueabihf/4.9/cc1plus' to '/usr/lib/gcc/arm-linux-gnueabihf/4.9/cc1plus.dpkg-new': failed to write (No space left on device)
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Selecting previously unselected package g++.
Preparing to unpack .../g++_4%3a4.9.2-2_armhf.deb ...
Unpacking g++ (4:4.9.2-2) ...
Selecting previously unselected package make.
Preparing to unpack .../make_4.0-8.1_armhf.deb ...
Unpacking make (4.0-8.1) ...
Selecting previously unselected package libtimedate-perl.
Preparing to unpack .../libtimedate-perl_2.3000-2_all.deb ...
Unpacking libtimedate-perl (2.3000-2) ...
Selecting previously unselected package libdpkg-perl.
Preparing to unpack .../libdpkg-perl_1.17.26_all.deb ...
Unpacking libdpkg-perl (1.17.26) ...
Selecting previously unselected package dpkg-dev.
Preparing to unpack .../dpkg-dev_1.17.26_all.deb ...
Unpacking dpkg-dev (1.17.26) ...
Selecting previously unselected package build-essential.
Preparing to unpack .../build-essential_11.7_armhf.deb ...
Unpacking build-essential (11.7) ...
Errors were encountered while processing:
/var/cache/apt/archives/g++-4.9_4.9.2-10_armhf.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

~~~~>>>Please always follow rules and read before you post<<<~~~~
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump: