Thank you for your donation


Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Passthrough via S/PDIF without pulse
28th May, 2016, 12:27 AM
Post: #1
Passthrough via S/PDIF without pulse
During the last couple of months, I have unsuccessfully tried to set up audio pass through via my Pi 2 with an HifiBerry-card. When pass through is enabled, no sound can be heard from my soundbar, only the subwoofer kind of "rumbles" a little.

I partly blame my audio device (Samsung HW-D 450), because it seems to be working for other people with the same setting otherwise. I knew, however, that it was able to play pass through audio when connected to my windows PC using the pass through settings of mpc-hc.

I now noticed that, when using Ubuntu and VLC player, I can only get pass through to work if I select "playback/recording through the pulseaudio sound server" as the audio device. If I choose the optical digital output directly ("Digital IEC958 ..."), I can reproduce the faulty behaviour of the raspberry under xbian described above.

So the question is: What could cause my soundbar to properly handle pass through streams only when pulse audio (or Windows) is involved? Is there a way I can get past these limitations? Is pulse still unsupported in xbian?
Find all posts by this user
Quote this message in a reply
28th May, 2016, 03:23 AM
Post: #2
RE: Passthrough via S/PDIF without pulse
Which hifi berry card are you trying to get working?
Find all posts by this user
Quote this message in a reply
28th May, 2016, 03:42 AM
Post: #3
RE: Passthrough via S/PDIF without pulse
There was discussion about this problem here

@daharn
What is your version of Kodi (xbian-package-xbmc) ?

Maybe it is good idea to update it and try again.
Find all posts by this user
Quote this message in a reply
28th May, 2016, 04:06 AM
Post: #4
RE: Passthrough via S/PDIF without pulse
(28th May, 2016 03:23 AM)Skywatch Wrote:  Which hifi berry card are you trying to get working?

It's the digi+ with optical and coaxial connector. Works non-pass through output.

(28th May, 2016 03:42 AM)Nachteule Wrote:  There was discussion about this problem here

What is your version of Kodi (xbian-package-xbmc) ?

Jep, that was me as well. Discussion then moved on to different issues and I didn't know what to try next either.

However, this latest finding somehow suggests that the problem is not xbian or raspberry specific but occurs whenever alsa tries to send the audio directly via s/pdif.

I just recently installed all available updates for my xbian build.
Find all posts by this user
Quote this message in a reply
30th May, 2016, 06:23 AM
Post: #5
RE: Passthrough via S/PDIF without pulse
>It's the digi+ with optical and coaxial connector.

Ah, ok then, you have the right card for this! Wink

>Works non-pass through output.

??? This is really confusing me now. How can it work in 'non-pass through output' ???

I have tried with my card and can't get anything unless passthrough is selected and even then stereo audio only works with 'stereo upmix' selected (which is not ideal as it outputs sound from all speakers when you might only want pure stereo sound).

Can you please clarify what you mean by the above?
Find all posts by this user
Quote this message in a reply
30th May, 2016, 04:08 PM
Post: #6
RE: Passthrough via S/PDIF without pulse
what you get from

Code:
aplay -l

~~~~>>>Please always follow rules and read before you post<<<~~~~
Find all posts by this user
Quote this message in a reply
30th May, 2016, 07:38 PM
Post: #7
RE: Passthrough via S/PDIF without pulse
(30th May, 2016 06:23 AM)Skywatch Wrote:  >Works non-pass through output.

??? This is really confusing me now. How can it work in 'non-pass through output' ??

Can you please clarify what you mean by the above?

Well, I can select the hifiberry as the output device in system/audio. As long as I disable passthrough, Kodi, as I assume, transforms the Dolby or dts signal to a digital stereo signal and outputs it to my soundbar (which physically is a 2.1 system) through the optical output of the hifiberry card. This works in any case.

(30th May, 2016 04:08 PM)rikardo1979 Wrote:  what you get from

Code:
aplay -l

Terminal
xbian@xbian ~ $ aplay -L
null
Discard all samples (playback) or generate zero samples (capture)
default:CARD=sndrpihifiberry
snd_rpi_hifiberry_digi,
Default Audio Device
sysdefault:CARD=sndrpihifiberry
snd_rpi_hifiberry_digi,
Default Audio Device
dmix:CARD=sndrpihifiberry,DEV=0
snd_rpi_hifiberry_digi,
Direct sample mixing device
dsnoop:CARD=sndrpihifiberry,DEV=0
snd_rpi_hifiberry_digi,
Direct sample snooping device
hw:CARD=sndrpihifiberry,DEV=0
snd_rpi_hifiberry_digi,
Direct hardware device without any conversions
plughw:CARD=sndrpihifiberry,DEV=0
snd_rpi_hifiberry_digi,
Hardware device with all software conversions
Find all posts by this user
Quote this message in a reply
30th May, 2016, 08:21 PM (This post was last modified: 30th May, 2016 08:25 PM by rikardo1979.)
Post: #8
RE: Passthrough via S/PDIF without pulse
and what your /boot/config.txt looks like?

Do you have
Code:
dtparam=audio=on
commented out?

~~~~>>>Please always follow rules and read before you post<<<~~~~
Find all posts by this user
Quote this message in a reply
30th May, 2016, 08:43 PM
Post: #9
RE: Passthrough via S/PDIF without pulse
(30th May, 2016 08:21 PM)rikardo1979 Wrote:  and what your /boot/config.txt looks like?

Do you have
Code:
dtparam=audio=on
commented out?

Terminal
xbian@xbian ~ $ cat /boot/config.txt
initramfs initramfs.gz 0x1000000
gpu_mem_1024=256
gpu_mem_512=144
gpu_mem_256=100
initial_turbo=3
hdmi_ignore_cec_init=1
disable_overscan=1
disable_splash=1

#dtoverlay=lirc-rpi
dtoverlay=hifiberry-digi

dtparam=i2s=on
hdmi_force_hotplug=1

max_usb_current=1

So, this specific setting is not present.
Find all posts by this user
Quote this message in a reply
30th May, 2016, 08:53 PM
Post: #10
RE: Passthrough via S/PDIF without pulse
(30th May, 2016 08:43 PM)daharn Wrote:  
(30th May, 2016 08:21 PM)rikardo1979 Wrote:  and what your /boot/config.txt looks like?

Do you have
Code:
dtparam=audio=on
commented out?

Terminal
xbian@xbian ~ $ cat /boot/config.txt
initramfs initramfs.gz 0x1000000
gpu_mem_1024=256
gpu_mem_512=144
gpu_mem_256=100
initial_turbo=3
hdmi_ignore_cec_init=1
disable_overscan=1
disable_splash=1

#dtoverlay=lirc-rpi
dtoverlay=hifiberry-digi

dtparam=i2s=on
hdmi_force_hotplug=1

max_usb_current=1

So, this specific setting is not present.

I dont have any card on my RPi 3 running XBian but I have an I-Sabre ES9023 DAC in RPi2 and I haver this in my config
Code:
#dtparam=i2s=on
#dtparam=audio=on

~~~~>>>Please always follow rules and read before you post<<<~~~~
Find all posts by this user
Quote this message in a reply
30th May, 2016, 08:58 PM
Post: #11
RE: Passthrough via S/PDIF without pulse
(30th May, 2016 08:53 PM)rikardo1979 Wrote:  I dont have any card on my RPi 3 running XBian but I have an I-Sabre ES9023 DAC in RPi2 and I haver this in my config
Code:
#dtparam=i2s=on
#dtparam=audio=on

Alright, for the rest of the week I only have remote access to my pi but I will try this out as soon as I get home.
Find all posts by this user
Quote this message in a reply
31st May, 2016, 07:23 AM
Post: #12
RE: Passthrough via S/PDIF without pulse
I have tried various combinations in /boot/config.txt and /etc/modules and cannot replicate your situation.

When passthrough is not selected, no sound comes through (as you might expect).

What is the source audio you are using? ?How many channels? What type of encoding? etc...

Do you only have the one pi and one dac? Just wondering if a comparison might be possible???

I know what it is like to be away from your pi! - So if you need it and don't want it to crash until you get back to it then that is fine! Smile

Also can you again try aplay -l (note lower case 'l' and *not* upper case 'L')
Find all posts by this user
Quote this message in a reply
7th Jun, 2016, 11:24 PM
Post: #13
RE: Passthrough via S/PDIF without pulse
(31st May, 2016 07:23 AM)Skywatch Wrote:  When passthrough is not selected, no sound comes through (as you might expect).

Did you only choose the dac as the passthrough device or as the main audio output as well? Because if I don't select it as the main device, I don't get any output in any case.

(31st May, 2016 07:23 AM)Skywatch Wrote:  What is the source audio you are using? ?How many channels? What type of encoding? etc...

I am using test trailers for dolby and dts that can be found here. The most basic are both 5.1.

(31st May, 2016 07:23 AM)Skywatch Wrote:  Do you only have the one pi and one dac? Just wondering if a comparison might be possible???

Unfortunately, yes. More annoyingly, I the sound bar is my only audio device that has a digital audio input, so I don't know, whether this might work with different hardware...

(31st May, 2016 07:23 AM)Skywatch Wrote:  I know what it is like to be away from your pi! - So if you need it and don't want it to crash until you get back to it then that is fine! Smile

Well, the main problem is that I can't test the new settings via SSH or do you know a solution to that?

(31st May, 2016 07:23 AM)Skywatch Wrote:  Also can you again try aplay -l (note lower case 'l' and *not* upper case 'L')

Terminal

xbian@xbian ~ $ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: sndrpihifiberry [snd_rpi_hifiberry_digi], device 0: HifiBerry Digi HiFi wm8804-spdif-0 []
Subdevices: 1/1
Subdevice #0: subdevice #0

(30th May, 2016 08:53 PM)rikardo1979 Wrote:  I dont have any card on my RPi 3 running XBian but I have an I-Sabre ES9023 DAC in RPi2 and I haver this in my config
Code:
#dtparam=i2s=on
#dtparam=audio=on

I tried again after commenting out "dtparam=i2s=on", but it didn't change anything.
Find all posts by this user
Quote this message in a reply
8th Jun, 2016, 03:33 AM
Post: #14
RE: Passthrough via S/PDIF without pulse
I've just setup a fresh image for RPi2 and hifiberry-dac (clone)

In /boot/config.txt
#dtparam=audio=on
dtoverlay=hifiberry-digi
(This line may not be needed but without it - KODI hung when selecting the S/PDIF option)
dtoverlay=lirc-rpi,gpio_out_pin=17,gpio_in_pin=22,debug

and
(Not too sure if this is needed, but)
/etc/modules.xbian
#snd_bcm2835

It worked perfectly on first plug in. Once I set the output everything was fine. Nothing else was changed or installed - Basically worked out of the box.

I tried DTS-MA, AC3 and various other 5.1 formats without any issue.

My setup is: HDMI to TV, S/PDIF to Yahama AV using AppTV Skin

Maybe you need to restart from scratch and start from there. Confluence skin, no add-ons or other modifications apart from thise listed above and see what you get.

Please read before you post
How to post a log file

If you liked my help, click on "Thanks" to show your appreciation.
Find all posts by this user
Quote this message in a reply
8th Jun, 2016, 05:46 AM
Post: #15
RE: Passthrough via S/PDIF without pulse
Hey, that's great. You have Hifiberry card, good to know Smile

(8th Jun, 2016 03:33 AM)IriDium Wrote:  (This line may not be needed but without it - KODI hung when selecting the S/PDIF option)
dtoverlay=lirc-rpi,gpio_out_pin=17,gpio_in_pin=22,debug

FYI: This line is required if you want to use LIRC and Hifiberry at the same time
If not, you can disable lirc-rpi overlay

Quote:and
(Not too sure if this is needed, but)
/etc/modules.xbian
#snd_bcm2835

FYI: not really required since kernel 4.4 and #dtparam=audio=on

Module will be loaded but does nothing because onboard sound is not enabled. Consumes only some kb of memory
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump: