Thank you for your donation


Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Raspberry Pi 3 loosing wifi - busy status
1st Jul, 2016, 09:01 AM
Post: #1
Raspberry Pi 3 loosing wifi - busy status
Hello,

I have a strange Wifi problem with my Raspberry Pi 3 setup using Xbian.

I'm connected to my home router using the onboard wifi adapter. I have a good connection and wifi works at normal speed.

After some time (it ranges from one to a few days), the wifi connection drops. The results are the following:
- SSH not working (incoming wifi down)
- Weather, Internet radio, Youtube... not working from kodi (outgoing WiFi down)
- In Kodi: when I go to System, Information: multiple status are shown as busy: Internet Status, Uptime, etc...

If I reboot, everything is back to normal for a few days again.

I would really appreciate to have ideas on how to debug this.

Thanks in advance!

Mathieu
Find all posts by this user
Quote this message in a reply
1st Jul, 2016, 03:36 PM
Post: #2
RE: Raspberry Pi 3 loosing wifi - busy status
(1st Jul, 2016 09:01 AM)mgouin Wrote:  Hello,

I have a strange Wifi problem with my Raspberry Pi 3 setup using Xbian.

I'm connected to my home router using the onboard wifi adapter. I have a good connection and wifi works at normal speed.

After some time (it ranges from one to a few days), the wifi connection drops. The results are the following:
- SSH not working (incoming wifi down)
- Weather, Internet radio, Youtube... not working from kodi (outgoing WiFi down)
- In Kodi: when I go to System, Information: multiple status are shown as busy: Internet Status, Uptime, etc...

If I reboot, everything is back to normal for a few days again.

I would really appreciate to have ideas on how to debug this.

Thanks in advance!

Mathieu

to troubleshoot you would need to provide log file

~~~~>>>Please always follow rules and read before you post<<<~~~~
Find all posts by this user
Quote this message in a reply
1st Jul, 2016, 09:48 PM
Post: #3
RE: Raspberry Pi 3 loosing wifi - busy status
@mgouin

What's the kernel version you are running?

Terminal

unname -a

I have similar issues since one week and I have kernel version 4.4.13 and 4.4.14 under suspicion (the raspbian kernel guys did make some changes for 8192CU driver, maybe they killed brcmfmac driver with those commits).

My wlan connection is only stable for a few seconds (before Kodi starts) and then connection is down and never comes back until reboot Sad

Have to investigate more at evening
Find all posts by this user
Quote this message in a reply
1st Jul, 2016, 10:15 PM
Post: #4
RE: Raspberry Pi 3 loosing wifi - busy status
Terminal

Linux xbian 4.4.14+ #1 SMP PREEMPT Wed Jun 29 13:04:58 CEST 2016 armv7l GNU/Linux

Thanks

@rikardo
Do you mean the xbian log (with command xl ) ?
Find all posts by this user
Quote this message in a reply
2nd Jul, 2016, 04:27 AM
Post: #5
RE: Raspberry Pi 3 loosing wifi - busy status
So, did not fixed my issue with onboard wlan device. After changing wlan channel it is more stable but still not perfect

Your issue may be related to wlan power saving.
You could try disabling power management by command

Terminal

sudo iw wlan0 set power_save off

or adding one line to /etc/network/interfaces (I did this on my RPi3 now)

Code:
-- snip --
iface wlan0 inet static
       address 192.168.1.24
       netmask 255.255.255.0
       network 192.168.1.0
       broadcast 192.168.1.255
       gateway 192.168.1.10
       wireless-power off            # <-- Disabling power management
-- snap --

Seems not to be kernel issue > 4.4.12 and not firmware issue. Reverted back to older versions but did not make any difference.

HTH
Find all posts by this user
Quote this message in a reply
4th Jul, 2016, 10:55 AM
Post: #6
RE: Raspberry Pi 3 loosing wifi - busy status
(2nd Jul, 2016 04:27 AM)Nachteule Wrote:  So, did not fixed my issue with onboard wlan device. After changing wlan channel it is more stable but still not perfect

Your issue may be related to wlan power saving.
You could try disabling power management by command

Terminal

sudo iw wlan0 set power_save off

or adding one line to /etc/network/interfaces (I did this on my RPi3 now)

Code:
-- snip --
iface wlan0 inet static
       address 192.168.1.24
       netmask 255.255.255.0
       network 192.168.1.0
       broadcast 192.168.1.255
       gateway 192.168.1.10
       wireless-power off            # <-- Disabling power management
-- snap --

Seems not to be kernel issue > 4.4.12 and not firmware issue. Reverted back to older versions but did not make any difference.

HTH

Power saving is already disabled... Thanks anyway.

Could you be more specific about what log file would you need ?
Find all posts by this user
Quote this message in a reply
4th Jul, 2016, 09:57 PM
Post: #7
RE: Raspberry Pi 3 loosing wifi - busy status
This is good question.

You will nothing find in Kodi log, I suppose you have to install and run a syslog daemon (I'm using rsyslog, but syslog and syslog-ng should be ok also)

Did you already checked if your RPi automatically reconnects to network after rebooting AP?

AFAIR I had issues here few years ago so I wrote script running in background doing this
Find all posts by this user
Quote this message in a reply
7th Jul, 2016, 05:47 AM
Post: #8
RE: Raspberry Pi 3 loosing wifi - busy status
(4th Jul, 2016 09:57 PM)Nachteule Wrote:  ...
Did you already checked if your RPi automatically reconnects to network after rebooting AP?

AFAIR I had issues here few years ago so I wrote script running in background doing this

AP : You mean my wifi access point? My wifi router?

What I still don't understand is the busy status reported in Kodi...

Also, regarding your script, I'm ok fiddling with cron jobs, however I'm not sure which commands would work for resetting/reconnecting the wifi.

Thanks!

I'll try to post a screenshot later when this happens.
Find all posts by this user
Quote this message in a reply
7th Jul, 2016, 08:09 AM
Post: #9
RE: Raspberry Pi 3 loosing wifi - busy status
(7th Jul, 2016 05:47 AM)mgouin Wrote:  AP : You mean my wifi access point? My wifi router?

Yes, AP == AccessPoint Smile

Quote:What I still don't understand is the busy status reported in Kodi...

Kodi tries to check online status, and if no network is working, it takes a little bit longer ...

Quote:Also, regarding your script, I'm ok fiddling with cron jobs, however I'm not sure which commands would work for resetting/reconnecting the wifi.

This should work for you:

Code:
#!/bin/bash

ROUTERIP="192.168.1.10"

if ping -c3 $ROUTERIP > /dev/null 2&>1; then

    echo "Restart network"
    /sbin/ifdown -a
    /sbin/ifup -a
fi

ROUTERIP is the IP of your access point/router

Don't forget to make this script executable and put it then into cronjob (sudo crontab -e)
Find all posts by this user
Quote this message in a reply
8th Jul, 2016, 02:17 PM
Post: #10
RE: Raspberry Pi 3 loosing wifi - busy status
Thanks for the script I'll try it.

However, I remember last time it hang, I found the option in XBian to click the shutdown button, then select exit. This way, without network connectivity, I was able to login directly on they Pi with the TV screen to try reconnecting it live.

I had tried the following with no success:

Terminal
sudo ifdown wlan0
sudo ifup wlan0

Next time, I'll try with "-a" flag and see if it helps...

Also, if it can help: the output of "ifconfig" when disconnected vs operational is identical (except for rx,tx byte count).

However,
iwconfig operational (I prepended stars to lines only present when up):
Code:
wlan0     IEEE 802.11bgn  ESSID:"mgmg"  
          Mode:Managed  Frequency:2.462 GHz  Access Point: 68:15:90:3A:1B:7E  
*         Bit Rate=72.2 Mb/s   Tx-Power=31 dBm  
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
*         Link Quality=70/70  Signal level=-38 dBm  
*         Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
*         Tx excessive retries:477  Invalid misc:0   Missed beacon:0

iwconfig down is:
Code:
wlan0     IEEE 802.11bgn  ESSID:"mgmg"  
          Mode:Managed  Frequency:2.462 GHz  Access Point: 68:15:90:3A:1B:7E  
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
Find all posts by this user
Quote this message in a reply
8th Jul, 2016, 08:41 PM (This post was last modified: 8th Jul, 2016 08:53 PM by Nachteule.)
Post: #11
RE: Raspberry Pi 3 loosing wifi - busy status
Uh, looks not nice. Seems driver is being confused. In this case -a option does not help

Try this script on next failure:

Code:
#!/bin/bash

ROUTERIP="192.168.1.10"

if ! ping -c3 $ROUTERIP > /dev/null 2&>1; then
    echo "Restart WLAN"
    /sbin/ifdown --force wlan0
    /usr/bin/killall wpa_supplicant
    /sbin/rmmod brcmfmac
    /sbin/modprobe brcmfmac
    sleep 5
    /sbin/ifup -a
fi

This reloads module brcmfmac. Last command (/sbin/ifup -a is optional and should not be necessary)
Find all posts by this user
Quote this message in a reply
10th Jul, 2016, 12:08 PM
Post: #12
RE: Raspberry Pi 3 loosing wifi - busy status
Thanks for the commands, I will try that next failure...

I don't know if it's related, but I also noticed that recently, my ssh connections are becoming unreliable.

I explain: Usually, I can connect with no problem. On some rare occasion, just after password entry, there is a long delay of about 30 seconds.

But the most frequent issue is that regularly, while typing, the ssh session seems to not accept any keys. The session is still open, I can ping the PI so network is not down. However the session does not respond to any keypress. After about 30s to 1min (approx), this usually comes to normal and the "buffered" keys appear in the bash prompt. Then, I can type without lag for 1min, then freeze again.

This is driving me nuts... Huh
Find all posts by this user
Quote this message in a reply
10th Jul, 2016, 08:03 PM
Post: #13
RE: Raspberry Pi 3 loosing wifi - busy status
AFAIR I had similar strange behavior before I changed wlan channel at my AP 2 weeks ago. Since I did this, connection seems to be stable again (I switched from 6 to 1). Could you try this?
Find all posts by this user
Quote this message in a reply
12th Jul, 2016, 08:37 AM
Post: #14
RE: Raspberry Pi 3 loosing wifi - busy status
I did not change my AP channel, I'm not even sure my router supports that...

I will try, but if that was the problem, not just SSH would be flaky, right?

Repeated pings are working fine...

I start to suspect the latest apt upgrade I did from xbian-config utility.
Find all posts by this user
Quote this message in a reply
21st Jul, 2016, 11:31 PM
Post: #15
RE: Raspberry Pi 3 loosing wifi - busy status
(8th Jul, 2016 08:41 PM)Nachteule Wrote:  Try this script on next failure:
Code:
#!/bin/bash

ROUTERIP="192.168.1.10"

if ! ping -c3 $ROUTERIP > /dev/null 2&>1; then
    echo "Restart WLAN"
    /sbin/ifdown --force wlan0
    /usr/bin/killall wpa_supplicant
    /sbin/rmmod brcmfmac
    /sbin/modprobe brcmfmac
    sleep 5
    /sbin/ifup -a
fi

I tried it and it at the "modprobe brcmfmac" command, it resulted in internal error oops 17. Refer to the attached screen shot. Sorry for poor quality, I took a picture of my TV at that point because no wifi, so no ssh access...

EDIT: I cannot add an attachment to the post? Is this normal?
Find all posts by this user
Quote this message in a reply
Post Reply 


Possibly Related Threads...
Thread: Author Replies Views: Last Post
  Issue with Official Raspberry Pi Wifi Dongle nmrcantao 1 1,724 9th Jan, 2016 11:44 PM
Last Post: IriDium

Forum Jump: