Thank you for your donation


Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
aMule install
16th Oct, 2016, 03:04 AM
Post: #1
aMule install
Hi

I am trying to install aMule on xBian, is it possible?

Code:
sudo apt-get install
Code:
sudo apt-get -y upgrade
Code:
sudo reboot
Code:
sudo apt-get install amule-daemon
Code:
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package amule-daemon
Code:
sudo nano /etc/apt/sources.list
I add:
Code:
deb http://archive.raspbian.org/raspbian wheezy main contrib non-free
deb-src http://archive.raspbian.org/raspbian wheezy main contrib non-free
Code:
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package amule-daemon

Best regards
Find all posts by this user
Quote this message in a reply
16th Oct, 2016, 06:43 AM
Post: #2
RE: aMule install
You need to run update after adding a repo.

Please read rules and do a search before you post! | FAQs | How to post log file? | Can't find an answer? Contact us.
Visit this user's website Find all posts by this user
Quote this message in a reply
16th Oct, 2016, 06:51 AM
Post: #3
RE: aMule install
(16th Oct, 2016 06:43 AM)f1vefour Wrote:  You need to run update after adding a repo.
Thanks

After repeating:
Terminal
sudo apt-get install
sudo apt-get -y upgrade
sudo reboot
sudo apt-get install amule-daemon

Same result:

Terminal
xbian@xbian ~ $ sudo apt-get install amule-daemon
[sudo] password for xbian:
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package amule-daemon
Find all posts by this user
Quote this message in a reply
16th Oct, 2016, 06:55 AM (This post was last modified: 16th Oct, 2016 06:57 AM by Nachteule.)
Post: #4
RE: aMule install
Nope, this package is not in Debian Jessie repo

You could try downloading it from raspbian repo: http://archive.raspbian.org/raspbian/pool/main/a/amule/
Find all posts by this user
Quote this message in a reply
16th Oct, 2016, 07:14 AM
Post: #5
RE: aMule install
(16th Oct, 2016 06:55 AM)Nachteule Wrote:  Nope, this package is not in Debian Jessie repo

You could try downloading it from raspbian repo: http://archive.raspbian.org/raspbian/pool/main/a/amule/

Thanks Nachteule.

How do I do that? Is it about downloading and compiling or something? I don't know about this Sad
I don't even know what to download betewwn all those files Confused
Find all posts by this user
Quote this message in a reply
16th Oct, 2016, 08:31 AM
Post: #6
RE: aMule install
I suppose you need -daemon and -common debs.

Download them and then run dpkg -i ... command
Find all posts by this user
Quote this message in a reply
16th Oct, 2016, 08:47 AM
Post: #7
RE: aMule install
(16th Oct, 2016 08:31 AM)Nachteule Wrote:  I suppose you need -daemon and -common debs.

Download them and then run dpkg -i ... command

Thanks

This seems to work:
Terminal
xbian@xbian /JDownloader $ sudo dpkg -i amule-common_2.3.2-1_all.deb
Selecting previously unselected package amule-common.
(Reading database ... 29828 files and directories currently installed.)
Preparing to unpack amule-common_2.3.2-1_all.deb ...
Unpacking amule-common (1:2.3.2-1) ...
Setting up amule-common (1:2.3.2-1) ...

But this seems to need some dependencies:
Terminal
xbian@xbian /JDownloader $ sudo dpkg -i amule-daemon_2.3.2-1_armhf.deb Selecting previously unselected package amule-daemon.
(Reading database ... 29953 files and directories currently installed.)
Preparing to unpack amule-daemon_2.3.2-1_armhf.deb ...
Unpacking amule-daemon (1:2.3.2-1) ...
dpkg: dependency problems prevent configuration of amule-daemon:
amule-daemon depends on libboost-system1.61.0; however:
Package libboost-system1.61.0 is not installed.
amule-daemon depends on libcrypto++6; however:
Package libcrypto++6 is not installed.
amule-daemon depends on libpng16-16 (>= 1.6.2-1); however:
Package libpng16-16 is not installed.
amule-daemon depends on libreadline7 (>= 6.0); however:
Package libreadline7 is not installed.
amule-daemon depends on libstdc++6 (>= 5.2); however:
Version of libstdc++6:armhf on system is 4.9.2-10.
amule-daemon depends on libupnp6 (>= 1:1.6.13); however:
Package libupnp6 is not installed.
amule-daemon depends on libwxbase3.0-0v5 (>= 3.0.2+dfsg); however:
Package libwxbase3.0-0v5 is not installed.

dpkg: error processing package amule-daemon (--install):
dependency problems - leaving unconfigured
Processing triggers for systemd (215-17+deb8u5) ...
Processing triggers for man-db (2.7.0.2-5) ...
Errors were encountered while processing:
amule-daemon

Should I try better MLDonkey????
Find all posts by this user
Quote this message in a reply
16th Oct, 2016, 09:05 PM
Post: #8
RE: aMule install
Please run:

Terminal

sudo apt-get install -f

This command should install unmet dependencies and finishes installation of amule-daemon

MLdonkey? Don't know. Used those programs 10 years ago ...
Find all posts by this user
Quote this message in a reply
17th Nov, 2016, 05:05 AM
Post: #9
RE: aMule install
Hi,
I have executed apt-get install -f as you told me and that command deletes de amule-daemon packages
Sad.
Please, coudl you help me?
Find all posts by this user
Quote this message in a reply
17th Nov, 2016, 06:05 AM
Post: #10
RE: aMule install
@zelgadis2

Without output of apt-get install -f can not help, sorry
Find all posts by this user
Quote this message in a reply
17th Nov, 2016, 07:11 AM
Post: #11
RE: aMule install
(17th Nov, 2016 05:05 AM)zelgadis2 Wrote:  Hi,
I have executed apt-get install -f as you told me and that command deletes de amule-daemon packages
Sad.
Please, coudl you help me?
Forget amule.
MLDonkey works like a charm on xBian.
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump: