Full Version: Solved: Pisnes gamepad or keyboard control only after plugging in a mouse
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I am currently trying to use my recently purchased Raspberry Pi as a mediacenter and retro game platform, using pisnes (snes9x, adapted for the Pi) . I am currently trying and comparing raspbmc and xbian. Currently I think xbian suits me better. There is however one very weird issue with xbian, that I don't experience on raspbmc. I do not know if this is a problem in xbian, or in pisnes or even in the Pi hardware itself or a combination of these, but I have to start somewehere, hence my question here.

To start a game I exit XBMC and log in to the console. I can start snes games in Pisnes but only have control (keyboard or gamepad) after a mouse is/has been plugged in. Without it, a game launches, I have video and sound output but my gamepad doesn't do anything and the only keys on my keyboard that get a response are CTRL-C to quit the game. When I return to the console I do see all the keys I have been pressing on screen, so the system does receive them. While troubleshooting this issue I installed Scummvm, as another application that uses SDL to see if the problem lies in SDL. Launching Scummvm it says a mouse is missing, so for testing purposes I plugged in a mouse on a free USB port. Scummvm started. And to my big surprise now I also can control games in pisnes. also after I remove the mouse. After a reboot I have to insert the mouse again to get it working again.

Like I said, I do not have this on my raspbmc setup installed on another SD card. Could this be a problem in SDL or the configuration of SDL on xbian? Does anybody else experience similar issues with pisnes or other SDL based applications in xbian?

I would prefer to use xbian and hope we can sort this wierd problem out. Of course I will continue finding a solution. When I find one I will report this here


XBian version: XBian 1.0 Beta 2
XBMC version: 12.2 Git:20130916-091cb29
Overclock settings: default

Power supply rating: 4.8V 1A
RPi model (model A/B 256mb/512mb): B
SD card size and make/type: Sandisk ultra II, 4Gb, class 4
Network (wireless or LAN): LAN
Connected devices (TV, USB, network storage, etc.): Sony Bravia TV via HDMI, Logitech "Internet 350" keyboard via USB, Trustmaster "Dual analog 4" gamepad via USB

Hmmm, I just did an apt-get update and apt-get upgrade to see if this would fix anything. When I exit XBMC now to go to the console, XBMC automatically launches itself. One of the reasons to prefer xbian over raspbmc was that xbian didn't do this. Now, to get a console I have to ssh into the machine and kill the xbmc.bin proces. Not handy. Also not handy is the fact that after killing xbmc I get wierd characters from the command prompt and I cannot log in. These are however completely other issues.

I have eventually been able to test pisnes once more, but the issues remain
Had a bright moment in the shower this morning where I thought that the plugging in of a mouse might trigger the load of a kernel module. This would explain why it works after plugging in a mouse. And indeed: lsmod showed the module "mousedev" loaded after plugging in a mouse while it wasn't there before. I added the module to /etc/modules and all is fine now. A little weird that this module is needed to use my keyboard in pisnes but hey, it works...

Next: starting a game from XBMC, but that's a completely different challenge :-)
1) Have you tried the addon ROM Browser - I believe it was written to directly support some games within XBMC
2) You may be better suited to having Rasbian with Xbian rather that native Xbian - which was designed to be a Media Player rather than a mix and match - See

Not related - but I would check your PSU - 4.8V may not be enough in some cases (5.1V is the preferred supply)
Hi IriDium,

Thanks for the reply.
1.) Yes, but I haven't been able to succesvfully start a game from there in both xbian or raspbmc :-(
2.) Thanks for the tip. Perhaps that works better. Going to try...

Reference URL's