Forum

Full Version: Kodi 17.4 is not playing video smoothly.
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I want to go back to previous version but Xbian is downloading with Kodi 17.4
Where can I download the previous version?
Or does someone have a solution for this problem with video that stops every 3 or 4 seconds?
Thanks
(9th Sep, 2017 10:23 AM)GastonBA Wrote: [ -> ]I want to go back to previous version but Xbian is downloading with Kodi 17.4
Where can I download the previous version?

Solution A)
1) revert to a snapshot before you upgraded Kodi and CEC packages. This can be done in xbian-config GUI, section Backup
It it is enough to revert subvolume root only
2) reboot

Solution B)
1) open a ssh connection
2) sudo apt-get update
3) sudo apt-cache policy xbian-package-xbmc
This shows you a list of available versions of xbian-package-xbmc
4) sudo apt-get install xbian-package-xbmc=<version_you_want>
for example sudo apt-get install xbian-package-xbmc=17.3-1498401095
5) Important: if you are running Debian Stretch, you have to install previous versions of cec packages also

Quote:Or does someone have a solution for this problem with video that stops every 3 or 4 seconds?
Thanks

Not yet, as already told, I do not have any issues playing vids on my Hummingboard
(10th Sep, 2017 12:20 AM)Nachteule Wrote: [ -> ]
(9th Sep, 2017 10:23 AM)GastonBA Wrote: [ -> ]I want to go back to previous version but Xbian is downloading with Kodi 17.4
Where can I download the previous version?

Solution A)
1) revert to a snapshot before you upgraded Kodi and CEC packages. This can be done in xbian-config GUI, section Backup
It is enough to revert subvolume root only
2) reboot

Solution B)
1) open a ssh connection
2) sudo apt-get update
3) sudo apt-cache policy xbian-package-xbmc
This shows you a list of available versions of xbian-package-xbmc
4) sudo apt-get install xbian-package-xbmc=<version_you_want>
for example sudo apt-get install xbian-package-xbmc=17.3-1498401095
5) Important: if you are running Debian Stretch, you have to install previous versions of cec packages also

Quote:Or does someone have a solution for this problem with video that stops every 3 or 4 seconds?
Thanks

Not yet, as already told, I do not have any issues playing vids on my Hummingboard

Thanks!
That´s what I was doing. I went back to weekly snapshot.
I can´t tell if the problem starts when upgrading to 17.4 of when upgrading to Debian Stretch. How can I know which Debian I´m running?
(10th Sep, 2017 03:57 AM)GastonBA Wrote: [ -> ]I can´t tell if the problem starts when upgrading to 17.4 of when upgrading to Debian Stretch. How can I know which Debian I´m running?

Please look here for example
Not a Debian 9 issue.... running it with Kodi 17.3 and i don't have any new problems. (Pi 1 B)
I start again from Debian 8 and Kodi 17.3

I installed each update one by one. And everything runs smoothly.
Then there were only two updates left. Kodi 17.4 (Xbian Update) and Debian Stretch.
I try Kodi first...
And there it was the problem again. Video stops and catch up fast. Impossible to view.

I´m roling back to 17.3 and I´ll try updating to stretch staying on Kodi 17.3
(21st Sep, 2017 10:48 AM)GastonBA Wrote: [ -> ]I start again from Debian 8 and Kodi 17.3

I installed each update one by one. And everything runs smoothly.
Then there were only two updates left. Kodi 17.4 (Xbian Update) and Debian Stretch.
I try Kodi first...
And there it was the problem again. Video stops and catch up fast. Impossible to view.

I´m roling back to 17.3 and I´ll try updating to stretch staying on Kodi 17.3

Thanks for your testing.

I'll try to reproduce this issue next days. Till now, I do not have any issue running Kodi 17.4 / Debian Stretch on my Hummingboard Quad Core / 2G Ram

That's really confusing me Confused
(21st Sep, 2017 08:56 PM)Nachteule Wrote: [ -> ]
(21st Sep, 2017 10:48 AM)GastonBA Wrote: [ -> ]I start again from Debian 8 and Kodi 17.3

I installed each update one by one. And everything runs smoothly.
Then there were only two updates left. Kodi 17.4 (Xbian Update) and Debian Stretch.
I try Kodi first...
And there it was the problem again. Video stops and catch up fast. Impossible to view.

I´m roling back to 17.3 and I´ll try updating to stretch staying on Kodi 17.3

Thanks for your testing.

I'll try to reproduce this issue next days. Till now, I do not have any issue running Kodi 17.4 / Debian Stretch on my Hummingboard Quad Core / 2G Ram

That's really confusing me Confused


My configuration is different.
I'm on a Cubox i2 only 1gb Ram.



Enviado desde mi iPhone utilizando Tapatalk
(21st Sep, 2017 09:16 PM)GastonBA Wrote: [ -> ]My configuration is different.
I'm on a Cubox i2 only 1gb Ram.

Yeah, but don't believe that this is the culprit (usually having 1.4G of free RAM and cpu load is below 10%)
Stretch Installation took a long time, so I left it over night.
Today when I start the system, Stretch was installed but also Kodi 17.4, so it´s not working fine again.

I´m rolling back to previous snapshot again.
One questión about this... When I select rollback I get four options...
HOME
STORAGE
ROOT
DATA
which of the four is the most complete going back to previous snapshot?
Thanks!

I was planning to roll back again, but is there a way to upgrade stretch without upgrading Kodi?
Thanks again.
(22nd Sep, 2017 06:00 AM)GastonBA Wrote: [ -> ]Stretch Installation took a long time, so I left it over night.
Today when I start the system, Stretch was installed but also Kodi 17.4, so it´s not working fine again.

I´m rolling back to previous snapshot again.
One questión about this... When I select rollback I get four options...
HOME
STORAGE
ROOT
DATA
which of the four is the most complete going back to previous snapshot?
Thanks!

I was planning to roll back again, but is there a way to upgrade stretch without upgrading Kodi?
Thanks again.

You could set xbian-package-xbmc to hold before upgrading. But this does not make sense, because a lot of dependencies will not be updated and you'll have a mix of Jessie and Stretch

Please read my previous posts. All your questiions are already answered

Btw, you do not revert to a snapshot, it's just enough to install older version of Kodi (explained in Solution B)
Thanks!

I was going to try solution B, but this line scares me away:
5) Important: if you are running Debian Stretch, you have to install previous versions of cec packages also
(22nd Sep, 2017 07:24 AM)GastonBA Wrote: [ -> ]Thanks!

I was going to try solution B, but this line scares me away:
5) Important: if you are running Debian Stretch, you have to install previous versions of cec packages also

4.0.2.1~xbian-1489608861 is the version you need
Reference URL's