Thank you for your donation


Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Kodi 17.4 is not playing video smoothly.
9th Sep, 2017, 10:23 AM
Post: #1
Kodi 17.4 is not playing video smoothly.
I want to go back to previous version but Xbian is downloading with Kodi 17.4
Where can I download the previous version?
Or does someone have a solution for this problem with video that stops every 3 or 4 seconds?
Thanks
Find all posts by this user
Quote this message in a reply
10th Sep, 2017, 12:20 AM (This post was last modified: 12th Sep, 2017 04:53 AM by Nachteule.)
Post: #2
RE: Kodi 17.4 is not playing video smoothly.
(9th Sep, 2017 10:23 AM)GastonBA Wrote:  I want to go back to previous version but Xbian is downloading with Kodi 17.4
Where can I download the previous version?

Solution A)
1) revert to a snapshot before you upgraded Kodi and CEC packages. This can be done in xbian-config GUI, section Backup
It it is enough to revert subvolume root only
2) reboot

Solution B)
1) open a ssh connection
2) sudo apt-get update
3) sudo apt-cache policy xbian-package-xbmc
This shows you a list of available versions of xbian-package-xbmc
4) sudo apt-get install xbian-package-xbmc=<version_you_want>
for example sudo apt-get install xbian-package-xbmc=17.3-1498401095
5) Important: if you are running Debian Stretch, you have to install previous versions of cec packages also

Quote:Or does someone have a solution for this problem with video that stops every 3 or 4 seconds?
Thanks

Not yet, as already told, I do not have any issues playing vids on my Hummingboard
Find all posts by this user
Quote this message in a reply
10th Sep, 2017, 03:57 AM
Post: #3
RE: Kodi 17.4 is not playing video smoothly.
(10th Sep, 2017 12:20 AM)Nachteule Wrote:  
(9th Sep, 2017 10:23 AM)GastonBA Wrote:  I want to go back to previous version but Xbian is downloading with Kodi 17.4
Where can I download the previous version?

Solution A)
1) revert to a snapshot before you upgraded Kodi and CEC packages. This can be done in xbian-config GUI, section Backup
It is enough to revert subvolume root only
2) reboot

Solution B)
1) open a ssh connection
2) sudo apt-get update
3) sudo apt-cache policy xbian-package-xbmc
This shows you a list of available versions of xbian-package-xbmc
4) sudo apt-get install xbian-package-xbmc=<version_you_want>
for example sudo apt-get install xbian-package-xbmc=17.3-1498401095
5) Important: if you are running Debian Stretch, you have to install previous versions of cec packages also

Quote:Or does someone have a solution for this problem with video that stops every 3 or 4 seconds?
Thanks

Not yet, as already told, I do not have any issues playing vids on my Hummingboard

Thanks!
That´s what I was doing. I went back to weekly snapshot.
I can´t tell if the problem starts when upgrading to 17.4 of when upgrading to Debian Stretch. How can I know which Debian I´m running?
Find all posts by this user
Quote this message in a reply
10th Sep, 2017, 04:32 AM
Post: #4
RE: Kodi 17.4 is not playing video smoothly.
(10th Sep, 2017 03:57 AM)GastonBA Wrote:  I can´t tell if the problem starts when upgrading to 17.4 of when upgrading to Debian Stretch. How can I know which Debian I´m running?

Please look here for example
Find all posts by this user
Quote this message in a reply
12th Sep, 2017, 02:08 AM
Post: #5
RE: Kodi 17.4 is not playing video smoothly.
Not a Debian 9 issue.... running it with Kodi 17.3 and i don't have any new problems. (Pi 1 B)

:) :)
Find all posts by this user
Quote this message in a reply
21st Sep, 2017, 10:48 AM
Post: #6
RE: Kodi 17.4 is not playing video smoothly.
I start again from Debian 8 and Kodi 17.3

I installed each update one by one. And everything runs smoothly.
Then there were only two updates left. Kodi 17.4 (Xbian Update) and Debian Stretch.
I try Kodi first...
And there it was the problem again. Video stops and catch up fast. Impossible to view.

I´m roling back to 17.3 and I´ll try updating to stretch staying on Kodi 17.3
Find all posts by this user
Quote this message in a reply
21st Sep, 2017, 08:56 PM
Post: #7
RE: Kodi 17.4 is not playing video smoothly.
(21st Sep, 2017 10:48 AM)GastonBA Wrote:  I start again from Debian 8 and Kodi 17.3

I installed each update one by one. And everything runs smoothly.
Then there were only two updates left. Kodi 17.4 (Xbian Update) and Debian Stretch.
I try Kodi first...
And there it was the problem again. Video stops and catch up fast. Impossible to view.

I´m roling back to 17.3 and I´ll try updating to stretch staying on Kodi 17.3

Thanks for your testing.

I'll try to reproduce this issue next days. Till now, I do not have any issue running Kodi 17.4 / Debian Stretch on my Hummingboard Quad Core / 2G Ram

That's really confusing me Confused
Find all posts by this user
Quote this message in a reply
21st Sep, 2017, 09:16 PM
Post: #8
Kodi 17.4 is not playing video smoothly.
(21st Sep, 2017 08:56 PM)Nachteule Wrote:  
(21st Sep, 2017 10:48 AM)GastonBA Wrote:  I start again from Debian 8 and Kodi 17.3

I installed each update one by one. And everything runs smoothly.
Then there were only two updates left. Kodi 17.4 (Xbian Update) and Debian Stretch.
I try Kodi first...
And there it was the problem again. Video stops and catch up fast. Impossible to view.

I´m roling back to 17.3 and I´ll try updating to stretch staying on Kodi 17.3

Thanks for your testing.

I'll try to reproduce this issue next days. Till now, I do not have any issue running Kodi 17.4 / Debian Stretch on my Hummingboard Quad Core / 2G Ram

That's really confusing me Confused


My configuration is different.
I'm on a Cubox i2 only 1gb Ram.



Enviado desde mi iPhone utilizando Tapatalk
Find all posts by this user
Quote this message in a reply
22nd Sep, 2017, 02:05 AM
Post: #9
RE: Kodi 17.4 is not playing video smoothly.
(21st Sep, 2017 09:16 PM)GastonBA Wrote:  My configuration is different.
I'm on a Cubox i2 only 1gb Ram.

Yeah, but don't believe that this is the culprit (usually having 1.4G of free RAM and cpu load is below 10%)
Find all posts by this user
Quote this message in a reply
22nd Sep, 2017, 06:00 AM
Post: #10
RE: Kodi 17.4 is not playing video smoothly.
Stretch Installation took a long time, so I left it over night.
Today when I start the system, Stretch was installed but also Kodi 17.4, so it´s not working fine again.

I´m rolling back to previous snapshot again.
One questión about this... When I select rollback I get four options...
HOME
STORAGE
ROOT
DATA
which of the four is the most complete going back to previous snapshot?
Thanks!

I was planning to roll back again, but is there a way to upgrade stretch without upgrading Kodi?
Thanks again.
Find all posts by this user
Quote this message in a reply
22nd Sep, 2017, 07:14 AM
Post: #11
RE: Kodi 17.4 is not playing video smoothly.
(22nd Sep, 2017 06:00 AM)GastonBA Wrote:  Stretch Installation took a long time, so I left it over night.
Today when I start the system, Stretch was installed but also Kodi 17.4, so it´s not working fine again.

I´m rolling back to previous snapshot again.
One questión about this... When I select rollback I get four options...
HOME
STORAGE
ROOT
DATA
which of the four is the most complete going back to previous snapshot?
Thanks!

I was planning to roll back again, but is there a way to upgrade stretch without upgrading Kodi?
Thanks again.

You could set xbian-package-xbmc to hold before upgrading. But this does not make sense, because a lot of dependencies will not be updated and you'll have a mix of Jessie and Stretch

Please read my previous posts. All your questiions are already answered

Btw, you do not revert to a snapshot, it's just enough to install older version of Kodi (explained in Solution B)
Find all posts by this user
Quote this message in a reply
22nd Sep, 2017, 07:24 AM
Post: #12
RE: Kodi 17.4 is not playing video smoothly.
Thanks!

I was going to try solution B, but this line scares me away:
5) Important: if you are running Debian Stretch, you have to install previous versions of cec packages also
Find all posts by this user
Quote this message in a reply
22nd Sep, 2017, 08:01 AM
Post: #13
RE: Kodi 17.4 is not playing video smoothly.
(22nd Sep, 2017 07:24 AM)GastonBA Wrote:  Thanks!

I was going to try solution B, but this line scares me away:
5) Important: if you are running Debian Stretch, you have to install previous versions of cec packages also

4.0.2.1~xbian-1489608861 is the version you need
Find all posts by this user
Quote this message in a reply
4th Oct, 2017, 06:29 AM
Post: #14
RE: Kodi 17.4 is not playing video smoothly.
Having this issue too.

(10th Sep, 2017 12:20 AM)Nachteule Wrote:  
(9th Sep, 2017 10:23 AM)GastonBA Wrote:  I want to go back to previous version but Xbian is downloading with Kodi 17.4
Where can I download the previous version?

Solution A)
1) revert to a snapshot before you upgraded Kodi and CEC packages. This can be done in xbian-config GUI, section Backup
It it is enough to revert subvolume root only
2) reboot

Solution B)
1) open a ssh connection
2) sudo apt-get update
3) sudo apt-cache policy xbian-package-xbmc
This shows you a list of available versions of xbian-package-xbmc
4) sudo apt-get install xbian-package-xbmc=<version_you_want>
for example sudo apt-get install xbian-package-xbmc=17.3-1498401095
5) Important: if you are running Debian Stretch, you have to install previous versions of cec packages also

Quote:Or does someone have a solution for this problem with video that stops every 3 or 4 seconds?
Thanks

Not yet, as already told, I do not have any issues playing vids on my Hummingboard


If you do solution B, do you lose your add ons/data?
Find all posts by this user
Quote this message in a reply
4th Oct, 2017, 07:32 AM
Post: #15
RE: Kodi 17.4 is not playing video smoothly.
(4th Oct, 2017 06:29 AM)cairnarvon Wrote:  If you do solution B, do you lose your add ons/data?

No, Kodi's config folder (/home/xbian/.kodi) is never be lost
Find all posts by this user
Quote this message in a reply
Post Reply 


Possibly Related Threads...
Thread: Author Replies Views: Last Post
  Kodi is not working smoothly karanda 1 2,261 26th Oct, 2015 06:12 PM
Last Post: karanda
  [PROBLEM] Airplay playing only sound, never video igorkulman 3 27,680 11th Jan, 2015 05:50 AM
Last Post: rikardo1979
  [PROBLEM] Auto-update to RC3 -> playing video files not working anymore syco 15 15,647 17th Sep, 2014 10:40 AM
Last Post: moocow
  Playing next video Baz8755 8 10,641 28th Oct, 2013 04:49 AM
Last Post: rikardo1979

Forum Jump: