Forum

Full Version: Kodi v18 (Leia) testbuilds
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2


It's not a carneval joke Big Grin testbuilds for Kodi v18 are available for download
  • How to get it?
    1. You have to enable devel repo
    2. Refresh package list
    3. Install (upgrade) xbian-package-xbmc
  • Some useful hints
    1. Make sure that you have latest xbian-package-config-shell installed
      At least 20180116-0 is required
    2. The helper script script.module.inputstreamhelper needs already loaded loop module
      This is already fixed but probably not available yet for download. So make sure that loop module is loaded before you're upgrading libwivedine
      EDIT: not longer needed due to new version of script.module.inputstreamhelper

It should be noted that those testbuilds are available for Raspberry Pi 0-3 only
Hi Nachteule, do you know if and when it'll be available on cubox-i also?
Thanks and keep up the good work!
(18th Mar, 2018 10:13 PM)unbroken Wrote: [ -> ]Hi Nachteule, do you know if and when it'll be available on cubox-i also?
Thanks and keep up the good work!

iMX6 support has been removed from current Kodi Leia sources, so probably there will never be a version for Cubox-i available
Hi Nachteule

I tried K18 from your instructions and all worked

just wanted to tell you that since Kodi 16 I have had to change CEC behavior in sources because of this

https://github.com/Pulse-Eight/libcec/issues/326

in fact by changing this in libcec and compiling deb it all goes back to normal and also RSS speed is fluid

If this isnt pushed RSS is sluggish and CEC skips input even if only one pulse from remote

thanks
raf
@rafhtl
(24th Mar, 2018 11:43 PM)rafhtl Wrote: [ -> ]https://github.com/Pulse-Eight/libcec/issues/326

in fact by changing this in libcec and compiling deb it all goes back to normal and also RSS speed is fluid

If this isnt pushed RSS is sluggish and CEC skips input even if only one pulse from remote

thanks
raf

What exactly did you change? Reverting this commit?
exactly!
On MasterV3 branch works perfectly!
In fact there is no need for that new code and a lot of users are suffering from this!

I have the exact code I can give you if u want

raf
thanks
(25th Mar, 2018 12:53 AM)rafhtl Wrote: [ -> ]exactly!
On MasterV3 branch works perfectly!
In fact there is no need for that new code and a lot of users are suffering from this!

I have the exact code I can give you if u want

raf
thanks

Yes, please Angel

So, you're running libcec v3 (masterv3 branch), and this works? HuhHuh That's really confusing me Huh
sorry I wasnt clear

So on isengard we know that we can only use 3 and not libcec4

After isengard on 16 17 and 18 we use master (v4)

I tested this (libcec3 modded by me) on isengard and compiled correctly and solved the problem of double skip and sluggish rss feed.
And I realized this change was in fact giving problems since it was committed (2014) during isengard

So I kept my mods and everything was fine

Then when we started using libcec4 I realized same problems where occurring so this "REVERT" or change can easily be done on Master CEC and it will fix this problem also for kodi 16 17 and... I suppose... 18

Hope to have explained better
thanks
raf
Yes, you did it Smile
HI i'm new to xbian, and i was trying to upgrade to leia on a ras pi 3 (B+) and after i upgraded the terminal, turning on devl packages and upgrading everything, I reboot and nothing really happens. The green LED on the pi stays on, but thats about it.
Quote:The helper script script.module.inputstreamhelper needs already loaded loop module

I didn't do that, so maybe that has somthing to do with it?
And if it does, I don't know what you mean or how to do that.

~Logos
(14th Apr, 2018 01:35 AM)Logos_Coder Wrote: [ -> ]HI i'm new to xbian, and i was trying to upgrade to leia on a ras pi 3 (B+) and after i upgraded the terminal, turning on devl packages and upgrading everything, I reboot and nothing really happens. The green LED on the pi stays on, but thats about it.
Quote:The helper script script.module.inputstreamhelper needs already loaded loop module

I didn't do that, so maybe that has somthing to do with it?

No, it does not. script.module.inputstreamhelper is just needed for updating that libwivedine stuff required by inputstream addon

Ohhh, I think I know what happened. You probably installed package xbian-package-firmware from devel repo, but unfortunately this is old stuff which does not support Pi3B+
(14th Apr, 2018 02:55 AM)Nachteule Wrote: [ -> ]No, it does not. script.module.inputstreamhelper is just needed for updating that libwivedine stuff required by inputstream addon

Ohhh, I think I know what happened. You probably installed package xbian-package-firmware from devel repo, but unfortunately this is old stuff which does not support Pi3B+

That did work! Though... after I tried installing the netflix module (link here), but I needed to install pip so I could install the pycryptodomex module. while it was installing it went into read only mode, (I did
Code:
dmesg | less
to look at the error but I didn't document it. Sorry Undecided) I shutdown, unplug, plug back in but all I got was a not-blinking cursor in the top left. put the sd into the comuter and gparted can't seem to read it.

ps; I did some other things before resurching what might be wrong, like
Code:
sudo chmod -R 666 /
and canceled it half-way through

~Logos
(14th Apr, 2018 01:42 PM)Logos_Coder Wrote: [ -> ]
(14th Apr, 2018 02:55 AM)Nachteule Wrote: [ -> ]No, it does not. script.module.inputstreamhelper is just needed for updating that libwivedine stuff required by inputstream addon

Ohhh, I think I know what happened. You probably installed package xbian-package-firmware from devel repo, but unfortunately this is old stuff which does not support Pi3B+

That did work! Though... after I tried installing the netflix module (link here), but I needed to install pip so I could install the pycryptodomex module. while it was installing it went into read only mode, (I did
Code:
dmesg | less
to look at the error but I didn't document it. Sorry Undecided) I shutdown, unplug, plug back in but all I got was a not-blinking cursor in the top left. put the sd into the comuter and gparted can't seem to read it.

ps; I did some other things before resurching what might be wrong, like
Code:
sudo chmod -R 666 /
and canceled it half-way through

~Logos

1) That's one of the most annoying issues of the Pi3B+: The default clock settings leads in a unstable configuration, please set overclocking mode in xbian-config to Pi3B+:XBian or add sdram_frequ=450 manually to /boot/config.txt

2) I'm wondering if you have to install pip to install pycryptodomex module, because the required debian package should be installed automatically

Terminal

root@kmxbilr2 ~ # dpkg-query -s xbian-package-xbmc | grep ^Depends | grep -o python-pycryptodome
python-pycryptodome
root@kmxbilr2 ~ #

3) XBian is using BTRFS with LZ4 compression for root partition, so usually you can't read this partition from a standard (windows) system

4) AFAIK Netflix addon seems to be currently broken, see this issue
EDIT: Tried again to make Netflix addon work, and now I got success. You have to disable OMXplayer to make it work

5) Oh yes, running sudo chmod -R 666 / was a very bad idea
sorry but we are still with this version?
(30th Jun, 2018 12:44 AM)roboso Wrote: [ -> ]sorry but we are still with this version?

Yes, we are (alpha3)
Pages: 1 2
Reference URL's