Thank you for your donation


Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Solved: Unable to install libav-tools, ffmpeg etc. on Stretch
14th Sep, 2017, 09:24 AM
Post: #5
RE: Unable to install libav-tools, ffmpeg etc. on Stretch
(14th Sep, 2017 02:14 AM)Nachteule Wrote:  @Gyuunduh

New xbian-package-firmware available.

Please update this package and after that installing ffmpeg shouldn't complain anything Smile

Thanks @Nachteule , ffmpeg and libav-tools can now be installed.

But now I'm running into an issue I didn't have before the debian upgrade. I need libav-tools and avconv to merge video and audio from youtube videos downloaded with youtube-dl. Previously it worked just like that, but now I get error message:

Terminal
xbian@RPi2 ~/youtube $ youtube-dl --ignore-config -v -f mp4+bestaudio/best --netrc https://www.youtube.com/watch?v=R9p_BU_sagQ
[debug] System config: []
[debug] User config: []
[debug] Custom config: []
[debug] Command-line args: [u'--ignore-config', u'-v', u'-f', u'mp4+bestaudio/best', u'--netrc', u'https://www.youtube.com/watch?v=R9p_BU_sagQ']
[debug] Encodings: locale UTF-8, fs UTF-8, out UTF-8, pref UTF-8
[debug] youtube-dl version 2017.09.02
[debug] Python version 2.7.13 - Linux-4.9.48+-armv7l-with-debian-9.1
[debug] exe versions: avconv present, avprobe present, ffmpeg present, ffprobe present, rtmpdump 2.4
[debug] Proxy map: {}
[youtube] Downloading login page
[youtube] Looking up account info
[youtube] Logging in
[youtube] Checking cookie
[youtube] R9p_BU_sagQ: Downloading webpage
[youtube] R9p_BU_sagQ: Downloading video info webpage
[youtube] R9p_BU_sagQ: Extracting video information
[youtube] R9p_BU_sagQ: Downloading MPD manifest
WARNING: Requested formats are incompatible for merge and will be merged into mkv.
[debug] Invoking downloader on u'https://r2---sn-qo5-ixal.googlevideo.com/videoplayback?dur=331.232&pl=19&sparams=clen%2Cdur%2Cei%2Cgcr%2Cgir%2Cid%2Cinitcwndbps%2Cip%2Cipbits%2Citag%​2Clmt%2Cmime%2Cmm%2Cmn%2Cms%2Cmv%2Cpl%2Cratebypass%2Crequiressl%2Csource%2Cexpir​e&source=youtube&ms=au&ei=v7u5Wcn8B4mt7QTc84bQCw&id=o-APOxfqZeSgULvWAMpCTZ5JBwy-l7OGNrvna3dpPBOI9v&mv=m&itag=18&mt=1505344309&mn=sn-qo5-ixal&mm=31&signature=2C1E96CEDBBEA8B654A5ADBC063EA251051137D6.042CA393304EA4481059495BF​43251F94C0E9B6B&lmt=1505213915609548&key=yt6&ip=82.128.241.19&gir=yes&expire=1505366047&ratebypass=yes&ipbits=0&requiressl=yes&clen=27864217&gcr=fi&mime=video%2Fmp4&initcwndbps=2706250'
[download] Destination: Sossutapaaminen Loppui-R9p_BU_sagQ.f18.mp4
[download] 100% of 26.57MiB in 00:22
[debug] Invoking downloader on u'https://r2---sn-qo5-ixal.googlevideo.com/videoplayback?dur=331.181&keepalive=yes&pl=19&sparams=clen%2Cdur%2Cei%2Cgcr%2Cgir%2Cid%2Cinitcwndbps%2Cip%2Cipbits%2Citag%​2Ckeepalive%2Clmt%2Cmime%2Cmm%2Cmn%2Cms%2Cmv%2Cpl%2Crequiressl%2Csource%2Cexpire​&source=youtube&ms=au&ei=v7u5Wcn8B4mt7QTc84bQCw&id=o-APOxfqZeSgULvWAMpCTZ5JBwy-l7OGNrvna3dpPBOI9v&mv=m&itag=251&mt=1505344309&mn=sn-qo5-ixal&mm=31&signature=B14B28BFCFFCEA2B8A97E4DEF4558CAF6A9334DE.2A0177900F830C92949F3412A​CF50373143E45CC&lmt=1505215614589575&key=yt6&ip=82.128.241.19&gir=yes&expire=1505366047&ipbits=0&requiressl=yes&clen=3961610&gcr=fi&mime=audio%2Fwebm&initcwndbps=2706250&ratebypass=yes'
[download] Destination: Sossutapaaminen Loppui-R9p_BU_sagQ.f251.webm
[download] 100% of 3.78MiB in 00:03
[ffmpeg] Merging formats into "Sossutapaaminen Loppui-R9p_BU_sagQ.mkv"
[debug] ffmpeg command line: avconv -y -i 'file:Sossutapaaminen Loppui-R9p_BU_sagQ.f18.mp4' -i 'file:Sossutapaaminen Loppui-R9p_BU_sagQ.f251.webm' -c copy -map '0:v:0' -map '1:a:0' 'file:Sossutapaaminen Loppui-R9p_BU_sagQ.temp.mkv'
ERROR: avconv: error while loading shared libraries: libwayland-egl.so.1: cannot open shared object file: No such file or directory
Traceback (most recent call last):
File "/usr/local/bin/youtube-dl/youtube_dl/YoutubeDL.py", line 2004, in post_process
files_to_delete, info = pp.run(info)
File "/usr/local/bin/youtube-dl/youtube_dl/postprocessor/ffmpeg.py", line 479, in run
self.run_ffmpeg_multiple_files(info['__files_to_merge'], temp_filename, args)
File "/usr/local/bin/youtube-dl/youtube_dl/postprocessor/ffmpeg.py", line 204, in run_ffmpeg_multiple_files
raise FFmpegPostProcessorError(msg)
FFmpegPostProcessorError: avconv: error while loading shared libraries: libwayland-egl.so.1: cannot open shared object file: No such file or directory

As far as I get any insight from the error message, the problem is with a shared library libwayland-egl.so.1 that isn't installed. Quick googling gives me the idea that it might be included in the package libwayland-egl1-mesa , but trying to install it would remove some really essential xbian packages, for instance linux-image-bcm2836, xbian-package-config-xbmc, etc. Somehow I feel that's not something I should try.

Terminal
xbian@RPi2 ~/youtube $ apt-get install -s libwayland-egl1-mesa
NOTE: This is only a simulation!
apt-get needs root privileges for real execution.
Keep also in mind that locking is deactivated,
so don't depend on the relevance to the real current situation!
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages were automatically installed and are no longer required:
alsa-tools autofs cifs-utils crda exfat-fuse exfat-utils hdparm hfsplus hfsprogs hfsutils ifplugd ir-keytable iw libafpclient0 libatasmart4 libbluetooth3
libdevmapper-event1.02.1 libenca0 libgif7 libgudev-1.0-0 libhfsp0 libimobiledevice6 libiw30 liblvm2app2.2 libmariadbclient18 libmicrohttpd12 libmpeg2-4 libnfs8
libnl-3-200 libnl-genl-3-200 libntfs-3g871 libpcrecpp0v5 libpcsclite1 libsdl-image1.2 libsdl1.2debian libsgutils2-2 libsmbclient libsqlite0 libssh-4 libtag1v5
libtag1v5-vanilla libtinyxml2.6.2v5 libudisks2-0 libupower-glib3 libusbmuxd4 libvncserver1 libwebpdemux2 libyajl2 mysql-common ntfs-3g patch pv python-imaging
python-pil python-pyinotify python-sqlite sudo udisks udisks2 upower usbutils wireless-regdb wireless-tools wpasupplicant
Use 'apt autoremove' to remove them.
The following additional packages will be installed:
libegl1-mesa libgbm1 libwayland-server0 linux-image-4.9.0-3-armmp linux-image-armmp
Suggested packages:
linux-doc-4.9 debian-kernel-handbook
Recommended packages:
firmware-linux-free irqbalance
The following packages will be REMOVED:
linux-image-bcm2836 xbian-package-config-xbmc xbian-package-firmware xbian-package-vnc-server xbian-package-xbmc xbian-update
The following NEW packages will be installed:
libegl1-mesa libgbm1 libwayland-egl1-mesa libwayland-server0 linux-image-4.9.0-3-armmp linux-image-armmp
WARNING: The following essential packages will be removed.
This should NOT be done unless you know exactly what you are doing!
xbian-package-firmware xbian-update xbian-package-vnc-server (due to xbian-update)
0 upgraded, 6 newly installed, 6 to remove and 0 not upgraded.
Inst linux-image-4.9.0-3-armmp (4.9.30-2+deb9u2 Debian:9.1/stable [armhf])
Inst linux-image-armmp (4.9+80+deb9u1 Debian:9.1/stable [armhf])
Conf linux-image-4.9.0-3-armmp (4.9.30-2+deb9u2 Debian:9.1/stable [armhf])
Conf linux-image-armmp (4.9+80+deb9u1 Debian:9.1/stable [armhf])
Remv linux-image-bcm2836 [4.9.48+-1504955167]
Remv xbian-package-xbmc [17.4-1504805281]
Remv xbian-package-config-xbmc [20170913-0]
Remv xbian-update [20170628-0]
Remv xbian-package-vnc-server [2.4.3-1498497958]
Inst libwayland-server0 (1.12.0-1 Debian:9.1/stable [armhf])
Inst libgbm1 (13.0.6-1+b2 Debian:9.1/stable [armhf])
Remv xbian-package-firmware [7-1505302961] [libsdl2-2.0-0:armhf ]
Inst libwayland-egl1-mesa (13.0.6-1+b2 Debian:9.1/stable [armhf]) []
Inst libegl1-mesa (13.0.6-1+b2 Debian:9.1/stable [armhf])
Conf libwayland-server0 (1.12.0-1 Debian:9.1/stable [armhf])
Conf libgbm1 (13.0.6-1+b2 Debian:9.1/stable [armhf])
Conf libwayland-egl1-mesa (13.0.6-1+b2 Debian:9.1/stable [armhf])
Conf libegl1-mesa (13.0.6-1+b2 Debian:9.1/stable [armhf])

Does it have something to do with dependencies with xbian-package-firmware again or is the problem somewhere else?
Find all posts by this user
Quote this message in a reply
Post Reply 


Messages In This Thread
RE: Unable to install libav-tools, ffmpeg etc. on Stretch - Gyuunduh - 14th Sep, 2017 09:24 AM

Possibly Related Threads...
Thread: Author Replies Views: Last Post
  ffmpeg (stretch) (cubox-i) tempest 8 271 6th Nov, 2017 02:26 AM
Last Post: Nachteule

Forum Jump: