Thank you for your donation


Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Solved: Unable to install libav-tools, ffmpeg etc. on Stretch
13th Sep, 2017, 04:34 AM
Post: #1
Unable to install libav-tools, ffmpeg etc. on Stretch
I just updated debian/xbian to Stretch but am now missing avconv which is a part of libav-tools package. When trying to install it, apt-get tells me

Code:
xbian@RPi2 ~ $ sudo apt-get install libav-tools
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
libav-tools : Depends: ffmpeg but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

When trying to install ffmpeg the error message is a bit more precise:
Code:
sudo apt-get install ffmpeg
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
ffmpeg : Depends: libavdevice57 (>= 7:3.2.5) but it is not going to be installed
          Depends: libsdl2-2.0-0 (>= 2.0.4) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

And on and on, with libavdevice57 the end of failed installation error message being
Code:
The following information may help to resolve the situation:

The following packages have unmet dependencies:
libavdevice57 : Depends: libsdl2-2.0-0 (>= 2.0.4) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Any ideas how to fix this and get libav-tools installed?
Find all posts by this user
Quote this message in a reply
13th Sep, 2017, 06:30 AM (This post was last modified: 13th Sep, 2017 06:45 AM by Nachteule.)
Post: #2
RE: Unable to install libav-tools, ffmpeg etc. on Stretch
(13th Sep, 2017 04:34 AM)Gyuunduh Wrote:  Any ideas how to fix this and get libav-tools installed?

No, seems I do not have any issues installing ffmpeg and libav-tools

Terminal

root@kmxbimx /usr/local/sbin # LC_ALL=C apt-get install -s libav-tools
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages were automatically installed and are no longer required:
libtag1v5 libtag1v5-vanilla libtinyxml2.6.2v5
Use 'apt autoremove' to remove them.
The following additional packages will be installed:
ffmpeg libavc1394-0 libavcodec57 libavdevice57 libavfilter6 libavformat57 libavresample3 libavutil55 libbs2b0 libcairo2 libcdio-cdda1 libcdio-paranoia1 libchromaprint1
libdc1394-22 libebur128-1 libfftw3-double3 libflite1 libgme0 libgsm1 libiec61883-0 libjack-jackd2-0 libmp3lame0 libmpg123-0 libopenal-data libopenal1 libopencv-core2.4v5
libopencv-imgproc2.4v5 libopenjp2-7 libopenmpt0 libopus0 libpgm-5.2-0 libpostproc54 libraw1394-11 librubberband2 libsdl2-2.0-0 libshine3 libsnappy1v5 libsndio6.1
libsodium18 libsoxr0 libssh-gcrypt-4 libswresample2 libswscale4 libtheora0 libtwolame0 libva-drm1 libva-x11-1 libvdpau1 libvpx4 libwavpack1 libwayland-cursor0
libx264-148 libx265-95 libxcursor1 libxinerama1 libxkbcommon0 libxrandr2 libxrender1 libxss1 libxv1 libxvidcore4 libxxf86vm1 libzmq5 libzvbi-common libzvbi0
Suggested packages:
ffmpeg-doc libfftw3-bin libfftw3-dev alsa-base jackd2 libportaudio2 opus-tools libraw1394-doc sndiod
Recommended packages:
vdpau-driver-all | vdpau-driver
The following NEW packages will be installed:
ffmpeg libav-tools libavc1394-0 libavcodec57 libavdevice57 libavfilter6 libavformat57 libavresample3 libavutil55 libbs2b0 libcairo2 libcdio-cdda1 libcdio-paranoia1
libchromaprint1 libdc1394-22 libebur128-1 libfftw3-double3 libflite1 libgme0 libgsm1 libiec61883-0 libjack-jackd2-0 libmp3lame0 libmpg123-0 libopenal-data libopenal1
libopencv-core2.4v5 libopencv-imgproc2.4v5 libopenjp2-7 libopenmpt0 libopus0 libpgm-5.2-0 libpostproc54 libraw1394-11 librubberband2 libsdl2-2.0-0 libshine3 libsnappy1v5
libsndio6.1 libsodium18 libsoxr0 libssh-gcrypt-4 libswresample2 libswscale4 libtheora0 libtwolame0 libva-drm1 libva-x11-1 libvdpau1 libvpx4 libwavpack1
libwayland-cursor0 libx264-148 libx265-95 libxcursor1 libxinerama1 libxkbcommon0 libxrandr2 libxrender1 libxss1 libxv1 libxvidcore4 libxxf86vm1 libzmq5 libzvbi-common
libzvbi0
0 upgraded, 66 newly installed, 0 to remove and 9 not upgraded.
Inst libxss1 (1:1.2.2-1 Debian:9.1/stable [armhf])
Inst libva-drm1 (1.7.3-2 Debian:9.1/stable [armhf])
Inst libva-x11-1 (1.7.3-2 Debian:9.1/stable [armhf])
Inst libvdpau1 (1.1.1-6 Debian:9.1/stable [armhf])
Inst libavutil55 (7:3.2.5-1 Debian:9.1/stable [armhf])
Inst libgsm1 (1.0.13-4+b2 Debian:9.1/stable [armhf])
Inst libmp3lame0 (3.99.5+repack1-9+b2 Debian:9.1/stable [armhf])
Inst libopenjp2-7 (2.1.2-1.1 Debian:9.1/stable [armhf])
Inst libopus0 (1.2~alpha2-1 Debian:9.1/stable [armhf])
Inst libshine3 (3.1.0-5 Debian:9.1/stable [armhf])
Inst libsnappy1v5 (1.1.3-3 Debian:9.1/stable [armhf])
Inst libsoxr0 (0.1.2-2 Debian:9.1/stable [armhf])
Inst libswresample2 (7:3.2.5-1 Debian:9.1/stable [armhf])
Inst libxrender1 (1:0.9.10-1 Debian:9.1/stable [armhf])
Inst libcairo2 (1.14.8-1 Debian:9.1/stable [armhf])
Inst libtheora0 (1.1.1+dfsg.1-14+b1 Debian:9.1/stable [armhf])
Inst libtwolame0 (0.3.13-2 Debian:9.1/stable [armhf])
Inst libvpx4 (1.6.1-3 Debian:9.1/stable [armhf])
Inst libwavpack1 (5.0.0-2 Debian:9.1/stable [armhf])
Inst libx264-148 (2:0.148.2748+git97eaef2-1 Debian:9.1/stable [armhf])
Inst libx265-95 (2.1-2+b2 Debian:9.1/stable [armhf])
Inst libxvidcore4 (2:1.3.4-1+b2 Debian:9.1/stable [armhf])
Inst libzvbi-common (0.2.35-13 Debian:9.1/stable [all])
Inst libzvbi0 (0.2.35-13 Debian:9.1/stable [armhf])
Inst libavcodec57 (7:3.2.5-1 Debian:9.1/stable [armhf])
Inst libraw1394-11 (2.1.2-1+b1 Debian:9.1/stable [armhf])
Inst libavc1394-0 (0.5.4-4+b1 Debian:9.1/stable [armhf])
Inst libchromaprint1 (1.4.2-1 Debian:9.1/stable [armhf])
Inst libgme0 (0.6.0-4 Debian:9.1/stable [armhf])
Inst libmpg123-0 (1.23.8-1+b1 Debian:9.1/stable [armhf])
Inst libopenmpt0 (0.2.7386~beta20.3-3+deb9u2 Debian:9.1/stable [armhf])
Inst libssh-gcrypt-4 (0.7.3-2 Debian:9.1/stable [armhf])
Inst libavformat57 (7:3.2.5-1 Debian:9.1/stable [armhf])
Inst libavresample3 (7:3.2.5-1 Debian:9.1/stable [armhf])
Inst libbs2b0 (3.1.0+dfsg-2.2 Debian:9.1/stable [armhf])
Inst libebur128-1 (1.2.2-2 Debian:9.1/stable [armhf])
Inst libflite1 (2.0.0-release-3+b1 Debian:9.1/stable [armhf])
Inst libopencv-core2.4v5 (2.4.9.1+dfsg1-2 Debian:9.1/stable [armhf])
Inst libopencv-imgproc2.4v5 (2.4.9.1+dfsg1-2 Debian:9.1/stable [armhf])
Inst libpostproc54 (7:3.2.5-1 Debian:9.1/stable [armhf])
Inst libfftw3-double3 (3.3.5-3 Debian:9.1/stable [armhf])
Inst librubberband2 (1.8.1-7 Debian:9.1/stable [armhf])
Inst libswscale4 (7:3.2.5-1 Debian:9.1/stable [armhf])
Inst libpgm-5.2-0 (5.2.122~dfsg-2 Debian:9.1/stable [armhf])
Inst libsodium18 (1.0.11-2 Debian:9.1/stable [armhf])
Inst libzmq5 (4.2.1-4 Debian:9.1/stable [armhf])
Inst libavfilter6 (7:3.2.5-1 Debian:9.1/stable [armhf])
Inst libcdio-cdda1 (0.83-4.3+b1 Debian:9.1/stable [armhf])
Inst libcdio-paranoia1 (0.83-4.3+b1 Debian:9.1/stable [armhf])
Inst libdc1394-22 (2.2.5-1 Debian:9.1/stable [armhf])
Inst libiec61883-0 (1.2.0-2 Debian:9.1/stable [armhf])
Inst libjack-jackd2-0 (1.9.10+20150825git1ed50c92~dfsg-5 Debian:9.1/stable [armhf])
Inst libopenal-data (1:1.17.2-4 Debian:9.1/stable [all])
Inst libsndio6.1 (1.1.0-3 Debian:9.1/stable [armhf])
Inst libopenal1 (1:1.17.2-4+b2 Debian:9.1/stable [armhf])
Inst libwayland-cursor0 (1.12.0-1 Debian:9.1/stable [armhf])
Inst libxcursor1 (1:1.1.14-1+b4 Debian:9.1/stable [armhf])
Inst libxinerama1 (2:1.1.3-1+b3 Debian:9.1/stable [armhf])
Inst libxkbcommon0 (0.7.1-1 Debian:9.1/stable [armhf])
Inst libxrandr2 (2:1.5.1-1 Debian:9.1/stable [armhf])
Inst libxxf86vm1 (1:1.1.4-1+b2 Debian:9.1/stable [armhf])
Inst libsdl2-2.0-0 (2.0.5+dfsg1-2 Debian:9.1/stable [armhf])
Inst libxv1 (2:1.0.11-1 Debian:9.1/stable [armhf])
Inst libavdevice57 (7:3.2.5-1 Debian:9.1/stable [armhf])
Inst ffmpeg (7:3.2.5-1 Debian:9.1/stable [armhf])
Inst libav-tools (7:3.2.5-1 Debian:9.1/stable [all])
Conf libxss1 (1:1.2.2-1 Debian:9.1/stable [armhf])
Conf libva-drm1 (1.7.3-2 Debian:9.1/stable [armhf])
Conf libva-x11-1 (1.7.3-2 Debian:9.1/stable [armhf])
Conf libvdpau1 (1.1.1-6 Debian:9.1/stable [armhf])
Conf libavutil55 (7:3.2.5-1 Debian:9.1/stable [armhf])
Conf libgsm1 (1.0.13-4+b2 Debian:9.1/stable [armhf])
Conf libmp3lame0 (3.99.5+repack1-9+b2 Debian:9.1/stable [armhf])
Conf libopenjp2-7 (2.1.2-1.1 Debian:9.1/stable [armhf])
Conf libopus0 (1.2~alpha2-1 Debian:9.1/stable [armhf])
Conf libshine3 (3.1.0-5 Debian:9.1/stable [armhf])
Conf libsnappy1v5 (1.1.3-3 Debian:9.1/stable [armhf])
Conf libsoxr0 (0.1.2-2 Debian:9.1/stable [armhf])
Conf libswresample2 (7:3.2.5-1 Debian:9.1/stable [armhf])
Conf libxrender1 (1:0.9.10-1 Debian:9.1/stable [armhf])
Conf libcairo2 (1.14.8-1 Debian:9.1/stable [armhf])
Conf libtheora0 (1.1.1+dfsg.1-14+b1 Debian:9.1/stable [armhf])
Conf libtwolame0 (0.3.13-2 Debian:9.1/stable [armhf])
Conf libvpx4 (1.6.1-3 Debian:9.1/stable [armhf])
Conf libwavpack1 (5.0.0-2 Debian:9.1/stable [armhf])
Conf libx264-148 (2:0.148.2748+git97eaef2-1 Debian:9.1/stable [armhf])
Conf libx265-95 (2.1-2+b2 Debian:9.1/stable [armhf])
Conf libxvidcore4 (2:1.3.4-1+b2 Debian:9.1/stable [armhf])
Conf libzvbi-common (0.2.35-13 Debian:9.1/stable [all])
Conf libzvbi0 (0.2.35-13 Debian:9.1/stable [armhf])
Conf libavcodec57 (7:3.2.5-1 Debian:9.1/stable [armhf])
Conf libraw1394-11 (2.1.2-1+b1 Debian:9.1/stable [armhf])
Conf libavc1394-0 (0.5.4-4+b1 Debian:9.1/stable [armhf])
Conf libchromaprint1 (1.4.2-1 Debian:9.1/stable [armhf])
Conf libgme0 (0.6.0-4 Debian:9.1/stable [armhf])
Conf libmpg123-0 (1.23.8-1+b1 Debian:9.1/stable [armhf])
Conf libopenmpt0 (0.2.7386~beta20.3-3+deb9u2 Debian:9.1/stable [armhf])
Conf libssh-gcrypt-4 (0.7.3-2 Debian:9.1/stable [armhf])
Conf libavformat57 (7:3.2.5-1 Debian:9.1/stable [armhf])
Conf libavresample3 (7:3.2.5-1 Debian:9.1/stable [armhf])
Conf libbs2b0 (3.1.0+dfsg-2.2 Debian:9.1/stable [armhf])
Conf libebur128-1 (1.2.2-2 Debian:9.1/stable [armhf])
Conf libflite1 (2.0.0-release-3+b1 Debian:9.1/stable [armhf])
Conf libopencv-core2.4v5 (2.4.9.1+dfsg1-2 Debian:9.1/stable [armhf])
Conf libopencv-imgproc2.4v5 (2.4.9.1+dfsg1-2 Debian:9.1/stable [armhf])
Conf libpostproc54 (7:3.2.5-1 Debian:9.1/stable [armhf])
Conf libfftw3-double3 (3.3.5-3 Debian:9.1/stable [armhf])
Conf librubberband2 (1.8.1-7 Debian:9.1/stable [armhf])
Conf libswscale4 (7:3.2.5-1 Debian:9.1/stable [armhf])
Conf libpgm-5.2-0 (5.2.122~dfsg-2 Debian:9.1/stable [armhf])
Conf libsodium18 (1.0.11-2 Debian:9.1/stable [armhf])
Conf libzmq5 (4.2.1-4 Debian:9.1/stable [armhf])
Conf libavfilter6 (7:3.2.5-1 Debian:9.1/stable [armhf])
Conf libcdio-cdda1 (0.83-4.3+b1 Debian:9.1/stable [armhf])
Conf libcdio-paranoia1 (0.83-4.3+b1 Debian:9.1/stable [armhf])
Conf libdc1394-22 (2.2.5-1 Debian:9.1/stable [armhf])
Conf libiec61883-0 (1.2.0-2 Debian:9.1/stable [armhf])
Conf libjack-jackd2-0 (1.9.10+20150825git1ed50c92~dfsg-5 Debian:9.1/stable [armhf])
Conf libopenal-data (1:1.17.2-4 Debian:9.1/stable [all])
Conf libsndio6.1 (1.1.0-3 Debian:9.1/stable [armhf])
Conf libopenal1 (1:1.17.2-4+b2 Debian:9.1/stable [armhf])
Conf libwayland-cursor0 (1.12.0-1 Debian:9.1/stable [armhf])
Conf libxcursor1 (1:1.1.14-1+b4 Debian:9.1/stable [armhf])
Conf libxinerama1 (2:1.1.3-1+b3 Debian:9.1/stable [armhf])
Conf libxkbcommon0 (0.7.1-1 Debian:9.1/stable [armhf])
Conf libxrandr2 (2:1.5.1-1 Debian:9.1/stable [armhf])
Conf libxxf86vm1 (1:1.1.4-1+b2 Debian:9.1/stable [armhf])
Conf libsdl2-2.0-0 (2.0.5+dfsg1-2 Debian:9.1/stable [armhf])
Conf libxv1 (2:1.0.11-1 Debian:9.1/stable [armhf])
Conf libavdevice57 (7:3.2.5-1 Debian:9.1/stable [armhf])
Conf ffmpeg (7:3.2.5-1 Debian:9.1/stable [armhf])
Conf libav-tools (7:3.2.5-1 Debian:9.1/stable [all])
root@kmxbimx /usr/local/sbin #

You could try to remove all av packages and try again

Hmmm, above log was produced from Cubox-i/Hummingboard installation.

And you are right, installation on Rpi1/Rpi3 fails, have to investigate a bit more (I suppose dependencies of package xbian-package-firmware are culprit)
Find all posts by this user
Quote this message in a reply
13th Sep, 2017, 07:08 AM
Post: #3
RE: Unable to install libav-tools, ffmpeg etc. on Stretch
Yup

Terminal

root@kmxbibr ~ # LC_ALL=C apt-get install -s ffmpeg libavdevice57 libsdl2-2.0-0 libwayland-egl1
Reading package lists... Done
Building dependency tree
Reading state information... Done
Note, selecting 'libwayland-egl1-mesa' instead of 'libwayland-egl1'
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
libwayland-egl1-mesa : Depends: libegl1-mesa (= 13.0.6-1)
E: Unable to correct problems, you have held broken packages.
root@kmxbibr ~ # dpkg-query -s xbian-package-firmware
Package: xbian-package-firmware
Essential: yes
Status: install ok installed
Priority: optional
Section: firmware
Installed-Size: 16736
Origin: XBian
Maintainer: mkreisl <development@xbian.org>
Architecture: armhf
Version: 6-1494173043
Replaces: raspberrypi-artwork, raspberrypi-bootloader, libraspberrypi0, libraspberrypi-bin, libraspberrypi-dev, xbian-update (<= 1.0-0.4)
Provides: libraspberrypi0, libraspberrypi-dev, libegl1-mesa (= 8.0.0), libegl1-mesa-dev, libegl1-mesa-drivers, libgles2-mesa-dev, libgles2-mesa (= 8.0.0)
Conflicts: libraspberrypi0, raspberrypi-artwork, raspberrypi-bootloader, libraspberrypi0, libraspberrypi-bin, libraspberrypi-dev, xbian-package-firmware-6q, libegl1-mesa, libegl1-mesa-dev, libegl1-mesa-drivers, libgles2-mesa-dev, libgles2-mesa
Description: RPI firmware (RPI2 compatible)
(at commit src f924320b83f29ee3110876f51929279d9a5b800a, commit xbian repo 2abfaccd1d1c5fc7441a78e6beb3602724a23dff)
root@kmxbibr ~ #

xbian-package-firmware provides libegl1-mesa (= 8.0.0), but required is version libegl1-mesa (= 13.0.6-1)

Ok, that's it. Will build xbian-package-firmware tomorrow Smile
Find all posts by this user
Quote this message in a reply
14th Sep, 2017, 02:14 AM
Post: #4
RE: Unable to install libav-tools, ffmpeg etc. on Stretch
@Gyuunduh

New xbian-package-firmware available.

Please update this package and after that installing ffmpeg shouldn't complain anything Smile
Find all posts by this user
Quote this message in a reply
14th Sep, 2017, 09:24 AM
Post: #5
RE: Unable to install libav-tools, ffmpeg etc. on Stretch
(14th Sep, 2017 02:14 AM)Nachteule Wrote:  @Gyuunduh

New xbian-package-firmware available.

Please update this package and after that installing ffmpeg shouldn't complain anything Smile

Thanks @Nachteule , ffmpeg and libav-tools can now be installed.

But now I'm running into an issue I didn't have before the debian upgrade. I need libav-tools and avconv to merge video and audio from youtube videos downloaded with youtube-dl. Previously it worked just like that, but now I get error message:

Terminal
xbian@RPi2 ~/youtube $ youtube-dl --ignore-config -v -f mp4+bestaudio/best --netrc https://www.youtube.com/watch?v=R9p_BU_sagQ
[debug] System config: []
[debug] User config: []
[debug] Custom config: []
[debug] Command-line args: [u'--ignore-config', u'-v', u'-f', u'mp4+bestaudio/best', u'--netrc', u'https://www.youtube.com/watch?v=R9p_BU_sagQ']
[debug] Encodings: locale UTF-8, fs UTF-8, out UTF-8, pref UTF-8
[debug] youtube-dl version 2017.09.02
[debug] Python version 2.7.13 - Linux-4.9.48+-armv7l-with-debian-9.1
[debug] exe versions: avconv present, avprobe present, ffmpeg present, ffprobe present, rtmpdump 2.4
[debug] Proxy map: {}
[youtube] Downloading login page
[youtube] Looking up account info
[youtube] Logging in
[youtube] Checking cookie
[youtube] R9p_BU_sagQ: Downloading webpage
[youtube] R9p_BU_sagQ: Downloading video info webpage
[youtube] R9p_BU_sagQ: Extracting video information
[youtube] R9p_BU_sagQ: Downloading MPD manifest
WARNING: Requested formats are incompatible for merge and will be merged into mkv.
[debug] Invoking downloader on u'https://r2---sn-qo5-ixal.googlevideo.com/videoplayback?dur=331.232&pl=19&sparams=clen%2Cdur%2Cei%2Cgcr%2Cgir%2Cid%2Cinitcwndbps%2Cip%2Cipbits%2Citag%​2Clmt%2Cmime%2Cmm%2Cmn%2Cms%2Cmv%2Cpl%2Cratebypass%2Crequiressl%2Csource%2Cexpir​e&source=youtube&ms=au&ei=v7u5Wcn8B4mt7QTc84bQCw&id=o-APOxfqZeSgULvWAMpCTZ5JBwy-l7OGNrvna3dpPBOI9v&mv=m&itag=18&mt=1505344309&mn=sn-qo5-ixal&mm=31&signature=2C1E96CEDBBEA8B654A5ADBC063EA251051137D6.042CA393304EA4481059495BF​43251F94C0E9B6B&lmt=1505213915609548&key=yt6&ip=82.128.241.19&gir=yes&expire=1505366047&ratebypass=yes&ipbits=0&requiressl=yes&clen=27864217&gcr=fi&mime=video%2Fmp4&initcwndbps=2706250'
[download] Destination: Sossutapaaminen Loppui-R9p_BU_sagQ.f18.mp4
[download] 100% of 26.57MiB in 00:22
[debug] Invoking downloader on u'https://r2---sn-qo5-ixal.googlevideo.com/videoplayback?dur=331.181&keepalive=yes&pl=19&sparams=clen%2Cdur%2Cei%2Cgcr%2Cgir%2Cid%2Cinitcwndbps%2Cip%2Cipbits%2Citag%​2Ckeepalive%2Clmt%2Cmime%2Cmm%2Cmn%2Cms%2Cmv%2Cpl%2Crequiressl%2Csource%2Cexpire​&source=youtube&ms=au&ei=v7u5Wcn8B4mt7QTc84bQCw&id=o-APOxfqZeSgULvWAMpCTZ5JBwy-l7OGNrvna3dpPBOI9v&mv=m&itag=251&mt=1505344309&mn=sn-qo5-ixal&mm=31&signature=B14B28BFCFFCEA2B8A97E4DEF4558CAF6A9334DE.2A0177900F830C92949F3412A​CF50373143E45CC&lmt=1505215614589575&key=yt6&ip=82.128.241.19&gir=yes&expire=1505366047&ipbits=0&requiressl=yes&clen=3961610&gcr=fi&mime=audio%2Fwebm&initcwndbps=2706250&ratebypass=yes'
[download] Destination: Sossutapaaminen Loppui-R9p_BU_sagQ.f251.webm
[download] 100% of 3.78MiB in 00:03
[ffmpeg] Merging formats into "Sossutapaaminen Loppui-R9p_BU_sagQ.mkv"
[debug] ffmpeg command line: avconv -y -i 'file:Sossutapaaminen Loppui-R9p_BU_sagQ.f18.mp4' -i 'file:Sossutapaaminen Loppui-R9p_BU_sagQ.f251.webm' -c copy -map '0:v:0' -map '1:a:0' 'file:Sossutapaaminen Loppui-R9p_BU_sagQ.temp.mkv'
ERROR: avconv: error while loading shared libraries: libwayland-egl.so.1: cannot open shared object file: No such file or directory
Traceback (most recent call last):
File "/usr/local/bin/youtube-dl/youtube_dl/YoutubeDL.py", line 2004, in post_process
files_to_delete, info = pp.run(info)
File "/usr/local/bin/youtube-dl/youtube_dl/postprocessor/ffmpeg.py", line 479, in run
self.run_ffmpeg_multiple_files(info['__files_to_merge'], temp_filename, args)
File "/usr/local/bin/youtube-dl/youtube_dl/postprocessor/ffmpeg.py", line 204, in run_ffmpeg_multiple_files
raise FFmpegPostProcessorError(msg)
FFmpegPostProcessorError: avconv: error while loading shared libraries: libwayland-egl.so.1: cannot open shared object file: No such file or directory

As far as I get any insight from the error message, the problem is with a shared library libwayland-egl.so.1 that isn't installed. Quick googling gives me the idea that it might be included in the package libwayland-egl1-mesa , but trying to install it would remove some really essential xbian packages, for instance linux-image-bcm2836, xbian-package-config-xbmc, etc. Somehow I feel that's not something I should try.

Terminal
xbian@RPi2 ~/youtube $ apt-get install -s libwayland-egl1-mesa
NOTE: This is only a simulation!
apt-get needs root privileges for real execution.
Keep also in mind that locking is deactivated,
so don't depend on the relevance to the real current situation!
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages were automatically installed and are no longer required:
alsa-tools autofs cifs-utils crda exfat-fuse exfat-utils hdparm hfsplus hfsprogs hfsutils ifplugd ir-keytable iw libafpclient0 libatasmart4 libbluetooth3
libdevmapper-event1.02.1 libenca0 libgif7 libgudev-1.0-0 libhfsp0 libimobiledevice6 libiw30 liblvm2app2.2 libmariadbclient18 libmicrohttpd12 libmpeg2-4 libnfs8
libnl-3-200 libnl-genl-3-200 libntfs-3g871 libpcrecpp0v5 libpcsclite1 libsdl-image1.2 libsdl1.2debian libsgutils2-2 libsmbclient libsqlite0 libssh-4 libtag1v5
libtag1v5-vanilla libtinyxml2.6.2v5 libudisks2-0 libupower-glib3 libusbmuxd4 libvncserver1 libwebpdemux2 libyajl2 mysql-common ntfs-3g patch pv python-imaging
python-pil python-pyinotify python-sqlite sudo udisks udisks2 upower usbutils wireless-regdb wireless-tools wpasupplicant
Use 'apt autoremove' to remove them.
The following additional packages will be installed:
libegl1-mesa libgbm1 libwayland-server0 linux-image-4.9.0-3-armmp linux-image-armmp
Suggested packages:
linux-doc-4.9 debian-kernel-handbook
Recommended packages:
firmware-linux-free irqbalance
The following packages will be REMOVED:
linux-image-bcm2836 xbian-package-config-xbmc xbian-package-firmware xbian-package-vnc-server xbian-package-xbmc xbian-update
The following NEW packages will be installed:
libegl1-mesa libgbm1 libwayland-egl1-mesa libwayland-server0 linux-image-4.9.0-3-armmp linux-image-armmp
WARNING: The following essential packages will be removed.
This should NOT be done unless you know exactly what you are doing!
xbian-package-firmware xbian-update xbian-package-vnc-server (due to xbian-update)
0 upgraded, 6 newly installed, 6 to remove and 0 not upgraded.
Inst linux-image-4.9.0-3-armmp (4.9.30-2+deb9u2 Debian:9.1/stable [armhf])
Inst linux-image-armmp (4.9+80+deb9u1 Debian:9.1/stable [armhf])
Conf linux-image-4.9.0-3-armmp (4.9.30-2+deb9u2 Debian:9.1/stable [armhf])
Conf linux-image-armmp (4.9+80+deb9u1 Debian:9.1/stable [armhf])
Remv linux-image-bcm2836 [4.9.48+-1504955167]
Remv xbian-package-xbmc [17.4-1504805281]
Remv xbian-package-config-xbmc [20170913-0]
Remv xbian-update [20170628-0]
Remv xbian-package-vnc-server [2.4.3-1498497958]
Inst libwayland-server0 (1.12.0-1 Debian:9.1/stable [armhf])
Inst libgbm1 (13.0.6-1+b2 Debian:9.1/stable [armhf])
Remv xbian-package-firmware [7-1505302961] [libsdl2-2.0-0:armhf ]
Inst libwayland-egl1-mesa (13.0.6-1+b2 Debian:9.1/stable [armhf]) []
Inst libegl1-mesa (13.0.6-1+b2 Debian:9.1/stable [armhf])
Conf libwayland-server0 (1.12.0-1 Debian:9.1/stable [armhf])
Conf libgbm1 (13.0.6-1+b2 Debian:9.1/stable [armhf])
Conf libwayland-egl1-mesa (13.0.6-1+b2 Debian:9.1/stable [armhf])
Conf libegl1-mesa (13.0.6-1+b2 Debian:9.1/stable [armhf])

Does it have something to do with dependencies with xbian-package-firmware again or is the problem somewhere else?
Find all posts by this user
Quote this message in a reply
14th Sep, 2017, 09:47 PM
Post: #6
RE: Unable to install libav-tools, ffmpeg etc. on Stretch
(14th Sep, 2017 09:24 AM)Gyuunduh Wrote:  Does it have something to do with dependencies with xbian-package-firmware again or is the problem somewhere else?

WTF Angry Yes, indeed, it has

Never expected that ffmpeg requires that library Dodgy

So, back to the drawing board ...
Find all posts by this user
Quote this message in a reply
15th Sep, 2017, 04:51 AM
Post: #7
RE: Unable to install libav-tools, ffmpeg etc. on Stretch
@Gyuunduh

Could ypu please download and install new firmware and try again?

I removed all mesa and egl stuff from control file for testing

Kodi of my RPi3 is still playing vids after installing this firmware and ffmpeg Smile
Find all posts by this user
Quote this message in a reply
15th Sep, 2017, 06:06 AM
Post: #8
RE: Unable to install libav-tools, ffmpeg etc. on Stretch
(15th Sep, 2017 04:51 AM)Nachteule Wrote:  @Gyuunduh

Could ypu please download and install new firmware and try again?

I removed all mesa and egl stuff from control file for testing

Kodi of my RPi3 is still playing vids after installing this firmware and ffmpeg Smile

Video playback seems to be working, and also downloading videos with youtube-dl and merging different audio formats into .mkv with ffmpeg/avconv.

There is an extremely minor cosmetic problem, youtube-dl gives a warning about avconv being outdated, but it's working anyway, so it's not a problem to me.

Terminal
xbian@RPi2 ~/temp $ youtube-dl --ignore-config -v -f mp4+bestaudio/best --netrc https://www.youtube.com/watch?v=R9p_BU_sagQ
[debug] System config: []
[debug] User config: []
[debug] Custom config: []
[debug] Command-line args: [u'--ignore-config', u'-v', u'-f', u'mp4+bestaudio/best', u'--netrc', u'https://www.youtube.com/watch?v=R9p_BU_sagQ']
[debug] Encodings: locale UTF-8, fs UTF-8, out UTF-8, pref UTF-8
[debug] youtube-dl version 2017.09.02
[debug] Python version 2.7.13 - Linux-4.9.48+-armv7l-with-debian-9.1
[debug] exe versions: avconv 3.2.5-1, avprobe 3.2.5-1, ffmpeg 3.2.5-1, ffprobe 3.2.5-1, rtmpdump 2.4
[debug] Proxy map: {}
[youtube] Downloading login page
[youtube] Looking up account info
[youtube] Logging in
[youtube] Checking cookie
[youtube] R9p_BU_sagQ: Downloading webpage
[youtube] R9p_BU_sagQ: Downloading video info webpage
[youtube] R9p_BU_sagQ: Extracting video information
[youtube] R9p_BU_sagQ: Downloading MPD manifest
WARNING: Requested formats are incompatible for merge and will be merged into mkv.
[debug] Invoking downloader on u'https://r2---sn-qo5-ixal.googlevideo.com/videoplayback?expire=1505441030&dur=331.232&gir=yes&ei=puC6WeIboa3sBPL3oeAM&initcwndbps=2053750&ip=82.128.241.19&requiressl=yes&ms=au&mt=1505419343&mv=m&id=o-AK8GP7w2IEGPJxSS93G0TIzNEavSYudZPzNae9UZSC7s&mime=video%2Fmp4&pl=19&mm=31&mn=sn-qo5-ixal&ipbits=0&gcr=fi&itag=18&key=yt6&lmt=1505213915609548&ratebypass=yes&signature=9D54C1F4DFB9E741A9A2661DB85C3F27F06FFB46.C5CAB0BD9942B190A27E4F472​A1B1CBD667A13AC&clen=27864217&source=youtube&sparams=clen%2Cdur%2Cei%2Cgcr%2Cgir%2Cid%2Cinitcwndbps%2Cip%2Cipbits%2Citag%​2Clmt%2Cmime%2Cmm%2Cmn%2Cms%2Cmv%2Cpl%2Cratebypass%2Crequiressl%2Csource%2Cexpir​e'
[download] Destination: Sossutapaaminen Loppui-R9p_BU_sagQ.f18.mp4
[download] 100% of 26.57MiB in 00:23
[debug] Invoking downloader on u'https://r2---sn-qo5-ixal.googlevideo.com/videoplayback?expire=1505441030&dur=331.181&gir=yes&ei=puC6WeIboa3sBPL3oeAM&initcwndbps=2053750&ip=82.128.241.19&requiressl=yes&ms=au&mt=1505419343&mv=m&id=o-AK8GP7w2IEGPJxSS93G0TIzNEavSYudZPzNae9UZSC7s&mime=audio%2Fwebm&pl=19&mm=31&mn=sn-qo5-ixal&ipbits=0&gcr=fi&keepalive=yes&itag=251&key=yt6&lmt=1505215614589575&signature=6357A06EAADFFFE78C6175315509A2F74123E1F0.4DE2C9BB677ADB910041709ED​79D0B34EC733AA7&clen=3961610&source=youtube&sparams=clen%2Cdur%2Cei%2Cgcr%2Cgir%2Cid%2Cinitcwndbps%2Cip%2Cipbits%2Citag%​2Ckeepalive%2Clmt%2Cmime%2Cmm%2Cmn%2Cms%2Cmv%2Cpl%2Crequiressl%2Csource%2Cexpire​&ratebypass=yes'
[download] Destination: Sossutapaaminen Loppui-R9p_BU_sagQ.f251.webm
[download] 100% of 3.78MiB in 00:03
[ffmpeg] Merging formats into "Sossutapaaminen Loppui-R9p_BU_sagQ.mkv"
WARNING: Your copy of avconv is outdated, update avconv to version 10-0 or newer if you encounter any errors.
[debug] ffmpeg command line: avconv -y -i 'file:Sossutapaaminen Loppui-R9p_BU_sagQ.f18.mp4' -i 'file:Sossutapaaminen Loppui-R9p_BU_sagQ.f251.webm' -c copy -map '0:v:0' -map '1:a:0' 'file:Sossutapaaminen Loppui-R9p_BU_sagQ.temp.mkv'
Deleting original file Sossutapaaminen Loppui-R9p_BU_sagQ.f18.mp4 (pass -k to keep)
Deleting original file Sossutapaaminen Loppui-R9p_BU_sagQ.f251.webm (pass -k to keep)

Cheers and thank you for your help!
Find all posts by this user
Quote this message in a reply
15th Sep, 2017, 06:47 AM (This post was last modified: 15th Sep, 2017 06:48 AM by Nachteule.)
Post: #9
RE: Unable to install libav-tools, ffmpeg etc. on Stretch
(15th Sep, 2017 06:06 AM)Gyuunduh Wrote:  Video playback seems to be working, and also downloading videos with youtube-dl and merging different audio formats into .mkv with ffmpeg/avconv.

Good news Smile

Quote:There is an extremely minor cosmetic problem, youtube-dl gives a warning about avconv being outdated, but it's working anyway, so it's not a problem to me.

This has to be done inside youtube-dl (seems that prog still does not know that Debian Stretch has been moved back from avtools to ffmpeg - all av.... binaries are symlinked to ff... binaries for backwards compatibilty)
Find all posts by this user
Quote this message in a reply
4th Nov, 2017, 05:59 AM
Post: #10
RE: Unable to install libav-tools, ffmpeg etc. on Stretch
I am suffering this same problem, but I am using the cubox-i. Is there a way to satisfy this using the firmware-imx package instead of the xbian-package-firmware?

edit: Forgive me, I didn't notice that this was marked as "solved". I will open a new thread for this related issue. I will also try not to post with a 3 year old climbing on me.
Find all posts by this user
Quote this message in a reply
Post Reply 


Possibly Related Threads...
Thread: Author Replies Views: Last Post
  ffmpeg (stretch) (cubox-i) tempest 8 254 6th Nov, 2017 02:26 AM
Last Post: Nachteule

Forum Jump: