Thank you for your donation


Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Beta2 [UPGRADE INSTRUCTIONS ONLY!]
17th Nov, 2013, 08:22 AM
Post: #16
RE: Beta2 [UPGRADE INSTRUCTIONS ONLY!]
(17th Nov, 2013 06:32 AM)mk01 Wrote:  for sure it is not corrupted.

just initramfs was installed without appropriate kernel package (installation interrupted).

you should be able to boot if you replace files in /boot with files inside this archive http://xbian.brantje.com/others/boot.xbian.zip .

Read Your post to late Tongue

I did update from clean install alpha5 and upgrade with no problem
Find all posts by this user
Quote this message in a reply
17th Nov, 2013, 08:24 AM
Post: #17
RE: Beta2 [UPGRADE INSTRUCTIONS ONLY!]
@mk01:
no analog signal at all, blank screen...my rpi is connected via scart to an old crt tv set...
Find all posts by this user
Quote this message in a reply
17th Nov, 2013, 08:47 AM
Post: #18
RE: Beta2 [UPGRADE INSTRUCTIONS ONLY!]
@PicatriX,

you can overwrite also firmware files in the /boot (http://xbian.brantje.com/others/boot.firmware.zip) and check, if /boot/config.txt has at least those lines:
Code:
initramfs initramfs.gz  0x00a00000
arm_freq=840
core_freq=275
gpu_mem_256=128
gpu_mem_512=128

black screen means kernel can't be loaded (when kernel starts loading, you see blinking cursor in upper left corner). but you used my kernel with no help. so last resort are damaged fw files. if boot shows no error and you rewrite the files you must get something on the screen.

Please read rules and do a search before you post! . FAQs . How to post log file? . Looking for answers? Please start here
Find all posts by this user
Quote this message in a reply
17th Nov, 2013, 06:09 PM
Post: #19
RE: Beta2 [UPGRADE INSTRUCTIONS ONLY!]
@mk01:
thanks for your advices...finally got beta 2 to boot to xbmc, but:
- no clock / date sync;
- no ssh connection possible (connection refused on port 22);
- system at first is controllable using Yatse;
- after few minutes or if you try looking at weather or at xbian config under system setup my installation breaks out of xbmc to the classical shell/login screen with a lot of:
modem-manager[pid]: <info> Loaded plugin Gobi...Nokia...Samsung...Huawei...Linktop...
I will try another restore to beta 1.2 and upgrade to beta 2 in order to eventually repeat this condition, maybe it could be helpful to other users...

Edit: same result after retry... :-(
Find all posts by this user
Quote this message in a reply
18th Nov, 2013, 03:44 AM
Post: #20
RE: Beta2 [UPGRADE INSTRUCTIONS ONLY!]
upgrading from alpha1, when doing
root@xbian:/home/xbian# apt-get install libc-bin libc-dev-bin libc6 libc6-dev xbian-package-cec xbian-package-config-shell xbian-package-config-xbmc xbian-package-lirc xbian-package-xbmc xbian-update

after typing "Yes, do as I say!", I get this:

http://pastebin.com/cj0uHdTF

i've got full backup of my sd card from before this upgrade.
any sugestions?


[mod]
Please use pastebin for long logs.
[mod]

i did this to solve this first problem, but now i get this:

Code:
updating to 1.0 Beta 2
mount: /dev/mmcblk0p2 already mounted or /tmp/btrfs-snap busy
mount: according to mtab, /dev/mmcblk0p2 is mounted on /
Error: unable to mount the filesystem
moving modules directory
mount: /dev/mmcblk0p2 already mounted or /tmp/tmp.qVZhbjSd3o busy
mount: according to mtab, /dev/mmcblk0p2 is mounted on /
umount: /tmp/tmp.qVZhbjSd3o: not mounted
mount: /dev/mmcblk0p2 already mounted or /lib/modules busy
mount: according to mtab, /dev/mmcblk0p2 is mounted on /
something wrong happened, your xbian may not boot successfully after restart. disabling restart after update finish
updating services

after reboot, there's no sign of live on my pi again..
Find all posts by this user
Quote this message in a reply
19th Nov, 2013, 05:38 AM
Post: #21
RE: Beta2 [UPGRADE INSTRUCTIONS ONLY!]
i have updated from beta 1 hotfix 1.1 with the following commands:
sudo -i
apt-get clean; apt-get update; apt-get upgrade
apt-get install xbian-package-xbmc

everything wnt good, got an automatic reboot.
but now xbmc does not start, is it possible to fix this?

The following services with auto start are not starten:
gssd
idmapd
statd
xbian-xbmc-bridge
xbmc
Find all posts by this user
Quote this message in a reply
20th Nov, 2013, 12:18 AM
Post: #22
RE: Beta2 [UPGRADE INSTRUCTIONS ONLY!]
Find all posts by this user
Quote this message in a reply
20th Nov, 2013, 05:23 AM
Post: #23
Re: RE: Beta2 [UPGRADE INSTRUCTIONS ONLY!]

Please read rules and do a search before you post! | FAQs | How to post log file? | Can't find an answer? Contact us.
Visit this user's website Find all posts by this user
Quote this message in a reply
20th Nov, 2013, 05:46 AM
Post: #24
RE: Beta2 [UPGRADE INSTRUCTIONS ONLY!]
Actually, I am not sudo-ing since I have the root login enabled. But yes, of course I am updating the sources.

[
sources.list:
deb http://mirrordirector.raspbian.org/raspbian/ wheezy main contrib non-free rpi
deb mirror://apt.xbian.org/mirror.txt wheezy main
]
Find all posts by this user
Quote this message in a reply
20th Nov, 2013, 05:55 AM
Post: #25
Re: RE: Beta2 [UPGRADE INSTRUCTIONS ONLY!]
Have you tried:

(20th Nov, 2013 05:46 AM)Freddie299 Wrote:  Actually, I am not sudo-ing since I have the root login enabled. But yes, of course I am updating the sources.

[
sources.list:
deb http://mirrordirector.raspbian.org/raspbian/ wheezy main contrib non-free rpi
deb mirror://apt.xbian.org/mirror.txt wheezy main
]

(16th Nov, 2013 07:31 AM)CurlyMo Wrote:  What is miss in the instructions is that people should change:
Code:
deb http://xbian.brantje.com/ wheezy main
into
Code:
deb http://xbian.brantje.com/ stable main

Please read rules and do a search before you post! | FAQs | How to post log file? | Can't find an answer? Contact us.
Visit this user's website Find all posts by this user
Quote this message in a reply
20th Nov, 2013, 06:04 AM
Post: #26
RE: Beta2 [UPGRADE INSTRUCTIONS ONLY!]
Well, I only tried to switch to stable on the sources I had, which apparently didnt work.

Anyway, with "brantje" I got the next problem: Now I am having a lot unresolved dependencies. The hint with manually selecting all the kept-back packages doest work, as I am missing ir-keytable, lsof, update-notifier-common and more stuff which I nave came across ...

[Edit: Now seems to work after a reboot. Maybe a memory issue. Consider it solved for now. Thanks!]

Thanks a lot for both your work and patience!
Find all posts by this user
Quote this message in a reply
21st Nov, 2013, 02:31 AM
Post: #27
RE: Beta2 [UPGRADE INSTRUCTIONS ONLY!]
@TheMystery

(19th Nov, 2013 05:38 AM)TheMystery Wrote:  The following services with auto start are not starten:
gssd
idmapd
statd
xbian-xbmc-bridge
xbmc

gssd/idmapd/statd will be auto-started if nfs2/3 (statd) or nfs4 (idmapd, gssd) is automounted through /etc/fstab or it's start is requested through /etc/default/nfs-common

xbian-xbmc-bridge will start only if xbmc is successfully started. can you provide versions of installed packages with:
Code:
sudo dpkg-query -W 'xbian*'

Please read rules and do a search before you post! . FAQs . How to post log file? . Looking for answers? Please start here
Find all posts by this user
Quote this message in a reply
21st Nov, 2013, 02:37 AM
Post: #28
RE: Beta2 [UPGRADE INSTRUCTIONS ONLY!]
Hi,

apt-get clean;apt-get update work, but

root@rpi:~# apt-get upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies:
xbian-package-kernel : Depends: xbian-package-initramfs-tools (>= 1.0-2.3) but 1.0-0.8 is installed
xbian-package-splash : Depends: xbian-package-initramfs-tools (>= 1.0-1) but 1.0-0.8 is installed
E: Unmet dependencies. Try using -f.

and

root@rpi:~# apt-get install xbian-update
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
xbian-package-kernel : Depends: xbian-package-initramfs-tools (>= 1.0-2.3) but 1.0-0.8 is to be installed
xbian-package-splash : Depends: xbian-package-initramfs-tools (>= 1.0-1) but 1.0-0.8 is to be installed
xbian-update : Depends: ir-keytable but it is not going to be installed
Depends: xbian-package-samba but it is not going to be installed
Depends: lsof but it is not going to be installed
Depends: update-notifier-common but it is not going to be installed
Depends: xbian-package-zram-swap (>= 1.0-3.6) but 1.0-3.1 is to be installed
Depends: xbian-package-upstart-xbmc-bridge but it is not going to be installed
Depends: unattended-upgrades but it is not going to be installed
Conflicts: udhcpc but 1:1.20.0-7 is to be installed
Breaks: xbian-package-config-shell (< 2.1.6-48b) but 2.1.3-3 is to be installed
Breaks: xbian-package-config-xbmc (< 1.1.4-1) but 1.1-2 is to be installed
Breaks: xbian-package-initramfs-tools (< 1.3.1-2) but 1.0-0.8 is to be installed
Breaks: xbian-package-usbmount (< 1.0.4-7) but 1.0-0.6 is to be installed
Breaks: xbian-package-zram-swap (< 1.0-4.3) but 1.0-3.1 is to be installed
Breaks: xbian-package-xbmc (< 2.9-10.13)
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

Any help?

Regards.
Find all posts by this user
Quote this message in a reply
21st Nov, 2013, 03:31 AM
Post: #29
RE: Beta2 [UPGRADE INSTRUCTIONS ONLY!]
***********************
***** EVERYONE *****
***********************

Please keep this thread on track with Problems with the UPGRADE INSTRUCTIONS and not problems with Beta 2.
Problems = Beta 2 Problems
Bugs = Bugs Prefixed with [Beta 2]
Find all posts by this user
Quote this message in a reply
21st Nov, 2013, 03:54 AM
Post: #30
RE: Beta2 [UPGRADE INSTRUCTIONS ONLY!]
(21st Nov, 2013 03:31 AM)IriDium Wrote:  ***********************
***** EVERYONE *****
***********************

Please keep this thread on track with Problems with the UPGRADE INSTRUCTIONS and not problems with Beta 2.
Problems = Beta 2 Problems
Bugs = Bugs Prefixed with [Beta 2]

As you can see, this is an upgrade problem.
Why you think it isn't?

There are errors during apt-get upgrade.

Regards.
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump: