Thank you for your donation


Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Beta2 [UPGRADE INSTRUCTIONS ONLY!]
19th Apr, 2014, 12:32 AM
Post: #76
RE: Beta2 [UPGRADE INSTRUCTIONS ONLY!]
(16th Apr, 2014 02:41 PM)mk01 Wrote:  don't replace the package names. always ADD those still 'missing' to one cmd line so it will grow. until you satisfy apt-get's need.
I don't understand.
Maybe I didn't explain myself correctly.
It says I miss a couple of packages.
I tried to add the first one with the cmd line, but then for that one it says I'm missing something else. When I try to add that one else, it says I'm missing the first one I tried to add.

I'll try to copy/paste the errors when I get home.
Find all posts by this user
Quote this message in a reply
19th Apr, 2014, 03:47 AM
Post: #77
RE: Beta2 [UPGRADE INSTRUCTIONS ONLY!]
Ok, so, fresh restart from alpha 5.

I edited my sources.list, as said by Coolopke with
Terminal
deb http://xbian.brantje.com wheezy main
deb http://mirrordirector.raspbian.org/raspbian/ wheezy main contrib non-free $
deb mirror://apt.xbian.org/mirror.txt wheezy main

Then, I got :
Terminal
Setting up triggerhappy (0.3.4-2) ...
initctl: Unable to connect to Upstart: Failed to connect to socket /com/ubuntu/upstart: Connection refused
Selecting previously unselected package xbian-package-kernel.
(Reading database ... 31502 files and directories currently installed.)
Unpacking xbian-package-kernel (from .../xbian-package-kernel_1.3-6.10_armhf.deb) ...
dpkg: error processing /var/cache/apt/archives/xbian-package-kernel_1.3-6.10_armhf.deb (--unpack):
trying to overwrite '/lib/firmware/carl9170-1.fw', which is also in package xbian-update 1.0-0.5
Selecting previously unselected package xbian-package-initramfs-tools.
Unpacking xbian-package-initramfs-tools (from .../xbian-package-initramfs-tools_1.3.3-4b_armhf.deb) ...
Selecting previously unselected package dialog.
Unpacking dialog (from .../dialog_1.1-20120215-2_armhf.deb) ...
Processing triggers for man-db ...
Errors were encountered while processing:
/var/cache/apt/archives/xbian-package-kernel_1.3-6.10_armhf.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

So again, I used the cmd by Coolopke :
Terminal
sudo apt-get install -f xbian-update=1.0.2-8d xbian-package-config-shell=2.1.6-51a xbian-package-initramfs-tools=1.3.1-5b xbian-package-xbmc-scripts libhal-storage1 libhal1

which gives me :
Terminal
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
btrfs-tools : Breaks: xbian-package-config-shell (< 2.1.6-53a) but 2.1.6-51a is to be installed
xbian-package-config-shell : Depends: apt-show-versions but it is not going to be installed
xbian-package-config-xbmc : Depends: xbian-package-config-shell (>= 2.1.6-53) but 2.1.6-51a is to be installed
xbian-package-initramfs-tools : Depends: busybox but it is not going to be installed
xbian-package-xbmc-scripts : Breaks: xbian-package-xbmc (< 2.9-10.9)
xbian-update : Depends: xbian-package-kernel but it is not going to be installed
Depends: unattended-upgrades but it is not going to be installed
Breaks: xbian-package-lirc (< 1.4-8.8) but 1.3 is to be installed
Breaks: xbian-package-xbmc (< 2.9-10.9)
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

Which package am I supposed to install then?
Find all posts by this user
Quote this message in a reply
19th Apr, 2014, 06:14 AM
Post: #78
RE: Beta2 [UPGRADE INSTRUCTIONS ONLY!]
Don't use versions. These you listed are now also obsolete. Looking at outputs, try this:

Code:
sudo apt-get install xbian-update xbian-package-config-shell xbian-package-initramfs-tools xbian-package-xbmc-scripts libhal-storage1 libhal1 xbian-package-config-xbmc xbian-package-kernel xbian-package-lirc xbian-package-xbmc

what I meant before you see in this commands. if apt-get complains again about some other packages (or version), just don't try to install it separately before, but add them to command I posted above.

for the error on updating kernel (that it wants to overwrite file belonging to another package) remove the file listed from
Code:
/var/lib/dpkg/info/xbian-update.list

Please read rules and do a search before you post! . FAQs . How to post log file? . Looking for answers? Please start here
Find all posts by this user
Quote this message in a reply
19th Apr, 2014, 06:45 AM
Post: #79
RE: Beta2 [UPGRADE INSTRUCTIONS ONLY!]
apt-get didn't complain before the messages I pasted.
If I try the
Terminal
sudo apt-get install xbian-update xbian-package-config-shell xbian-package-initramfs-tools xbian-package-xbmc-scripts libhal-storage1 libhal1 xbian-package-config-xbmc xbian-package-kernel xbian-package-lirc xbian-package-xbmc

I get this :
Terminal
Reading package lists... Done
Building dependency tree
Reading state information... Done
xbian-package-config-shell is already the newest version.
xbian-package-config-xbmc is already the newest version.
xbian-package-initramfs-tools is already the newest version.
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
xbian-package-xbmc : Depends: xbian-package-shairplay but it is not going to be installed
Depends: xbian-package-libtag (>= 1.0-2) but it is not going to be installed
Depends: xbian-package-libshairport (>= 1.0-1) but it is not going to be installed
Depends: xbian-package-cec (>= 1.0) but it is not going to be installed
Depends: libmad0 but it is not going to be installed
xbian-update : Depends: unattended-upgrades but it is not going to be installed
Depends: xbian-package-vnc-server (>= 1.0.0-2) but it is not going to be installed
Depends: xbian-package-cec (>= 1.1-0.3) but it is not going to be installed or
xbian-package-cec-6q but it is not installable
PreDepends: autofs but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

About the other thing, I have to -rm -r all the files listed in the xbian-update.list?

I'm very sorry if I seem stupdi, I'm a newbie with Linux, I vaguely understand the things I do, but have almost zero experience..
Thanks !
Find all posts by this user
Quote this message in a reply
19th Apr, 2014, 06:53 AM
Post: #80
RE: Beta2 [UPGRADE INSTRUCTIONS ONLY!]
@anagram

no all files, just those listed as "conflicting". in the case you posted it was "/lib/firmware/carl9170-1.fw" (and I suppose this will be just this one file). so open /var/lib/dpkg/info/xbian-update.list and remove just the one line containing /lib/firmware/carl9170-1.fw.

regarding the apt-get update run, just do as I told you. the new listed packages as missing dependencies add to the "apt-get install" line.
so now it would look like:
Code:
sudo apt-get install xbian-update xbian-package-config-shell xbian-package-initramfs-tools xbian-package-xbmc-scripts libhal-storage1 libhal1 xbian-package-config-xbmc xbian-package-kernel xbian-package-lirc xbian-package-xbmc xbian-package-libtag xbian-package-shairplay xbian-package-cec libmad0 unattended-upgrades xbian-package-vnc-server autofs

Please read rules and do a search before you post! . FAQs . How to post log file? . Looking for answers? Please start here
Find all posts by this user
Quote this message in a reply
19th Apr, 2014, 05:24 PM
Post: #81
RE: Beta2 [UPGRADE INSTRUCTIONS ONLY!]
Thanks.
Takes me a bit further.

With your apt-get cmd, I got this message :

Terminal

xbian-package-cec : Depends: inetutils-ping but it is not going to be installed
xbian-package-config-shell : Depends: xbian-package-xbianhome but it is not going to be installed
xbian-package-initramfs-tools : Depends: xbian-package-splash (>= 2.0.2) but 1.0.1-4 is to be installed
xbian-package-vnc-server : Depends: libvncserver0 but it is not going to be installed
Depends: libp11-kit-dev but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

So I've added them again to the apt-get cmd you gave me to make this one :
Code:
sudo apt-get install xbian-update xbian-package-config-shell xbian-package-initramfs-tools xbian-package-xbmc-scripts libhal-storage1 libhal1 xbian-package-config-xbmc xbian-package-kernel xbian-package-lirc xbian-package-xbmc xbian-package-libtag xbian-package-shairplay xbian-package-cec libmad0 unattended-upgrades xbian-package-vnc-server inetutils-ping xbian-package-xbianhome xbian-package-splash libvncserver0 libp11-kit-dev autofs

But it gives me this error :
Terminal
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
inetutils-ping : Conflicts: ping
iputils-ping : Conflicts: ping
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
I've had a look in the xbian-update.list just in case, but there is no ping (nor inetutils-ping nor iputils-ping).
Find all posts by this user
Quote this message in a reply
23rd Apr, 2014, 02:21 AM
Post: #82
RE: Beta2 [UPGRADE INSTRUCTIONS ONLY!]
Any idea about that conflicting ping error?
Find all posts by this user
Quote this message in a reply
27th May, 2014, 03:44 PM
Post: #83
RE: Beta2 [UPGRADE INSTRUCTIONS ONLY!]
yes, I will remove the packages from dependencies, then
Code:
apt-get clean
apt-get update

should refresh the "conditions" and should allow you to install. in few minutes.

just removed inetutils-ping from cec package.

I will check other packages for presence of iputils-ping

Please read rules and do a search before you post! . FAQs . How to post log file? . Looking for answers? Please start here
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump: